Archer A7 v5 not able to revert to factory firmware using tftp

No it’s through wired

Did you check the region of your device?

If it's EU, the stock firmware files linked to in the wiki will not work, since they are US.

I have us version.

Are you using an unmanaged switch between the router and the computer?

Is the computer's firewall temporarily disabled?

1 Like

I followed your guide, and tried that network switch thing, but it is still not successfully.

I can see on tfp windows that file is successfully transferred to the router, but it never flashes on the router.

I researched for a while trying to solve this. I had other tp-links routers, and managed to go between openwrt, and stock easily through tftp.

There is a revert stock firmware file that can be downloaded through the DD-WRT site.

The file does not need to be renamed...


I attempted that, and still reboots right into openwrt

TpLink A7v5 unable to revert to stock firmware - Installing and Using OpenWrt - OpenWrt Forum

same issues as this thread

Sounds like the next step is a serial recovery.

make sure the cable is support 1gb i have c7 and the problem with tftpd was that cable only uses 100mbps not 1000mbps

and tftpd32 works for me tftpd64 doesn't work for me for some reason

100 Mbps Full Duplex and TFTP64D work for my C7 v2.

c7 version 5 doesn't work with 100 mbps

I've seen it work for other C7 v5's, so there is something different for yours.

maybe i bought it from egypt

Got back to stock


  1. First Flash DD-WRT TP Link Archer A7v5 - DD-WRT Wiki using the factory-to-ddwrt.bin by using tftp.
  2. After it flashes, and reboots into dd-wrt download this recovery stock file from the that wiki page, and do the tftp recovery method again Download this recovery firmware file
  3. Once it flashes you end up on stock router web page at you can either update the firmware from firmware upgrade page, or you can another tftp recovery, and from this page Download for Archer A7 | TP-Link

Always use ArcherC7v5_tp_recovery.bin for the file name.


got back to stock using a weird method, but it worked.

Thank you @Terabits I too suffered this fate with my pair of TP Link A7v5's. Once I get a hold of them in a week or so, I will give this a try and reset them to stock using your approach. Thank you for your time in figuring this out.

Just wanted to provide an update.
Both my routers are dead. Just picked them up from my parents home, got home and was about to flash.
When I turn them on, the only thing that comes on is the Power and the WPS lights, no further progress/movement (no other lights flashing, etc). Looks like whatever happened during the earlier flashes weeks ago has permanently bricked the routers. RIP.

Thanks a lot mate for saving my A7. The whole process worked great.

Just a suggestion that in Step-1 your need to reiterate that it is DD-WRT image that needs to be flashed. Same in step-2 for the stock file.

The steps should be added to OpenWRT and DDWRT wikis for the router so others may benefit. Specially since this a problem specific to A7 now.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.