Archer A6v2 WAN not working

I installed OpenWRT on a Archer A6 v2, but the WAN ip does not get automatically detected. According to an older thread, the eth0 and eth1 are switched up, but the fix provided (modifying the /etc/config/nerwork file) does not work for version 2023.05.0.

Please show the output of ubus call system board
Remove all your fixes/modifications or reset to defaults. Disconnect WAN, reboot.
Run logread -f then connect WAN and show the output produced by logread.

Please show the content of your /etc/config/network and /etc/board.json

/etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd20:dd61:9824::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'
/etc/board.json
{
        "model": {
                "id": "tplink,archer-c6-v2",
                "name": "TP-Link Archer C6 v2 (EU/RU/JP)"
        },
        "led": {
                "lan": {
                        "name": "LAN",
                        "sysfs": "green:lan",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x3c",
                        "speed_mask": ""
                },
                "wan": {
                        "name": "WAN",
                        "sysfs": "green:wan",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x02",
                        "speed_mask": ""
                }
        },
        "switch": {
                "switch0": {
                        "enable": true,
                        "reset": true,
                        "ports": [
                                {
                                        "num": 0,
                                        "device": "eth0",
                                        "need_tag": false,
                                        "want_untag": false
                                },
                                {
                                        "num": 2,
                                        "role": "lan",
                                        "index": 1
                                },
                                {
                                        "num": 3,
                                        "role": "lan",
                                        "index": 2
                                },
                                {
                                        "num": 4,
                                        "role": "lan",
                                        "index": 3
                                },
                                {
                                        "num": 5,
                                        "role": "lan",
                                        "index": 4
                                },
                                {
                                        "num": 1,
                                        "role": "wan"
                                }
                        ],
                        "roles": [
                                {
                                        "role": "lan",
                                        "ports": "2 3 4 5 0t",
                                        "device": "eth0.1"
                                },
                                {
                                        "role": "wan",
                                        "ports": "1 0t",
                                        "device": "eth0.2"
                                }
                        ]
                }
        },
        "network": {
                "lan": {
                        "device": "eth0.1",
                        "protocol": "static"
                },
                "wan": {
                        "device": "eth0.2",
                        "protocol": "dhcp"
                }
        }
}

I don't see anything obviously wrong with the configuration.
Unfortunately, I do not currently have a suitable device to experiment with.

That's a bummer. Anyways, thanks for your help.