Archer A6 v2.0 poor selection of 5Ghz Networks on scan (QCA9886)

Just installed OpenWrt 22.03.3 on Archer A6 v2.0 (US) Latest version, OpenWrt 22.03.3

The 2.4Ghz works normally - (Qualcomm Atheros QCA9560 802.11bgn) - picking up dozens of nearby APs

The 5GHz though - (Qualcomm Atheros QCA9886 802.11acn) oh boy - just seeing one or two very near APs when I'd expect dozens based on experience with similar routers in the same place.

Do I have a dud, or could it be the driver or something else? I tried it on the driver that comes with OpenWrt 22.03.3, and also updated the driver as recommended to the commerical driver - same range of APs available.

Are you connected/using the 5.4 GHz when attempting to scan?

1 Like

Thanks for the suggestion - I've tried it both ways, connected to an AP and not - doesn't seem to make much difference.

What does "not" mean?

Describe how you're connected.

'not' means all the possible wireless connections for the 5ghz radio are disabled.
'connected' means that there is a currently associated station.

Don't think this is my issue, but thank you.


OK. (BTW, I'm trying to ask how your wireless is setup - I haven't yet made a suggestion; nor communicated a possible issue identified.)

  • That's not what I'm asking: I'm asking how are you connected to the router. Since not 5.4 GHz, is it: A.) Ethernet, B.) 2.4 GHz or C.) serial?
  • Are you using the web GUI or CLI to perform a scan?

Also, can you post your /etc/config/wireless file.

Oh I see, I thought you were asking if the 5.4GHz was connected to another AP or client during the scan.
I've connected to the router using both Ethernet and 2.4Ghz and 5GHz connections and scanned - not by serial though.
web GUI for the scan - LuCi

I'll have a look for that file.

1 Like

here's that file -

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option cell_density '0'
        option htmode 'VHT20'
        option channel '153'
config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxxxxxxx'
        option encryption 'psk2'
        option key 'xxxxxxxx'
config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxxxxxxx'
        option encryption 'psk2'
        option key 'xxxxxxxx'

Try 80 MHz channel bandwidth
Try to manually choose a different channel, e.g. channel 40

Thanks, I tried a few HT and VHT modes, and also setting the channel to 40 and to auto. No difference for any of the options.

Maybe what you experience is to be expected. Found following statement in the initial commit to the device:

Wireless: 5GHz is known to have lower RSSI signal, it affects speed and range.

There is a superlong discussion on github about this device and even more discussion in the forum.
Check out Follow on conversation for TP-Link Archer A6 v2 5GHz improvements, including user support - #166 by humanOS

I am not going to read all that :smiley: have fun, if you want to dig deeper.

Last but not least, there also is a pull-request for Archer A6 EU/RU, so if you are not sure, if you actually REALLY have the US version, you could try that one too.

Thanks for this - look like the 'lower RSSI signal' might be the problem which I guess is not solvable. There's a few comments about how the 5ghz signal is weak.
It might be that the router i'm comparing it to just has particularly good 5ghz performance and my expectations were too high.