Arcadyan VGV7510KW22 (o2 Box 6431) DSL problem

Hello,
After a few days fiddling with my box I have managed to get the firmware and so far I have copied all the configuration from https://oldwiki.archive.openwrt.org/toh/arcadyan/vgv7510kw22#vdsl_firmware

to my surprise the connection is working (see attached) but under interfaces > wan no data transfer is shown and if I try visiting any site is not working. What am I missing? maybe a VLAN?

Thank you in advance

root@OpenWrt:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          Broadcom 192.85
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.7.9.5.1.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.5 (VDSL2 with down- and upstream vectoring)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 2949
Severely Errored Seconds (SES):           Near: 0 / Far: 33
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 200 / Far: 200
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.14 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 96.145 Mb/s / Up: 27.880 Mb/s
Line Attenuation (LATN):                  Down: 14.3 dB / Up: 14.4 dB
Signal Attenuation (SATN):                Down: 14.3 dB / Up: 14.2 dB
Noise Margin (SNR):                       Down: 6.1 dB / Up: 9.6 dB
Aggregate Transmit Power (ACTATP):        Down: 1.6 dB / Up: 12.8 dB
Max. Attainable Data Rate (ATTNDR):       Down: 102.486 Mb/s / Up: 29.956 Mb/s
Line Uptime Seconds:                      429
Line Uptime:                              7m 9s
root@OpenWrt:~# swconfig dev eth0 show
Global attributes:
        enable_vlan: 1
Port 0:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 2
        link: port:0 link:down
Port 1:        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:1 link:down
Port 2:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:2 link:down
Port 3:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:3 link:down
Port 4:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:4 link:down
Port 5:
        uvr: 0
        vsr: 0
        vinr: 0
        tvm: 0
        pvid: 1
        link: port:5 link:down
Port 6:
        uvr: 0
        vsr: 0
        vinr: 0VLAN 2:
        vid: 2
        enable: 1
        ports: 0 6t
/etc/config/network
config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '0'
        option firmware '/lib/firmware/vr9-B-dsl.bin'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'pppoe'
        option username 'MYUSER'
        option password 'MYPASWORD'
        option ifname 'ptm0.7'
        option ipv6 '0'

New URL: https://openwrt.org/toh/arcadyan/vgv7510kw22#vdsl_firmware

The old page is for archival purposes only and does not receive updates any more.

The DSL device should call dsl0 On the current openwrt. And vlan normaly dsl0.7 vlan 7

Thanks, a big newbie here

Do you mean this?:

config dsl 'dsl0'            <<<<<<<<
        option annex 'b'
        option tone 'bv'
        option xfer_mode 'dsl'       <<<<<<<<
        option line_mode 'vdsl'
        option ds_snr_offset '0'
        option firmware '/lib/firmware/vr9-B-dsl.bin'
config interface 'wan'
        option proto 'pppoe'
        option username 'MYUSER'
        option password 'MYPASWORD'
        option ifname 'dsl0.7'        <<<<<<<<<<
        option ipv6 '0'

VLAN 7:
        vid: 2
        enable: 1
        ports: 0 6t             #port 6 is WAN port 0 is cpu

the only difference that I found in the new wiki is "ds_snr_offset" (this config is actually for my provider, O2):

config dsl 'dsl'
	option xfer_mode 'ptm'
	option annex 'b'
	option tone 'bv'
	option line_mode 'vdsl'
	option firmware '/lib/firmware/vr9-B-dsl.bin'
        option ds_snr_offset '60'    <<<<<<<<<<<<<<

Thank you for your help

now I know what you mean:

config interface 'wan'
        option proto 'pppoe'
        option username 'MYUSER'
        option password 'MYPASWORD'
        option ifname 'dsl0'        <<<<<<<<<<
        option ipv6 '0'

I tried but it did not work, I get in the wan interface "unknown error (USER_REQUEST)"

while /etc/init.d/dsl_control status shows me that I am Sync

While further researching I found the following topic:

with following configuration:

# cat /etc/config/firewall
....
config rule
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option dest_port '547'
	option name 'Allow DHCPv6 (546-to-547)'
	option family 'ipv6'
	option src_port '546'
 
config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option name 'Allow DHCPv6 (547-to-546)'
        option family 'ipv6'
        option src_port '547'

but so far nothing has improved

Sorry for my late answer but i have no idea the think that i can do is to send my working config
But note i have no VLAN 7.

...
config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option tone 'av'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config interface 'wan_dsl'
        option ifname 'dsl0'
        option proto 'pppoe'
        option username 'USER'
        option password 'PASSWORD'
        option ipv6 '1'
...

I remember strange problems with sync loss when i have to much dsl config parameters.

I got a 6431 box and installed OpenWRT 19.07.2 on it (was really easy).
To get DSL to work, all I needed to do manually in /etc/config/network was to change option ifname 'dsl0' to option ifname 'dsl0.7' for the wan interface (because my ISP expects PPPoE frames to be tagged with VLAN 7, and LuCI does not seem to offer any option to create such sub-interface).
I'm using the DSL driver from the latest AVM Fritzbox 7490 stable release.
I'm getting a 17a profile connection with roughly 110 Mb/s down/ 38 Mb/s up.
VDSL syncing takes about 4 minutes, irrespective of the settings I use (an AVM Fritzbox 7530 on the same line takes about 2 minutes to sync and achieves an uplink of about 45 Mb/s; however older Fritzbox and other DSL routers also yield lower uplink sync rates).

I deleted the default VLAN 2 (which included the WAN port and the CPU), as I understand it would only be used when I use ethernet (or pppoe) directly on the WAN port. My understanding is that the WAN port on this device is a dual-use ethernet and DSL port. Right?

So that device looks pretty nice; I'll now have to turn to getting VoIP running on it using the telephony ports.