AR9344 on 2.4Ghz SSID vanishes (dis/re)appears on several clients

Having two different devices with same AR9344 soc using 2.4GHz wifi hardware I noticed on OpenWrt 21.0.2.1 and or 21.0.2.2 that wifi works fine on these devices for already connected clients, but new (re)connecting clients (laptop/phone/etc) may not detect the SSID of the Router for almost minute(s)... although the already connected devices on wifi are working fine for months.

Hardware AR9280/AR9582?:

Configuration is plain simple out of the box with channel 1,6,11 on 20MHz with only WPA2 PSK CCMP country code netherlands. No other specific wifi parameters. The SSID name just lowercase letters no symbols/spaces.

#WDR3600
cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option country 'NL'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'somessidnamex'
	option encryption 'psk2+ccmp'
	option key 'passwordpasswordpw'
				

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'sae'
	option key 'passwordpasswordpsword'
	option ssid 'somessidnamey-5G'

#UAP-PRO
cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/ahb/18100000.wmac'
	option country 'NL'
	option cell_density '0'
	option htmode 'HT20'
	option channel '36'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'somessidy-5G'
	option key 'passwordpasswrd!'
	option ieee80211w '2'
	option encryption 'sae'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT20'
	option txpower '20'
	option country 'NL'
	option cell_density '0'
	option channel '6'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'somessidx'
	option encryption 'psk2+ccmp'
	option key 'passwordpasswrd!'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'somessidx12'
	option encryption 'psk2+ccmp'
	option key 'passwordpwrd'
	option network 'ifbrcpu12'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'somessid114'
	option encryption 'psk2+ccmp'
	option key 'passwordpwrd'
	option network 'ifbrcpu114'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'somessid16'
	option encryption 'psk2+ccmp'
	option key 'passwordpwrd'
	option network 'ibrcpu16'

The unifi_ap_pro is active in an area where there might be congestion in a flat apartment with 10-15 other AP's although SNR is ~50-70dB difference to other AP's on that same band. The tl-wdr3600_v1 however is located in a total isolated country side area with maybe 2 or 3 other AP's located ~15/20 meters away.

Contrary the 5GHz wifi interfaces on these devices are always available during SSID scan/discovery on a client device...

Anyone with similar experiance of SSID not showing up on their Laptop/Smartphone/etc?

I remember in the past that something with "Beacon interval" could affect this behaviour in the good old Linksys WRT54GL days...

While 21.02.2 ran for 60days uptime and kept showing this 2,4GHz ssid (re)appear issue on Ubiquite Unifi AP Pro, it seems that 21.02.3 is alot of faster for clients to detect and connect. Cannot say its fixed yet and also have to test TP-link but it certainly different!

It still seems that after almost 3 weeks the issue seems gone with 21.02.3.

Multiple times a day the daily driver laptop powering on/off and reconnecting with maybe once a period of 15seconds before it found the wifi, all the other countless time the wifi was up before reaching the desktop.

Also the TP-link is updated to 21.02.3 and did perform better directly after reboot however it has been only a few days for that device so we have to see.