AR5315u Wireless is not associated

After installing OpenWrt and configuring the device for my network, I can't use the wifi because it seems disabled. Any ssid I create and bridge to a vlan interface shows "Wireless is not associated".
Just realized that only the default wifi (OpenWrt, auto channel, etc) works. I suppose is something I misconfigured. Can someone give me a hand?

More info:

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
        option country 'ES'
        option channel '2'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option network 'TLN'
        option key '*************************************************'
        option ssid 'ssid1'
        option encryption 'psk2'

config wifi-iface 'wifinet1'
        option ssid 'ssid2'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option network 'IOT'
        option key '*************************************************+'

root@OpenWrt:~# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11g'
wireless.radio0.path='pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
wireless.radio0.country='ES'
wireless.radio0.channel='2'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.mode='ap'
wireless.default_radio0.network='TLN'
wireless.default_radio0.key='*************************************************'
wireless.default_radio0.ssid='ssid1'
wireless.default_radio0.encryption='psk2'
wireless.wifinet1=wifi-iface
wireless.wifinet1.ssid='ssid2'
wireless.wifinet1.encryption='psk2'
wireless.wifinet1.device='radio0'
wireless.wifinet1.mode='ap'
wireless.wifinet1.network='IOT'
wireless.wifinet1.key='*************************************************'
root@OpenWrt:~# iw reg get
global
country ES: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

root@OpenWrt:~# iw wlan0 scan
command failed: Network is down (-127)
root@OpenWrt:~# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2285 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 1:
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
        interface combinations are not supported
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Supported extended features:
                * [ RRM ]: RRM
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
root@OpenWrt:~# iw dev
phy#0
        Interface wlan0
                ifindex 31
                wdev 0x10
                addr f8:8e:85:3a:52:b0
                type AP
                txpower 20.00 dBm

Edit: One thing I forgot to mention is that while it says that radio/device is disabled, and scan fails from ssh, I can push the scan button on the gui and it works, detecting all wifis around.

interface combinations are not supported

That means this hardware / driver combination can't run two APs at the same time.

Also make sure that the network you're trying to attach to ("TLN" or "IOT") exists. It is best to use lowercase for network names.

That's a real shame. I pretended to make a repeater with this device.
I thought the message referred to vlans. Thank you very much.

BTW do you know if connecting an external usb wifi radio will do?

If you already got one, it doesn't hurt to try it. Otherwise, better buy a router that supports your use case.