AR-5381u, how to configure 1 eth port of the switch as WAN input?

Hi there, first time OpenWrt user here, I am in the need of a secondary wireless router because the one provided by my ISP isn't cutting it anymore. It's a DOCSIS gateway that I can easily put in bridge mode and I have tested it with a proper router so I have ordered one already, but it's going to take a while until it arrives so I looked at what I had laying around and found a Comtrend AR-5381u, it's an DSL router but it seems to be supported by OpenWrt (to an extent, Broadcom chipset).

So, as per the instructions laid down in that page I downloaded and flashed the current stable build for it and I verified it's running too. I enabled the WiFi radio and that too seems to be working, I was able to connect to it via WiFi and access the LuCI interface just as I could via Ethernet.

The problem I'm facing is how to actually configure it to use one of the ports of the switch it has to act as the WAN intake which would be connected to the ISP provided device. For some reason I am unable to do it, even though there are configuration suggestions? in the same page for the device in the site.

Because going through LuCI seemed to be complicated (probably not, but there are just so many things to choose from when it comes to setting up the interfaces that I'm lost, my knowledge in the matter is limited), I decided to go through SSH and edit the /etc/config/network file directly as proposed in the site and reboot the device.

Right now this is the content of that file:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd19:f9a1:df3e::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 8t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '3 8t'

And not only do I not get Internet access from the device itself when connected to the ISP gateway but also LuCI seems to be angry about the VLAN config:

Any help would be appreciated if there's something obvious that needs to be changed, or a better way to accomplish what I'd like to (via uci commands and uci commit maybe?). For now I'm alternating the ISP gateway between bridge mode to try the configs and the regular way to get access to the Internet. Maybe I should think about allowing access to the web interface or the SSH server from the WAN port of the Comtrend router to make my life easier while it's being configured... but I have no idea on how to for now, still didn't read about that, I'm sure that's explained somewhere else already.

Anyway, thanks for reading me and your time!