APU 4 and Sierra Wireless MC7455 in QMI-mode

Hi,

I have been trying using a Sierra Wireless MC7455 LTE-modem for a while on an APU 4. The last couple of days I have had some sucess, but still it doesn't work as I want :thinking:

I am using the latest version (OpenWRT 19.07.2) and all packages are updated.

I have installed the following packages: uqmi, luci-proto-qmi

When I run uqmi -d /dev/cdc-wdm0 --get-serving-system it says im "registered", but when I run for example "ifconfig" there is no interface.

Then I found out if i run "udhcpc -i wwan0" I get a public IP-adress and I can for example ping internet host with the interface "ping -I wwan0 1.1.1.1" but the interface only seems to work for a while and I cant see any traffic on it in Luci/WebGUI ?

Okay, I have really spent some time the last two weeks on my issue :thinking:

After a while I tried with an USB-adapter for the modem and then it worked just fine directly :roll_eyes: So I realised that all my hardware was working - was just something strange when the modem was directly in the mPCIe slot and probably something was initialized wrong... This is my final solution after lots of trying :nerd_face:

I made a SD-card with the following image openwrt-19.07.2-x86-64-combined-ext4.img.gz
I updated my hardware APU4C4 with BIOS 4.11.0.5 and updated the modem Sierra Wireless MC7455 firmware to FW 02.33.03.00

I run the following command

opkg update
opkg install qmi-utils kmod-usb-net-qmi-wwan
reboot

nano /etc/config/network

And added the following lines at the bottom
"
config interface 'wwan0'
option ifname 'wwan0'
option device '/dev/cdc-wdm0'
option proto 'qmi'
option apn 'your.apn'

config interface 'wwan1'
option ifname 'wwan1'
option device '/dev/cdc-wdm1'
option proto 'qmi'
option apn 'your.apn'

"
saved the file by pressing Ctrl - X folowed by Y and ENTER

/etc/init.d/network restart

If you need to control that the sim card is read run the following command (not necessary)

qmicli -d /dev/cdc-wdm0 -p --dms-uim-get-state (Or if wwan1 is the interface change to ...wdm1)

The answer should be:
"[/dev/cdc-wdm0] UIM state retrieved:
State: 'initialization-completed'"

This was the error i had:

qmicli --device=/dev/cdc-wdm0 --get-expected-data-format
qmicli --device=/dev/cdc-wdm1 --get-expected-data-format

I did get the answer 802-3

Then run the following commands

ifdown wwan0; ifdown wwan1
echo Y > /sys/class/net/wwan0/qmi/raw_ip ;echo Y > /sys/class/net/wwan1/qmi/raw_ip
ifup wwan0; ifup wwan1
udhcpc -i wwan0

Or (if wwan1 is the interface)

udhcpc -i wwan1

The answer shall be
"root@OpenWrt:/dev# udhcpc -i wwan0
udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: sending select for 100.66.87.229
udhcpc: lease of 100.66.87.229 obtained, lease time 7200
udhcpc: ifconfig wwan0 100.66.87.229 netmask 255.255.255.252 broadcast +
udhcpc: setting default routers: 100.66.87.230"

Then install the luci protocol

opkg install luci-proto-qmi
/etc/init.d/network restart

The interfaces wwan0 and wwan1 has to be added to the WAN-zone

nano /etc/config/firewall

The following part
"config zone
option name 'wan'"

Should look like this at bottom
option network 'wan wan6 wwan0 wwan1'

/etc/init.d/firewall restart

I wish you all luck - hopefully I saved you some time :wink:

Hello, I have a similar issue , any idea ? Thanks

how did you upgrade the MC firmware and where did you find it? i have 2 MC7430 modem

Hi :sunglasses:

If I remember correct I followed “Manual Flashing Procedure (Ubuntu Linux 18.04)” from this page:

I was using Linuxmint at the moment🐧