Apple/AirPlay Protocol not working

Deal with that later. First thing is to understand if the problem persists when you are using the regular methods of connecting to WiFi.

Ok I’ll give it a try tomorrow. Getting a little late here (CA) and I need to wake up early tomorrow. Will remove that info and test in the morning.

@psherman ok I cleared out the items you requested, connected one of my Apple TVs and my iPhone and AirPlay does work. However I am on different SSIDs. Apple TV is connected to SSID1 (5GHz radio) and my iPhone is connected to SSID2 (2.4GHz radio).

root@R7800:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT160'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'vlan1'
	option mode 'ap'
	option ssid 'SSID1'
	option encryption 'psk2'
	option key '******'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option channel '2'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'vlan1'
	option mode 'ap'
	option ssid 'SSID2'
	option encryption 'psk2'
	option key '*****'

Good. That tells us that the password based VLAN is at the heart of the issue here. Yet to be determined exactly why it's happening, but we know that removing it fixes the issue.

You do not need to be connected to the same SSID, but you do need to be on the same L2 network. In this case, both SSIDs are connected to VLAN 1.

So, if you re-enable the password-based VLAN approach, you need to make sure that both devices are using the same password so that they are associated with the same VLAN. Further, the whole point of the single SSID + multiple password approach is to use just one SSID, so both 2.4G and 5G radios should have the same SSID.

Yes both SSIDs are on VLAN1

Both devices were on the same VLAN, ie using the same password but on different SSIDs. The point in me having the radios segregated is due to having my streaming devices on the 5GHz pipe and the browsing devices on the 2.4GHz pipe. I would prefer to have my streaming devices hardwired but I haven't ran any lines yet. So the 5GHz radio having a "larger pipe" for data to flow will suffice for now.

@psherman so I just added the info back that you had me remove and added my Apple TV and iPhone to the (2) different SSIDs on VLAN20 and same issue. I thought it was the 5GHz radios so I moved both devices to the 2.4GHz radio but connected to VLAN20, same issue.

So the only time AirPlay will work is when the devices are connected to VLAN1. However this is not the case when I have the devices connected to my TP-Link AP. Seems like the DPSK configuration on the R7800 is incorrect somewhere.

Have you checked both devices to make sure they are indeed getting addresses on the same subnet?

Yes, I checked all that. Everything looks good. Strange that the issue is only when connecting to a VLAN other than VLAN1.

@psherman @trendy any other ideas? I’ve thru the the config and just can’t figure out why this happens when connected to the WLAN VLAN (VLAN20).

We could start capturing packets in and out of the wireless interfaces, but I'd suggest to move them to the same SSID and carry on.

Hi @trendy, thanks for the reply.

Having on the same SSID doesn't seem to be the issue, as I currently have both my iPhone and Apple TV on the same SSID at the time of this writing. The issue seems to be the VLAN.

When I have both devices using the VLAN1 password (LAN), I can AirPlay just fine. When I use the VLAN20 password (WLAN), AirPlay stops working. This is regardless of when on the 2.4GHz or 5GHz radios. So it seems it's something with the VLAN20 configuration that it s causing the issue, however I can't pinpoint what it is. Again tho, AirPlay works flawlessly when devices are connect to my TP-Link APs.

I would like to continue using this R7800 if possible since the radios are stronger than the TP-Link APs. However at this point, I may need to ditch the R7800 and get another TP-Link AP.

Do you maybe have another suggestion on your to configure the R7800 so it can work properly?

Try to disconnect the 7800 from the uplink pfsense and try again with these two devices. Make sure the DHCP lease is long enough so that it doesn't expire. This will verify if the pfsense is doing some proxyarp on the packets

Hi @trendy, I know it’s not the pfSense since everything works fine on the TP-Link APs and the devices are on the same VLAN, same SSIDs, and different SSIDs (still the same VLAN). However I did test it regardless and still the same issue.

It has to be something with the configuration on the R7800. However I don’t know what it could be. If you were to configure this device for my use, how would you do it? Any configuration you can provide would be helpful and I can’t eat on the device.

Thanks again for your help, this is something new to me and I’m trying to learn as best as possible.

Post once again the following:

uci export network; uci export wireless

@trendy here you go. All IP/WifI info has been changed to show generic configuration.

root@R7800:~# uci export network
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd60:c227:0684::/48'
	option packet_steering '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '20'
	option ports '4t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '21'
	option ports '4t 6t'

config device
	option type 'bridge'
	option name 'br-vlan1'
	list ports 'eth1.1'

config device
	option type 'bridge'
	option name 'br-vlan20'
	list ports 'eth1.20'

config device
	option type 'bridge'
	option name 'br-vlan21'
	list ports 'eth1.21'

config interface 'vlan1'
	option device 'br-vlan1'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'vlan20'
	option proto 'none'
	option device 'br-vlan20'

config interface 'vlan21'
	option proto 'none'
	option device 'br-vlan21'
root@R7800:~# uci export wireless
package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT160'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'vlan1'
	option mode 'ap'
	option ssid 'SSID1'
	option encryption 'psk2'
	option key 'password1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option channel '2'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'vlan1'
	option mode 'ap'
	option ssid 'SSID2'
	option encryption 'psk2'
	option key 'password1'

config wifi-vlan
	option name 'vl20'
	option network 'vlan20'
	option vid '20'

config wifi-station
	option key 'password2'
	option vid '20'

config wifi-vlan
	option name 'vl21'
	option network 'vlan21'
	option vid '21'

config wifi-station
	option key 'password3'
	option vid '21'

Delete this, we told you before.

Add this:

config wifi-iface 'default_radio5'
	option device 'radio1'
	option network 'vlan21'
	option mode 'ap'
	option ssid 'SSID1'
	option encryption 'psk2'
	option key 'password1'

config wifi-iface 'default_radio2'
	option device 'radio0'
	option network 'vlan21'
	option mode 'ap'
	option ssid 'SSID3'
	option encryption 'psk2'
	option key 'password1'

config wifi-iface 'default_radio3'
	option device 'radio1'
	option network 'vlan20'
	option mode 'ap'
	option ssid 'SSID3'
	option encryption 'psk2'
	option key 'password1'

config wifi-iface 'default_radio4'
	option device 'radio0'
	option network 'vlan20'
	option mode 'ap'
	option ssid 'SSID4'
	option encryption 'psk2'
	option key 'password1'

So you're just saying to create the radios for each network, correct?

Oh wait, I see what you're saying to do. Ok I'll Mae tat config and test when I get home.

Hi @trendy. I made the changes and it looks like everything is working as needed so far! Thanks for the help :pray:

One more question....When looking at the GUI interface (I use it just for reference), I see the different radios. However I am unable to tell which radio is for which VLAN. IS there any way to be able to add some type of description to show which VLAN the radio is associated to?