Hi guys,
I have some new ESP wireless device that fail to connect to my AP with psk mismatch error:

Tue Jan 1 23:03:21 2019 daemon.notice hostapd: wlan0: AP-STA-POSSIBLE-PSK-MISMATCH dc:4f:22:xx..

I tried a lot of configurations without success, do you have idea how to fix this problem?

My wireless config file is the follow:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option country 'IT'
	option distance '12'
	option legacy_rates '1'
	option channel '11'
	option htmode 'HT20'
	option txpower '17'

config wifi-iface
	option device 'radio0'
	option key 'xxx'
	option mode 'ap'
	option ssid 'spw2'
	option network 'lan'
	option disassoc_low_ack '0'
	option short_preamble '0'
	option skip_inactivity_poll '1'
	option encryption 'psk2+ccmp'

Thanks a lot,

Try changing that to

option encryption 'psk2'

If that doesnt try the original wpa encryption

option encryption ‘psk’

Thanks Sparks,
i tried all the possible configurations with psk psk2 and psk-mixed unsuccesfully :frowning:
Is there a way to have more verbose log?
Thanks a lot,

What router do you own? ESP devices are notorious to have troubles with some devices (or the other way around).

1 Like

same problem here on a AR9344 using the default MAC80211 802.11bgn on a TP-Link TL-WDR3600 v1
Any news on this?, I have two other routers same model, no problems so far.