AP mode, can not access devices associated to the AP

HI,

This is my network topology:
xiaomir3p main route, dhcp, wan to internet
dir882 ap, disabled dhcp/firewall/dnsmasq, lan connect to xiaomir3p lan

I want to make dir882 to be a wireless ap or wireless switch. This means get dhcp from xiaomir3p and should access all ip address from both the device.

For why I need an openwrt device is because i need 802.11r and this works ok.

The problem is:

Devices connected to xiaomir3p (wire or wireless) can not be PINGing from devices connected to dir882.
In another way to say, device AA connected to dir882, device BB connected to xiaomir3p.
AA ping BB lost, but BB ping AA ok. AA ping dir882, xiaomir3p and internet ok.
BB ping dir882, xiaomir3p and internet ok.

Sometimes (maybe after reboot 1 hour) it works fine and most times not.

I'm not sure whether this is a arp problem or route problem. But i'm sure this is not about wired or wireless. and logread on dir882 and xiaomir3p shows nothing wrong.

There is some configs of dir882:

root@DIR882:~# cat /overlay/upper/etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdbe:41d9:d484::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'dhcp'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option ifname 'eth0 lan1 lan2 lan3 lan4'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

config alias
        option interface 'lan'
        option proto 'static'
        option ipaddr '10.0.0.5'
        option netmask '255.255.255.0'
		
root@DIR882:~# ifconfig 
br-lan    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          inet addr:192.168.1.30  Bcast:192.168.1.255  Mask:255.255.255.0
eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
lan1      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:59996 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18964 errors:0 dropped:0 overruns:0 carrier:0
lan2      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:711 errors:0 dropped:0 overruns:0 frame:0
          TX packets:523 errors:0 dropped:0 overruns:0 carrier:0
wan       Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
wlan0     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18399 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35523 errors:0 dropped:0 overruns:0 carrier:0
wlan1     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:941 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2652 errors:0 dropped:0 overruns:0 carrier:0
		
root@DIR882:~# ip ro
default via 192.168.1.1 dev br-lan  src 192.168.1.30 
10.0.0.0/24 dev br-lan scope link  src 10.0.0.5 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.30 

root@DIR882:~# traceroute IP-ADDR-OF-BB
traceroute to 192.168.1.xx (192.168.1.xx), 30 hops max, 38 byte packets
 1  DIR882-br-lan.lan (192.168.1.30)  3077.869 ms !H  3070.128 ms !H  3071.144 ms !H

root@DIR882:~# traceroute IP-ADDR-OF-AA
traceroute to 192.168.1.xx (192.168.1.xx), 30 hops max, 38 byte packets
 1  AA.lan (192.168.1.xx)  9.403 ms  1.996 ms  1.726 ms

Great thanks for any prompt.

  1. From LAN interface remove:
  1. Remove wan and wan6 interfaces altogether.
  2. Verify with arp that you have a valid entry for the device you are trying to access.

Thanks for reply. It removed this two lines and wan wan6. I need days to verify. luci will seams remove gateway automaticly. I don't know why gateway is not need for lan. Is this makes lan to be a real layer-2 switch?

update:

I use tcpdump on xiaomir3p, dir882 boardcast a arp, but no response. Is this the root case of the problem?

Like this: https://bugs.openwrt.org/index.php?do=details&task_id=714&order=category&sort=asc

I found it may be a arp problem. If a device connect to xiaomir3p (main router), and here is no arp line in the dir882 (ap). How to solve this?

I use arp-scan test on dir882. If a device scan no response, it can not be connected and not exists in arp table.

but if a device connected to dir882 it may not exists in arp table, but it always can be connected.

xiaomir3p has all arp lines in the whole network.

does bridge fdb on the router show the MAC addresses from dir882?

thanks to remind this. this problem is occasionally. i see in a device, there is an arp line marked 'incomplete'. i will follow and update the problem.