AP mesh routing not working with IPv6

I have a PPPoE connection with IPv4 and IPv6 with my ISP. I have IPv6 working perfectly on my main router.

I've a mesh network, and the clients of the APs are getting IPv6 adresses too. So it seems DHCPv6 is working without problem. The problem is that routing seems not be working from my APs. Sorry if my vocabulary is not good enough, I'm starting learning about IPv6.

If I try to do a ping -6 www.google.com it works perfectly from the main router, but from the AP or from any client connected to the AP I get:

root@router-despacho:~# ping -6 www.google.com
PING www.google.com (2a00:1450:4003:802::2004): 56 data bytes
ping: sendto: Network unreachable

under IPv4, this usually happens if there is not a default gateway configured, so I tried to assign one to the br-lan interface, that is the one associated to the mesh, but I don't know if I did this right:

option ip6addr 'fd94:xxxx:xxxx:10::2/128'
option ip6gw 'fd94:xxxx:xxxx:10::1'  # This is internal IPv6 address of the main router

the result is that it didn't work neither.

Some idea? Thanks in advance!

I've changed the ip6addr from fd94:xxxx:xxxx:10::2/128 to fd94:xxxx:xxxx:10::2/60 and now the ping to the main router works. I don't know exactly what is the correct prefix length, so maybe is wrong. I tested with fd94:xxxx:xxxx:10::2/64 with the same result. But the ping to external address now keeps waiting without answer:

root@router-despacho:~# ping -6 www.google.com
PING www.google.com (2a00:1450:4003:807::2004): 56 data bytes

More info: my Windows computers connected to the AP work with IPv6. So when the router assigns the IPs and gateways, it works. Is only the AP itself that has static address, as expected, that don't work.

These are ULA address. Unique local address. Or in IPv4 speak: private addresses.
As I doubt you want to have NAT for IPv6... Just set on your br-lan on the AP DHCP and dhcpv6. You might need a lan6 interface...

1 Like

This is because on the remote routers (those bridged into the mesh instead of directly connected to the Internet), br-lan doesn't pick up a GUA IPv6 IP, so a remote router kernel can't originate IPv6 traffic internally.

This can be remedied by making lan dual stack in these routers similarly to how wan is dual stack in the main router. Add a section:

config interface 'lan6'
    option device '@lan'
    option proto 'dhcpv6'
    option reqprefix 'no'

A dumb AP router doesn't actually route (as everything is bridged) so they don't need a prefix, and should not request one to avoid taking up all the prefixes available from the main router.

Thanks to both for the replies! I added the @mk24 suggestion and it worked. The interface takes a lot of IPv6 addresses, so I'm sure I can be configured better, but I need to study and understand IPv6 a lot more.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.