AP-105 v IAP-105 plus install OpenWrt


I have been given a few AP-105 and was trying to install OpenWrt on one of them.

I maybe completely read the installing prosses wrong and I may have bricked this unit. (no biggie)

Using windows, I have wired a CH341a to the MX25L12845E (still attached to the board) and took a complete dump. (verified too)

Opened up a copy of the dump and the u-boot and copied the code from the u-boot and made a custom boot image.

Uploaded the boot image and putty has not output. uploaded the original dump and still the same. So guessing its dead.

Did I read the instructions seem correct or did I fail straight away?

Would it not being a IAP-105 be the issue or are both the IAP/AP-105 supported


Did you see this:

It should be possible to install without replacing bootloader. Try that on one of your other units.
It may be necessary to unsolder the flash chip to get a good write. With OpenWrt running you can read the bootloader out of an unmodified unit.

Hi mk24,

Yer i saw this but to me this as an IAP-105. In the UK we have the IAP-105 that has GUI interface and can be a controller where the AP-105 is dumb and needs a controller to work.

I have tried the TFTP method but cant seem to get it do boot to TFTP

Does it look like the IAP-105 is the same hardware?

If the bootloader is the same the netget command should work to TFTP to RAM. Problems with TFTP booting are almost always on the server side, for example not disabling the machine's firewall.