Anyway to limit Wifi to channel 1-11? Some devices cannot receive ch 12 & over

Is it anyway to limit Wifi to channel 1-11? Some devices cannot receive ch 12 & over. I've tried setting various country codes. The auto ch still hopped to ch12 & over and some devices just disconnected cuz they couldn't connect to ch 12 & over. Now I just avoid using auto channel and just use fixed channel.
How about adding a "country code" such as ZZ and limit ch to 1-11? How to do it?

Are you running OpenWrt from OpenWrt, OEM firmware, or firmware from another source?

Unmodified, OpenWrt restricts to only the “legal” channels for the country code set and “auto” does nothing more than select the lowest-numbered channel from that list.

What you’re describing sounds like OEM firmware. Even though many OEMs base their firmware on OpenWrt, what they deliver is often very, very different than OpenWrt itself.


Country 00 "World" should only do 1-11 as it is the minimum set of channels available globally.

It is openwrt 18.06.4. ramips zbt-wg3526-16M-squashfs-sysupgrade.bin mt7621chip.

I've tried US, 00,DE. It gave non-ch12+ first but minutes later ... ch13. Never mind I just disable autochannel.

Something is seriously wrong if you selected US or World - and get Channels 12 and/or 13.

I surmise you never saved/applied your edits or didn't change the country setting on both bands.

Also, it seems that you're saying that the device auto switches to 12 - that's not OpenWrt behavior.

1 Like

Everytime I made changes, I clicked "save and apply".
B4 I used 5G wifi to connect and changed the config with luci web interface. I got undesirable results as mentioned in this topic.
This time I connected the router with LAN cable and did the same changes. For the past 12 hrs the router didn't give ch12+.
I used 5G wifi to connect and config regular consumer routers with stock f/w. I didn't have this issue. I guess openwrt performs some weather radar checking thus takes longer time to activate 5G wifi. ...and the session has expired. So changes might not be "saved and applied" though on the web interface it shows so. Well it's just my guess.