Anyone working on TP-Link EAP225?

I agree, manually editing .config is painful and doesn't always lead to the outcome you want, which is why I didn't. I git cloned your repo and did make menuconfig to get an initial config. By default it selected all software to be built as modules (packages) which was taking forever to build. So I started over by moving aside my .config, running make allnoconfig, and enabling just the three target options above in menuconfig.

It's a little weird that the OpenWRT build instructions lead you to build everything under the sun. At the very least, I wish it explained that all packages are enabled by default, and that you should do make defconfig or make allnoconfig to start from a minimal config. make allnoconfig combines make defconfig and make menuconfig into a single step.

Thanks for your work on this! Seems to be running great on my EAP225 v3.

Have people with V3 units been successful in going back to factory firmware? Which revisions of firmware?


I'm not aware of EAP225v3 units converted back, but I've converted back the EAP245v1 (and cross-flashed it with EAP225v3 FW).

To do create a sysupgrade image from a TP-Link firwmare, you will need to build the tplink-safeloader tool from the OpenWrt sources (or manually build a compatible file from a TP-Link firmware upgrade file).

@svanheule I've built your tplink_eap2x5 branch and attempted to install it on my EAP 225 Outdoor v1. I first ran cliclientd stopcs as you suggested in your released firmware image. When I attempted to install the (renamed) openwrt-ath79-generic-tplink_eap225-outdoor-v1-squashfs-factory.bin file I received back a "Bad file." error.

My unit is currently running 1.20.0 Build 20200604 Rel. 51951(5553) which is a Canadian firmware file available here:

Please let me know if there's anything I can do to help test the cause of this issue. I'm online on freenode as johnf and asked you about this release a few days ago if you prefer to chat, I'll update this thread with any interesting information.

Thanks for testing and providing some feedback :slight_smile:

Do you happen to be able to access the serial console of the device? The software often provides a bit more detail on what exactly makes an image bad, if you can read the log statements. If you don't feel like taking the risk to get serial access (requires some soldering skills), I've also thrown the library responsible for checking the image into Ghidra.

On the CA version it appears to specifically require the product-info partition to be present in the factory image too. That partition must also contain "region=CA". The (universal) EU/US images don't contain this product-info partition, which is what I used originally to design the OpenWrt factory images.

I've created a test branch you can use to build a CA image for the EAP225-Outdoor (select "EAP225-Outdoor v1-ca" in make menuconfig):

The patches aren't merge-quality yet, but this should be enough to test if the extra product-info partition does the trick. I've build-tested the image, and it looks fine to me.

I built from your wip branch and was able to install OpenWrt! I configured the wireless networks and I see them broadcast from the AP so things seem to be working well. I didn't actually connect to the networks as it's presently about 5 degrees c outside.

Thanks very much!

1 Like

@svanheule sir, can i request for a advance working build for eu/us eap-225 outdoor. And instructions to install and debrick, while we are waiting for official release. Thanks :laughing: completely newbie here. My objective is to get the dfs channels.

im completely noob to this. out of curiousity, i tried to flash the *factory.bin for eap225 outdoor.

it progress up to 100%, then after 10 minutes, i ran out of patient, i forcefully reboot the device because it is not responding.

now i think i have bricked the device. my pc doesnt recognize the device, even manually setting the ip to nor

any way that i could unbrick this please?

thank you.

After flashing, the device IP would have changed from whatever was assigned by the DHCP server, to The flashing page will try to reconnect to the old (DHCP) address, which doesn't exist anymore. 10 minutes should be enough to not have a brick though.

When you switch on the device, the led behaviour should be on > blink fast > blink slow > on. If this is the case, your device should be functioning.

You should be able to reach the device at, which means your pc should have an address that is different and in the same subnet, e.g. If you still can't reach it, you can try pressing the reset button during the 5s where the device led is blinking fast. This will bring up the failsafe mode (indicated by the led flashing continuously), and you should be able to reach the device at via SSH.

sir, thank you so much.

silly me, i didnt do all basic troubleshooting. i had to bring down the eap225 from the pole, to connect it directly to my pc using ip.

i have been tinkering with it now. looks refreshing to see lots of options.

i hope you continue developing for this device sir, so we could have official release.

anyway, in case i want to revert back to official firmware, how to do it properly? thank you.

i think i totally broke it this time. i tried to upload official firmware via web.

powering it on gives green>orange>green steady.

i tried tftp recovery tutorials online, but i think its not implimented for this device.

any suggested course of action before this goes to junk? thanks.

If you just uploaded an unmodified TP-Link firmware via the OpenWrt web interface, then yes, you just bricked your device. As described earlier in this thread you need to modify that image to be able to flash it from OpenWrt.

I suggest you go read the commit message for the EAP225-Outdoor to learn how to find the serial port for this device. Also have a look at the pictures posted here earlier.

Support for the EAP225-Outdoor and EAP225v3 have been merged :partying_face:


Thank you so much!

This topic was intended for adding support for this specific device.
Since official OpenWrt are available now, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 100-something postings, if he has a specific problem with wifi or general network configuration?

Therefore: Please open new topics for any open issues with this device.



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.