Anyone installed on TP-link TL-WDR3600? How?

I am hopelessly struggling with initial installation on TL-WDR3600. From their web-gui, installer rejects firmware due to too long filename. If and when I rename it, and shorten, it rejects it again, as wrong version.
Next idea to try was TFTP, which is way to hack. Anyway, grabbed ubuntu laptop, wired link, and tried to turn ip of ethernet port to, listen for what it asks for with tcpdump. Renamed the file. It still does not appear to install. There are no very clear instructions, and whole process is really frustrating.

Given the age of this device, most of us -including myself- have probably flashed OpenWrt on this device eight or nine years ago, memory fades accordingly…

In general, the tl-wdr3600 and the tl-wdr4300 are basically the same device (only difference the number of rx/ tx chains, the wireless speed), therefore it does make sense to read both device pages (the tl-wdr4300 is a bit more verbose):

Make sure to have a recent enough OEM firmware installed first, as push-button tftp recovery was only retrofitted to this device in later firmware revisions (updates).

Keep in mind that you'll need the factory image for the initial OpenWrt installation from the OEM firmware upgrade page or the bootloader based tftp installation.


When you try to start TFTP recovery, the WPS light should come on and be the only light on. If it does not do that, TFTP recovery won't be possible.

I ran into this issue as well. I previously ran OpenWRT on my TL-WDR3600, then went back to the then-latest stock US firmware (build 151104), and then I wanted to install OpwnWRT again.

The OpenWRT factory.bin images were rejected, even if I gave them a short enough filename, with a message about the version being wrong. I managed to get the TFTP recovery process to upload the file to the device:

mkdir -p srv/tftp
cp openwrt-21.02.1-ath79-generic-tplink_tl-wdr3600-v1-squashfs-factory.bin srv/tftp/wdr3600v1_tp_recovery.bin
sudo ip addr add dev eth0
sudo in.tftpd -vv -L -a -u $(whoami) -p -s srv/tftp/

It didn't log anything, but I could see the file going over in Wireshark. However, the device didn't actually flash the new firmware.

As noted on the DD-WRT forums, current TP-Link firmwares for this device contain a restriction that prevent them from flashing non-TP-Link firmwares. It appears to apply to both the web UI and the TFTP-based flashing methods. So flashing from stock firmware images that are too new won't work! I suspect the stock firmware also refuses most downgrades, but I haven't tested that.

The solution that worked for me was to use the stock formware web UI to flash the firmware that that poster on the DD-WRT forums claims to have gotten from TP-Link support, after complaining to them that they couldn't flash the custom firmware they wanted. Then the router came up and reported that it was running build 151102 of the TP-Link firmware, and was willing to flash the OpenWRT firmware (after I renamed the file to a sufficiently short name of factory.bin).

The special TP-Link "unlocking" firmware of dubious provenance was behind a registration wall over there; I observed the file, wdr3600v1_en_us_up_boot.bin, to have SHA256 checksum 41720922adb393063d292a3a75d49eb69f83d008e77f9a1e24d273f44ec8a41d, and IPFS hash QmX8QUNnDwjXrVUk6VR4KyCnPeP4HVxX53EEmRbngtqABW, or QmSXsVpZ2AMaykh4A9vSQ1is7EQfro9dJDHhbZTZ1KdHgs when wrapped with its name. I suppose it could be malicious, but it would be a neat trick to compromise the next firmware flashed, so I'm not particularly worried about that. I am worried about the file getting lost; though. Am I allowed to post it here somehow?

I'm going to see about getting wiki access so I can note on the device's page that flashing OpenWRT from current US firmware versions has been made deliberately difficult.