Anyone got their smart bulbs working with Linksys WRT32X?

I'm trying to connect a smart bulb to my Linksys WRT32X wifi using just the 2.4 band, disabled the 5gz, to no avail (Smart Life app). I'm on the latest build LEDE/OPENWRT Venom wrt32x released 2018-09-20.

Anyone got smart bulbs got theirs working on a WRT32X?

Your smart bulbs probably use an ESP chip. These are notorious for having throuble to connect to some routers. And the mwlwifi drivers for your device are notorious for having throuble with the ESP.

You can follow the development of this issue here: https://github.com/kaloz/mwlwifi/issues/278

On the other hand, your device has three radios: radio0 is 5GHz and cannot be used, radio1 is 2.4GHz and is affected, but radio2 can be configured as 2.4GHz and is not affected.

interesting... thanks for the info.

I can't see radio2 in my settings or is this just for the WRT3200ACM?

got it... just need to install kmod-mwifiex-sdio ...

What's your settings for radio2 eduperez?

Got it working in the end... I used radio2 (legacy mode, 2.4ghz band, auto channel) for the smart bulbs and working fine so far.

Hopefully the rest of the radios (5ghz and 2.4ghz) remain stable.

I am currently using the same setup myself: radio2 for an isolated network where all the IoT devices connect, and radio0 and radio1 for computers, phones, ... So far, everything is working great.

My smart bulbs somehow connected to the network themselves, and I did not have to do anything.