Anyone else experiencing DoH problems?

I have OpenWRT version 18.06.8 installed. I've had this version installed since it pretty much came out. I also have DNS Over HTTPS installed via my having installed https-dns-proxy and luci-app-https-dns-proxy.

Over the last few weeks, my internet service has started to have problems. My speeds seem to be slower and there is noticeable delay when I land on pages before a response occurs. today I finally got tired of it and started looking into it. What I've discovered is if I disable the DoH service the problem goes away. I was using Quad 9. I tried cloudflare and other "versions" of Quad 9 like Secured with ECS etc but none of this experimentation made a difference. If the DoH service is enabled, my internet becomes sluggish. If I disable it, it is A+ scoring on DSL Reports.

Interestingly, with the DoH enabled, testing from DSL Reports tells me the following: Browser could not reach ANY server! Perhaps an extension like NO SCRIPT is blocking things. error:7. Your browser failed to contact any of the candidate test servers that are known to be online.

I have run DSL Reports testing on my DoH enabled connection before and never had a problem. I have of course run all tests without any extensions installed and tried different computers.

Any ideas? Is my only option to disable the DoH service to fix the problems I'm having? This is weird cause this problem only developed in the last several weeks and didn't exist before then.

I did a fresh install of 19.07.3. This seems to have resolved the problem. Perhaps something got corrupted as I used it in my last install?

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.