AnyDesk does not work with default settings

I have been trying to get AnyDesk to work for quite some time without any luck, went as far as of enabling uPnP but still it won't function properly, it always ends up with the message: "The network connection was closed unexpectedly".

I tried on quite a few different machines, Windows 7, Windows 10, etc, with fresh installations as well, made no difference.

Any one here knows how to get AnyDesk to work with OpenWrt?



What port does it use?

To connect to the AnyDesk network port 80, 443 or 6568 is used. For standard listening port direct line connection is 7070 (TCP).

Btw, I'm trying to establish an outgoing connection to a remote computer behind a regular tplink router.

Also, if I replace my OpenWrt router with a basic ISP router it solves the issue which means the endpoint computer is accessible no problem and my issue seems to be with outgoing connections via OpenWRT only.

Thank you

We use anydesk on a regular basis as incoming and outgoing service and never had this problem. Maybe double check if server/client have the same anydesk version, since there auto update feature is still buggy.

Thank you, the LEDE/OpenWrt builds I've tried were definitely not the issue, it also won't work on Gargoyle or DDWrt, I suspect it's my ISP doing some with the traffic in this case.