Any way to monitor if 802.11r is working?

wpad-openssl (full featured)- should be good right?

Additionally I’m using on my r7800 the ath10k-firmware-qca9984-ct. Seems like the htt firmware offers BSS and 802.11r benefits according to the description, thoughts? (ath10k-firmware-qca9984-ct-full-htt)

Do I need to adjust the dawn defaults to my own network’s settings?


root@OpenWrt:~# cat /etc/config/dawn

config network
        option broadcast_ip '10.0.0.255'
        option broadcast_port '1025'
        option tcp_port '1026'
        option network_option '2'
        option shared_key 'Niiiiiiiiiiiiiik'
        option iv 'Niiiiiiiiiiiiiik'
        option use_symm_enc '1'
        option collision_domain '-1'
        option bandwidth '-1'

Good question about CT firmware. I normally run @hnyman's build on my R7800 with the ct driver but I switch the firmware only to the "old"/mainline ver 10.4-3.10-00047 as that works best for my wifi clients.

Does anyone happen to know if r,k,v are supported by the mainline firmware, or do we need to run CT? I'm not sure I understand if these are functions of the firmware, driver, hostapd, or all of them.

Edit: FWIW, I see some of these messages, not sure what they mean or if harmful:
Rekeying PTK for STA a0:56:f3:*** but driver can't safely do that.

Why not wolfssl?

Could u post your whole config?

OpenSSL because that is what was the default in hynman’s build. :sunglasses:

Dawn config (Changed the Dawn broadcast IP to my access point’s IP, does this matter, does the dawn shared key need to be something different?):


root@OpenWrt:~# cat /etc/config/dawn

config network
        option broadcast_port '1025'
        option tcp_port '1026'
        option network_option '2'
        option shared_key 'Niiiiiiiiiiiiiik'
        option iv 'Niiiiiiiiiiiiiik'
        option use_symm_enc '1'
        option collision_domain '-1'
        option bandwidth '-1'
        option broadcast_ip '192.168.1.3'

config ordering
        option sort_order 'cbfs'

config hostapd
        option hostapd_dir '/var/run/hostapd'

config times
        option update_client '10'
        option denied_req_threshold '30'
        option remove_client '15'
        option remove_probe '30'
        option remove_ap '460'
        option update_hostapd '10'
        option update_tcp_con '10'
        option update_chan_util '5'
        option update_beacon_reports '20'

config metric
        option ap_weight '0'
        option no_ht_support '0'
        option no_vht_support '0'
        option rssi '10'
        option low_rssi '-500'
        option freq '100'
        option chan_util '0'
        option max_chan_util '-500'
        option rssi_val '-60'
        option low_rssi_val '-80'
        option chan_util_val '140'
        option max_chan_util_val '170'
        option bandwidth_threshold '6'
        option use_station_count '1'
        option max_station_diff '1'
        option deny_auth_reason '1'
        option deny_assoc_reason '17'
        option use_driver_recog '1'
        option min_number_to_kick '3'
        option chan_util_avg_period '3'
        option set_hostapd_nr '1'
        option op_class '0'
        option duration '0'
        option mode '0'
        option scan_channel '0'
        option ht_support '10'
        option vht_support '100'
        option eval_probe_req '1'
        option eval_auth_req '1'
        option eval_assoc_req '1'
        option min_probe_count '2'

Wireless:


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option legacy_rates '0'
        option country 'US'
        option beacon_int '101'
        option txpower '21'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ft_over_ds '1'
        option ssid '*********'
        option ft_psk_generate_local '1'
        option key '********'
        option ieee80211r '1'
        option encryption 'psk2+ccmp'
        option ieee80211k '1'
        option bss_transition '1'
        option ieee80211v '1'
        option wpa_disable_eapol_key_retries '1'

I know we've started mixing a couple of (related) topics here, sorry ...

I discovered that the "crappy" Chromebooks actually roam very well if I keep the wifi settings open so they scan for APs. Otherwise it doesn't look like they scan in the background, or maybe they do but not very often. This is fine, not a big deal, I showed my kids what to do if they move around with them and wifi is not great.

I suspect DAWN would help if it could tell the clients to rescan/send the "disassociation imminent" message.

Let me know if I am hijacking your thread and want me to start a new thread. I was hoping to be helpful with the discussion on dawn. :sunglasses:

No this is great, carry on! Perhaps I should rename the thread :slight_smile:

1 Like

I said in the beginning you should look into your wpad config and search for background scanning. :wink:

1 Like

Not sure what this means, do you mind providing some details, which config to look at and what to look for?

@ACwifidude

Could u set hostapd debugging level to get all messages and look if there are incoming beacon repsonses?

I showed here how u can trigger beacon reports via ubus manually

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=c8ef465e10f46fd017cc9c3e455cc368a2b9da2b

I will open a seperate dawn support thread, with a more detailed description of the status and possibilities.

1 Like

Do u use Networkmanager?

No, these are Chromebooks running Chrome OS. They are owned and managed by my kids' school so I can't mess with them and many settings are locked.

Couple minutes of walking between two r7800 APs (running hynman’s master with normal ct driver and both running dawn. Client is a new Apple iPad with latest OS). :sunglasses:. Anything stick out?


Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:48:06 2020 kern.warn kernel: [180337.338525] Rekeying PTK for STA 58:e6:ba:c7:XX:XX but driver can't safely do that.
Mon Sep  7 16:48:06 2020 kern.info kernel: [180337.338546] ath10k_pci 0000:01:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: association OK (aid 1)
Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 8 notification
Mon Sep  7 16:48:06 2020 daemon.info hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: associated (aid 1)
Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX MLME: MLME-REASSOCIATE.indication(58:e6:ba:c7:XX:XX)
Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:48:06 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 6 notification
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:50:29 2020 kern.warn kernel: [180480.477176] Rekeying PTK for STA 58:e6:ba:c7:XX:XX but driver can't safely do that.
Mon Sep  7 16:50:29 2020 kern.info kernel: [180480.477200] ath10k_pci 0000:01:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: association OK (aid 1)
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 8 notification
Mon Sep  7 16:50:29 2020 daemon.info hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: associated (aid 1)
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX MLME: MLME-REASSOCIATE.indication(58:e6:ba:c7:XX:XX)
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:50:29 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 6 notification
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:56:10 2020 kern.warn kernel: [180821.059562] Rekeying PTK for STA 58:e6:ba:c7:XX:XX but driver can't safely do that.
Mon Sep  7 16:56:10 2020 kern.info kernel: [180821.059585] ath10k_pci 0000:01:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: association OK (aid 1)
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 8 notification
Mon Sep  7 16:56:10 2020 daemon.info hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: associated (aid 1)
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX MLME: MLME-REASSOCIATE.indication(58:e6:ba:c7:XX:XX)
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX IEEE 802.11: binding station to interface 'wlan0'
Mon Sep  7 16:56:10 2020 daemon.debug hostapd: wlan0: STA 58:e6:ba:c7:XX:XX WPA: event 6 notification

I haven't really looked at how dawn communication works, but 192.168.1.3 is not a broadcast address, you most likely want 192.168.1.255.
Also, based on the comment below, it seems that 2 means tcp and server_ip is blank? So I'm not sure what really happens, maybe it "just works"(tm) because of mDNS.
https://github.com/openwrt/packages/blob/master/net/dawn/files/dawn.config#L6

Edit: I guess it works with mDNS because your network_option=2 so I don't think broadcast_ip matters.
https://github.com/openwrt/packages/blob/master/net/dawn/files/dawn.init#L57

Yep. And there is 3. You can find a detailed description in the commit message:


(the commit is wrong, actually the last option network_option '3' should be 2)

So server_ip is just for central monitoring.

Appreciate it. Changed it to 192.168.1.255. Looking forward to the dawn thread to see all the ways to tweak and optimize roaming (Interesting central managing option). :sunglasses:

I don't think it matters, unless you set network_option=0

1 Like