Any stable realease that works on Raspberry Pi 4?

Hello everyone.

I have raspberry pi 2 which I used with openwrt before and now I wanted to use rpi4 instead. I saw that there's currently on snapshot build for rpi4 and some "community" build that the maintainer emptied out with the advice that the current snapshot is too unstable, or something similar.

According to openwrt's rpi page, "bcm2709 (rpi2) subtarget can be used for bcm2710 (rpi3) and bcm2711 (rpi4) devices".
Does this mean that I can deploy stable 19.07.4 rpi2 release onto rpi4 (e.g. openwrt-19.07.4-brcm2708-bcm2709-rpi-2-ext4-factory.img.gz)?
If not, what does that statement about subtargets actually mean?

Thank you very much in advance!

yes edit: snapshot only it seems...

1 Like

for clarity...

downloads ( opkg ) was down my friend... i'm not going to leave images up when there is potentially hang worthy problems associated with upstream server faults...

1 Like

Hi @anon50098793!

Thanks a lot for such a quick response. No ill intentions on my side while commenting on the missing "community" release. Sorry if I came across as negative.

There was just a lot of uncertainty and lack of understanding on my side on what is going on there.

Anyway, the reason for starting this thread is that I spent some time reading/preparing for the deployment on rpi4 when I understood that only snapshots are available for the platform and that wasn't in the greatest shape at the moment. Accidentally I found your build as well and was really happy to try it (to avoid relying upon myself to start from scratch) but then there were nobuild/norelease warning which sounded quite grim.

I tried then to deploy official stable rpi2 image after which the rpi4 did not boot (I didn't have the opportunity to check the console screen at that moment) but the device wouldn't come on-line and the ethernet port's link light was blinking weirdly (activity light wasn't blinking at all). A assumed I misunderstood the statement about subtargets...

Then I created a local copy of all relevant bcm2711 snapshot opkg repositories to use them later if I need them. I was surprised to see that the rpi4 snapshot booted completely ok. There are indeed some missing packages, due to build failures in the snapshot but, so far, everything relevant/important works.

I'll try flash again the rpi2 stable release and connect to a monitor to see what is being reported. I'd like to start using this in "productive" environment (reconfigure things around home, not just play with it in an isolation), therefore a stable release is something I definitely would prefer now.

Thanks one more time!

1 Like

well it's reported to work...

snapshots only it seems

join the club, lol... there are probably 100-300 users in the same boat...

if you are capable of using a buildroot ( some linux skills )... the most reliable method at the moment is using the buildroot to generate your own images... ( or using the 32-bit stable as you have tried )...

so, you've got those three options at the moment;

  • use 32bit ( iron out the issue ) seems it's also snapshot only
  • use a buildroot
  • wait a few weeks for the packages issue to be fixed and possibily use the imagebuilder with snapshot...

Got it.

32bit is perfectly fine, if manage to make it work...
It didn't start again. Same behavior.
The microhdmi to hdmi adapter I have either does not work or the openwrt does not output anything to the screen.
Will try with earlier releases to see if anything changes.

see note above re: firmware blobs...

you might need to boot a 32bit raspbian and downgrade your firmware blob...

edit: got this back to front... it would be bootfiles that need to be updated not blobs reverted... ran a quick test... and it's more than bootfiles ( kernel level ) so snapshots only i'm afraid )

I can confirm that there is no output on the screen (via hdmi) with rpi2 19.07.4/19.07.3 images.

Not sure I know what you mean by firmware blobs. Are you referring to eeprom code update?
That's something that wouldn't be reverted back to the older version by flashing older 32-bit raspbian. It would have to be explicitly downgraded...

1 Like

I even tried openwrt-18.06.4-brcm2708-bcm2709-rpi-2-ext4-factory.img.gz with the identical result.
Rpi4 powers on without booting... There is a slow blinking of the ethernet port link led and nothing else. No output on the screen via hdmi (which normally works with rpi4 snapshot).

Is there anyone who is successfully using stable rpi2 release on their rpi4, who could also confirm if they had to do some preparational work before it worked?

I'm starting to suspect that the statement "bcm2709 subtarget can be used for bcm2710 and bcm2711 devices" does not mean that you can run rpi2 release image on rpi4. It sounds like it has something to do with building the image yourself (you can use bcm2709 target while building image for bcm2711 and in that way produce a 32bit image)...

no doubt bootcode related... in summary... it's snapshots only i'm afraid...

I'm looking for some more specifics on how close we are to a stable release so I can decide whether to install a new snapshot or hold out for the stable release. Any details yet, Allan?

RC2 working fine for me - Index of /releases/21.02.0-rc2/targets/bcm27xx/bcm2711/ (