Any pre-built with Linux 4.8 or 4.9?

Hi, are there any pre-builds that utilize the 4.8 or 4.9 kernel? I'm looking for anything that might match AR9344 and AR8327, found in Mikrotik RB2011UiAS.

Btw, were do you find general build info like kernel version etc for the pre-builds?

Thanks in advance!

Initial kernel 4.9 support has been introduced to LEDE, but only a few target platforms have been converted from 4.4 to 4.9 by now.

Versions available for a target depend on the global "available kernels" list and on the support files at the target platform.

Available kernels:;a=blob;f=include/;hb=HEAD

LINUX_VERSION-3.18 = .43

But the targets require kernel-specific config and patches. See the difference:
E.g. x86 has been converted to 4.9:;a=commit;h=92bda4ae5c6aac89e612c338bf9e9e6e9ee96aca

You can see that 4.9 from the target patches, config and Makefile:;a=tree;f=target/linux/x86;hb=HEAD;a=blob;f=target/linux/x86/Makefile;hb=HEAD


But e.g. ar71xx still uses 4.4 and has not yet any config-4.9 or patches-4.9;a=tree;f=target/linux/ar71xx;hb=HEAD

Thanks for the quick and comprehensive answer, just what I was looking for!

I'll try to set up my own rig using registry settings from an old config that used to work with RB2011UiAS.

Again, many thanks!
shows kernel versions per target.


And if you are really experimental, you can also see "work in progress" in the developers' staging directories.

E.g. nbd seems to be preparing 4.9 transition for mvebu.;a=shortlog

Ok. Im kinda a noob on building lede. I've built many firmwares but I have never messed around much with anything other than make menuconfig. I see that 4.9 is now in the PI3. I want to build a pi3 kernel 4.9.

What exactly do i need to edit to make this happen?

[quote="Westrem, post:6, topic:1557"]
I see that 4.9 is now in the PI3. I want to build a pi3 kernel 4.9.

What exactly do i need to edit to make this happen?
[/quote]If your target platform (brcm2708???) has already been bumped to 4.9, then you need to do nothing extra. Just clone the newest source and compile the new firmware for your router.

Note that you can't compile just kernel. You need to compile the whole firmware.

Thank you. Doing it now

Thanks, that's a keeper! :slight_smile:

Looks like Luci is not there yet. Going ahead and building without it.


Kernel version has no impact on LuCI.

But LuCI is a feed.
You need to do

./scripts/feeds update
./scripts/feeds install -a

to see LuCI & other feed packages in the menuconfig.

Just like explained in (specifically in ). Quite the same was as in Openwrt.

Yeah I did that. Strange. Ok i will just install it after. I even compiled modemmanager and did it again.

That's was a good suggestion! Now I know who's working active on migrations :grin:

Btw, you don't happen to know if there have been any major changes one should be aware of when moving to 4.9 in regards of e.g. device drivers etc, or is it just the usual stuff like shovelling around version info, #includes and other dependencies?

Yup. Did the update and install again and under luci is only a few luci apps and thats it. I dont get it.

I have no specific knowledge about 4.9.

But generally, mostly it is about new/changed kernel config symbols and the needed changes to LEDE/Openwrt specific kernel patches (~100 generic, ~30-50 per target platform).

Most of the critical stuff has probably been already done, as the first platforms have been successfully moved to 4.9. If you check the LEDE commit logs, you will notice about 10-20 commits about "changes for 4.9" to several packages.

But there can always be surprises. E.g. 4.4 transition was difficult for ar71xx. Some devices got into a boot loop. After that got fixed, there was a noticeable performance hit due to unaligned memory access. I helped nbd to debug that in May 2016 by trying patches from his staging tree. So, the community can help in the transition by testing the draft patches for platforms being worked upon.

Thanks for the input, seems that most of the hard work is already done!

Darn, I've totally forgot is to check whether it is possible to use remote debugging on the device or not. When I checked the device there is actually a serial port (RJ45) but I'm not sure it work with kgdb. Perhaps kgdb over ethernet using kgdboe might be an option?

Btw, did you use kgdb or have access to JTAG or something similar?

[quote="Boilerplate4U, post:16, topic:1557"]
totally forgot is to check whether it is possible to use remote debugging on the device or not.
did you use kgdb or have access to JTAG or something similar?
[/quote]I mainly used gdb for remote debugging with that unaligned access, as it was possible to boot the router normally and then cause the crash by activating the unaligned access debug logging (that quickly crashed the router).

But naturally that is not possible with an earlier boot loop. I used an USB TTL serial cable to document that boot loop. (wndr3700 had a nice serial header inside the router)

I redid every thing and all the packages showed up. I'm not sure what happened the first time around. But 4.9 is up and running.

4.9 kernel on mvebu wrtxx00acx series appear to be working. Been running on mamba for about a week, and as of today rango is now up and running.

I've tried to create a staging according to "Staging Trees" using my own project account password but in vain: "$ ssh "create lede/Boilerplate4U/staging"

Are you supposed to make a special request for a staging area and password or have i missed anything?