Any 18.x builds for TL-WR703N

The best I can find is LEDE but the code a dev wrote for us only runs on newer openwrt.
Does anyone know of a base, limited build for the TP-Link TL-WR703N that someone might be sharing on the Internet?

I realize 4MB is small for new openwrt but I barely install anything. I just need the operating system to be a very basic one, no luci, no firewall, barely anything but bash. I use these to read sensors that are connected to the USB port. Bash script polls, sends, polls, sends, nothing else.

All of the TL-WR703N become bricks for me unless I can run 18.x.

Thanks.

1 Like

https://openwrt.org/toh/tp-link/tl-wr703n -- 4/32 device, 400 MHz MIPS CPU

You'll likely need to build your own firmware, either from source or using the image builder.

See https://openwrt.org/docs/guide-user/additional-software/saving_space for some thoughts.

bash alone will likely kill you -- consider rewriting your scripts to be ash (sh) compatible. shellcheck on another platform may be helpful in finding and removing "bash-isms", along with https://wiki.ubuntu.com/DashAsBinSh

Installed size: at least 263kB (see https://openwrt.org/packages/table/start?dataflt[Name_pkg-dependencies*~]=bash)

As you already know, space is scarce on 4MB devices. Ditching bash is the easiest way to save a lot of space.

I tried using the image builder but I can only find LEDE versions, not newer openwrt.

Quite possibly because the image is too large for the flash. You'll likely have to build from source.

target/linux/ath79/image/tiny-tp-link.mk:define Device/tplink_tl-wr703n

suggests that the source is still available on master

I could play with the size by removing packages but the main problem is not finding an image builder that supports this device post LEDE.

Have you tried http://downloads.openwrt.org/snapshots/targets/ar71xx/tiny/openwrt-imagebuilder-ar71xx-tiny.Linux-x86_64.tar.xz ?

1 Like

I'm trying it now but have downloaded it three times and get an error on make info alone.

make info

snip
NBG_460N_550N_550NH:
ZyXEL NBG 460N/550N/550NH
Packages: kmod-rtc-pcf8563
hasImageMetadata: 0
make[1]: *** [_call_info] Error 1
make: *** [info] Error 2

I ran a build and it seemed to complete however.
make image profile=tl-wr703n-v1
-rw-r--r-- 1 root root 3604484 May 20 12:56 openwrt-ar71xx-tiny-tl-wr703n-v1-squashfs-sysupgrade.bin

Updating the device lost it. It won't grab a DHCP IP anymore. I do use my own files/ which should use DHCP.

Stragenly, now I cannot even use default reset methods to get back into it. It comes up with 192.168.1.1 but no services what so ever, no telnet, no ssh, etc. It's not bricked yet there is no way into it any more.

I used to compile the 18.06.2 image for tl-wr703n from source and succeeded. It contains LuCI, but no kmod-usb-core and kmod-usb2. That won't be an issue for me since I have modded my router.
I've also succeeded in compiling it from the image builder. This time the image does not have LuCI, but it has the kmods.
As long as you followed the doc on build system and installed all prerequisites, I think it won't be a problem.

1 Like

Hi Icarusradio,

I didn't get an email about this so didn't know someone had replied. I'll take another look but so far, I've had no luck what so ever using image builder.

I think those packages are blocked in my list or simply not added to it, cannot remember but I'll check.