Another new revision or Xiaomi R4AC (100M, int.), how to migrate to OpenWrt

I got my hands on a new R4AC (100M international version), the Revision on the box is DVB4307GL. It came with the last english firmware i.e. 3.2.16, and that's where the issue begins.

Because it doesn't accept OpenWrt sysupgrade or vendor downgrade through the gui, following the forum threads called from the Wiki, I have tried a downgrade with the chinese MIWIFIRepairTool to international 2c4a7_3.0.5 or chinese c4b35_2.18.28 or even chinese e9eec_2.18.58. It seems it doesn't take any of those, as just after finishing uploading the image the power LED inmediately starts to fast-blink in purple-like color. For confirmation, I've tried waiting several minutes, or power-cycling inmediately, and/or factory reset before trying, it still comes back with working 3.2.16.

Trying directly with the online method of OpenWRTInvasion, I got a couple of warnings:
"seems that the SSH connection to the router is not working", and
"Maybe your firmware version is not supported"

Anyways I tried to connect with telnet and ftp, and I could.
Then I checked the mtd6, and it reported what expected:
mtd6: 00200000 00010000 "overlay"
(the other mtd's looked similar to the wiki too).

So it seems I could proceed to write the OpenWrt sysimage, but because I don't have the 3.2.16_INT firmware to do a debrick, and it didn't take other images via the Xiaomi recovery tool, and I don't have an SPI handy, I want to be as sure as possible it's going to be OK before trying. Anyone has succeded with this new version?

Have you tried miwifi_r4ac_all_c4b35_2.18.28 version? Key moment is 'all' in name.

Yes, I tried that one, but at the end it wasn't needed the downgrade, as I could proceed mixing the method suggested on the wiki with the one explained by acecilia, and not by trying to follow the methods suggested on other threads of this forum. So I'm marking my second post as the solution (if I may do that), and leaving this for somebody else looking for tips, and/of for somebody updating the wiki with the new revision as supported.


PS. Now I'm testing stability and/or other stuff.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.