Another install on Asus RT-AC58U

Hello

I am going through my first OpenWRT install, on an Asus RT-AC58U router.

I started by following the instructions at https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=87c42101cfb001b4bd418d1201fa4d8c822dc77b and soldered some pins for the onboard serial port. Here I hit a problem, as I can receive data from the router and can see the full boot log of the Asus firmware, but I cannot select anything in the bootloader menu.
Maybe the Rx pin has a problem, I'll try to resolder it soon.

In the meanwhile, I logged on to the router through SSH (this can be nicely enabled in the Asus firmware) and spent some time reading through this forum and the Wiki. I saw that there is a way to flash OpenWRT without the serial port, but apparently it cannot be safely updated to the latest release...or am I wrong?

Anyway, starting from there I am now trying to understand the disk/partition layout of the router on the stock FW :slight_smile:
Could anybody explain what it looks like?
I read so far about MTD and UBI and the flash layout, looked at the output of mtdinfo -a, ubinfo -a, the kernel command line and other info from the boot log. But I'm still missing something.
On the router I see 7 partitions (nvram, Factory, Factory2, linux, rootfs, linux2, rootfs2), but it's clear that some of these are overlaid, as the sum of all their sizes is larger than 128 MB.

Also, I would like to add some info to the Wiki page of the router, which is pretty empty. What would be needed there?

Thanks!

1 Like

See here for installation instructions:

Everything with a FIXME.
Confirmed working installation instructions in english would be helpful.

Thank you! I had missed that post.
Before trying that, anyway, I'll try to fix the serial port; I would feel a bit more confortable flashing an official OpenWRT image.

Coming back to this after a few days, I am now pretty certain that the serial port on the router does not work fully. I can read the output of the router, but I cannot make any selection at the boot prompt.
I wonder if there could be something obvious that I am missing, like a terminator setting (I already tried with and without a terminator). Or maybe I just managed to fry the Rx pin of the interface during my initial soldering.

Aaand I solved it! I am leaving the information here, in case it helps somebody else.

At the Rx pin of the serial port header on the router board there is a resistive divider, whose output goes to the controller. The divider is made of an ~56 ohm resistor and an ~ 500 ohm resistor, which means that it draws a current around 6 mA from the corresponding Tx line at the other end.
I am using an USB-to-serial adapter built around an FT232R chip, and apparently it cannot drive the 6 mA; it's datasheet gives some voltage levels measured at a nominal current of 1 mA.

For the time being I went for a direct approach and removed the 500 ohm resistor (it is the one betwenn the Rx pin and the ground of the board). No more 6 mA needed and I am in the U-Boot menu :slight_smile:

2 Likes

Awesome! If you mark your last post with the [ ] Solution checkbox, it will quickly guide others to the results of your hard work.

Would it be appropriate to also include on the device page the link to the 4pda.ru installation instructions? It is not the "official" procedure, but several people used it successfully.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.