Anonymous vsftpd uploads not working?

I've tried seemingly everything but don't know where else to turn. Running 23.05.2 on a Netgear R6220. What I want is quite simple: An anonymoue FTP server with read/write permissions. However, I cannot get anonymous uploads to work. I'll get a 553 error when trying to upload with ftp in the terminal, and I've tried several GUI clients and Android clients, all of which fail to upload. I can delete files, and I can even mkdir , but for some reason uploads do not work. The vsftpd log was pretty useless, essentially just saying that the upload has failed. I have a USB drive mounted, at sda1 , with root as the owner and 555 as the permissions, and I have a sub folder with nobody as the owner and the permissions are set to dangerous levels, 777. That was to fix the "500 Oops error". Here's my vsftpd.conf

# Default Options
# Run vsftpd in the background
background=YES
# Listen for incoming connections
listen=YES
# Allow writing files
write_enable=YES
# File creation mask for local users - not used, but part of the default config, so I've left it in
local_umask=022
# Do not check for a valid user shell
check_shell=NO
# Do not maintain session logins
session_support=NO
# Anonymous FTP server specific stuff
# Enable anonymous logins
anonymous_enable=YES
# Disable local user logins - they won't be used
local_enable=NO
# Set the root path for the FTP server files
# This must NOT be publicly writable - ensure it's set with chmod permissions 775 at least
anon_root=/mnt/sda1
# Allow anonymous users to create directories
anon_mkdir_write_enable=YES
# Allow anoynmous users to upload files
anon_upload_enable=YES
# Allow anonymous users to rename and delete files
anon_other_write_enable=YES
# Do not ask for password for anonymous user
no_anon_password=YES
# Hide user/group info in directory listings
hide_ids=YES
# The name of the anonymous FTP user - this  fixes the 'cannot change directory' error
ftp_username=nobody
# Make newly uploaded files read/writable
anon_umask=000
seccomp_sandbox=NO
dirmessage_enable=YES
ftpd_banner=Welcome to blah FTP service.
session_support=NO
#syslog_enable=YES
xferlog_enable=YES
xferlog_file=/var/log/vsftpd.log
#xferlog_std_format=YES
pasv_enable=YES
pasv_max_port=40000
pasv_min_port=50000

Any suggestions?

Is there a firewall involved ?

No, no firewall.

Also, samba uploads work fine, as do nfs.

can't really reproduce it, using your config.

I did however set background= to NO, while testing, and started it via the
prompt (root@OpenWrt:/etc# /usr/sbin/vsftpd), instead of the service.

I also enabled syslog_enable=YES to get logging using logread -f.

Strange.. Maybe I'll start from scratch. Thanks, though!