Android phones cannot obtain IP address

I recently updated to 21.02 on my Linksys WRT3200ACM ... after some stability fighting it now appears as stable as 19.07 for my use-case. There is however one problem. I cant get any of my Android phones to obtain an IP address. I've tried with a Pixel 5 & Samsung Galaxy 10. They connect, but after connection IP negotiation fails.
I don't have this problem on my very cheap Android-based smart tv or my laptop (linux). Both 2.4 & 5 GHz works fine.
Updating to 21.02.1 did not solve the problem.

Does the problem occur only in IPv4 or IPv6 as well?
Let's have a look at the configs:

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user
{
	"kernel": "5.4.154",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Linksys WRT3200ACM",
	"board_name": "linksys,wrt3200acm",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.1",
		"revision": "r16325-88151b8303",
		"target": "mvebu/cortexa9",
		"description": "OpenWrt 21.02.1 r16325-88151b8303"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd0:d32e:0626::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '*****************'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'wlan0'
	option ipv6 '0'

config device
	option name 'wlan1'
	option ipv6 '0'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'DK'
	option cell_density '0'
	option channel '48'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr ''*****************'
	option ssid '******************'
	option wmm '0'
	option key '******************'
	option encryption 'psk2'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'DK'
	option cell_density '0'
	option channel '3'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr ''*****************'
	option wmm '0'
	option key '******************'
	option ssid '******************'
	option encryption 'psk2'
	option disassoc_low_ack '0'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '34'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled '0'

config include
	option path '/etc/firewall.user'


Here is what the log generates when Android phones try to connect :

Sun Nov  7 12:42:33 2021 daemon.info hostapd: wlan1: STA **:**:**:**:**:** IEEE 802.11: associated (aid 3)
Sun Nov  7 12:42:33 2021 daemon.info hostapd: wlan1: STA **:**:**:**:**:** IEEE 802.11: authenticated
Sun Nov  7 12:42:33 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED **:**:**:**:**:**
Sun Nov  7 12:42:33 2021 daemon.info hostapd: wlan1: **:**:**:**:**:** WPA: pairwise key handshake completed (RSN)
Sun Nov  7 12:42:41 2021 daemon.warn odhcpd[30099]: A default route is present but there is no public prefix on lan thus we don't announce a default route!
Sun Nov  7 12:42:41 2021 daemon.err odhcpd[30099]: Failed to send to ff02::1%lan@br-lan (Permission denied)
Sun Nov  7 12:42:51 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED **:**:**:**:**:**
Sun Nov  7 12:42:51 2021 kern.debug kernel: [571379.774546] ieee80211 phy1: staid 3 deleted

The only visible issue is that OpenWrt doesn't offer any IPv6 due to lack of public prefix.
It would be better to disable the RAs and DHCPv6 if you don't have any IPv6.
Other than that it would provide more insight to capture some packets when the android phones connect
opkg update; opkg install tcpdump; tcpdump -i br-lan -evn ether host xx:xx:xx:xx:xx:xx and use the mac of the phone.

I have upstream IPv4 & 6 .. But I think its a problem with IPv6 and OpenWRT 21.02, based on the log I have - how do I disable it, the internets is full of complicated suggestions ?.

Post along with the tcpdump also this one: ifstatus wan6; ifstatus lan

tcpdump: listening on br-lan, link-type EN10MB (Ethernet), capture size 262144 bytes
20:28:59.267230 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 6: LLC, dsap Null (0x00) Individual, ssap Null (0x00) Response, ctrl 0xaf: Unnumbered, xid, Flags [Response], length 6: 01 00
20:28:59.311073 f8:1a:2b:34:dc:3e > 33:33:ff:b1:f7:a2, 802.3, length 96: LLC, dsap Null (0x00) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 96
	0x0000:  0100 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0020 3aff 0000 0000 0000 0000  `.....:.........
	0x0020:  0000 0000 0000 0000 ff02 0000 0000 0000  ................
	0x0030:  0000 0001 ffb1 f7a2 8700 73ca 0000 0000  ..........s.....
	0x0040:  fe80 0000 0000 0000 a32a dda2 85b1 f7a2  .........*......
	0x0050:  0e01 05cf de51 1fbd 0012 dd0a 506f 9a16  .....Q......Po..
20:28:59.311317 f8:1a:2b:34:dc:3e > 33:33:00:00:00:16, 802.3, length 100: LLC, dsap 802.1B I (0x02) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 100
	0x0000:  0200 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0024 0001 0000 0000 0000 0000  `....$..........
	0x0020:  0000 0000 0000 0000 ff02 0000 0000 0000  ................
	0x0030:  0000 0000 0000 0016 3a00 0502 0000 0100  ........:.......
	0x0040:  8f00 7736 0000 0001 0400 0000 ff02 0000  ..w6............
	0x0050:  0000 0000 0000 0001 ffb1 f7a2 7200 0100  ............r...
	0x0060:  0033 0e51                                .3.Q
20:28:59.346508 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 350: LLC, dsap 802.1B I (0x02) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 350
	0x0000:  0300 0020 0000 0000 aaaa 0300 0000 0800  ................
	0x0010:  4510 0146 0000 4000 4011 3998 0000 0000  E..F..@.@.9.....
	0x0020:  ffff ffff 0044 0043 0132 3cdb 0101 0600  .....D.C.2<.....
	0x0030:  63d3 eb20 0000 0000 0000 0000 0000 0000  c...............
	0x0040:  0000 0000 0000 0000 f81a 2b34 dc3e 0000  ..........+4.>..
	0x0050:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0060:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0070:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0080:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0090:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00a0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00b0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00c0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00d0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00e0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00f0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0100:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0110:  0000 0000 0000 0000 6382 5363 3501 013d  ........c.Sc5..=
	0x0120:  0701 f81a 2b34 dc3e 3902 05dc 3c0f 616e  ....+4.>9...<.an
	0x0130:  6472 6f69 642d 6468 6370 2d31 320c 0750  droid-dhcp-12..P
	0x0140:  6978 656c 2d35 370c 0103 060f 1a1c 333a  ixel-57.......3:
	0x0150:  3b2b 726c ff00 2302 3f00 4605 7200       ;+rl..#.?.F.r.
20:28:59.412775 f8:1a:2b:34:dc:3e > 33:33:00:00:00:16, 802.3, length 100: LLC, dsap SNA (0x04) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 100
	0x0000:  0400 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0024 0001 0000 0000 0000 0000  `....$..........
	0x0020:  0000 0000 0000 0000 ff02 0000 0000 0000  ................
	0x0030:  0000 0000 0000 0016 3a00 0502 0000 0100  ........:.......
	0x0040:  8f00 7736 0000 0001 0400 0000 ff02 0000  ..w6............
	0x0050:  0000 0000 0000 0001 ffb1 f7a2 b3a5 9471  ...............q
	0x0060:  6c02 7f00                                l...
20:29:00.061159 f8:1a:2b:34:dc:3e > 33:33:00:00:00:16, 802.3, length 100: LLC, dsap SNA (0x04) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 100
	0x0000:  0500 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0024 0001 fe80 0000 0000 0000  `....$..........
	0x0020:  a32a dda2 85b1 f7a2 ff02 0000 0000 0000  .*..............
	0x0030:  0000 0000 0000 0016 3a00 0502 0000 0100  ........:.......
	0x0040:  8f00 7a93 0000 0001 0400 0000 ff02 0000  ..z.............
	0x0050:  0000 0000 0000 0001 ffb1 f7a2 00c0 0500  ................
	0x0060:  0300 0000                                ....
20:29:00.072455 f8:1a:2b:34:dc:3e > 33:33:00:00:00:02, 802.3, length 80: LLC, dsap IP (0x06) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 80
	0x0000:  0600 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0010 3aff fe80 0000 0000 0000  `.....:.........
	0x0020:  a32a dda2 85b1 f7a2 ff02 0000 0000 0000  .*..............
	0x0030:  0000 0000 0000 0002 8500 7e7e 0000 0000  ..........~~....
	0x0040:  0101 f81a 2b34 dc3e 040c 1830 6005 0400  ....+4.>...0`...
20:29:00.412659 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 350: LLC, dsap IP (0x06) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 350
	0x0000:  0700 0020 0000 0000 aaaa 0300 0000 0800  ................
	0x0010:  4510 0146 0000 4000 4011 3998 0000 0000  E..F..@.@.9.....
	0x0020:  ffff ffff 0044 0043 0132 3cda 0101 0600  .....D.C.2<.....
	0x0030:  63d3 eb20 0001 0000 0000 0000 0000 0000  c...............
	0x0040:  0000 0000 0000 0000 f81a 2b34 dc3e 0000  ..........+4.>..
	0x0050:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0060:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0070:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0080:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0090:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00a0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00b0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00c0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00d0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00e0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00f0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0100:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0110:  0000 0000 0000 0000 6382 5363 3501 013d  ........c.Sc5..=
	0x0120:  0701 f81a 2b34 dc3e 3902 05dc 3c0f 616e  ....+4.>9...<.an
	0x0130:  6472 6f69 642d 6468 6370 2d31 320c 0750  droid-dhcp-12..P
	0x0140:  6978 656c 2d35 370c 0103 060f 1a1c 333a  ixel-57.......3:
	0x0150:  3b2b 726c ff00 00fb 80e1 0100 5e00       ;+rl........^.
20:29:00.915340 f8:1a:2b:34:dc:3e > 33:33:00:00:00:16, 802.3, length 100: LLC, dsap Unknown (0x08) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 100
	0x0000:  0800 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0024 0001 fe80 0000 0000 0000  `....$..........
	0x0020:  a32a dda2 85b1 f7a2 ff02 0000 0000 0000  .*..............
	0x0030:  0000 0000 0000 0016 3a00 0502 0000 0100  ........:.......
	0x0040:  8f00 7a93 0000 0001 0400 0000 ff02 0000  ..z.............
	0x0050:  0000 0000 0000 0001 ffb1 f7a2 9dc0 9d00  ................
	0x0060:  1c80 0100                                ....
20:29:02.471659 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 350: LLC, dsap Unknown (0x08) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 350
	0x0000:  0900 0020 0000 0000 aaaa 0300 0000 0800  ................
	0x0010:  4510 0146 0000 4000 4011 3998 0000 0000  E..F..@.@.9.....
	0x0020:  ffff ffff 0044 0043 0132 3cd8 0101 0600  .....D.C.2<.....
	0x0030:  63d3 eb20 0003 0000 0000 0000 0000 0000  c...............
	0x0040:  0000 0000 0000 0000 f81a 2b34 dc3e 0000  ..........+4.>..
	0x0050:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0060:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0070:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0080:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0090:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00a0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00b0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00c0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00d0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00e0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00f0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0100:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0110:  0000 0000 0000 0000 6382 5363 3501 013d  ........c.Sc5..=
	0x0120:  0701 f81a 2b34 dc3e 3902 05dc 3c0f 616e  ....+4.>9...<.an
	0x0130:  6472 6f69 642d 6468 6370 2d31 320c 0750  droid-dhcp-12..P
	0x0140:  6978 656c 2d35 370c 0103 060f 1a1c 333a  ixel-57.......3:
	0x0150:  3b2b 726c ff00 1e32 6061 0000 0000       ;+rl...2`a....
20:29:03.824643 f8:1a:2b:34:dc:3e > 33:33:00:00:00:02, 802.3, length 80: LLC, dsap Unknown (0x0a) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 80
	0x0000:  0a00 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0010 3aff fe80 0000 0000 0000  `.....:.........
	0x0020:  a32a dda2 85b1 f7a2 ff02 0000 0000 0000  .*..............
	0x0030:  0000 0000 0000 0002 8500 7e7e 0000 0000  ..........~~....
	0x0040:  0101 f81a 2b34 dc3e 0000 0000 0081 e68e  ....+4.>........
20:29:06.402634 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 350: LLC, dsap Unknown (0x0a) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 350
	0x0000:  0b00 0020 0000 0000 aaaa 0300 0000 0800  ................
	0x0010:  4510 0146 0000 4000 4011 3998 0000 0000  E..F..@.@.9.....
	0x0020:  ffff ffff 0044 0043 0132 3cd4 0101 0600  .....D.C.2<.....
	0x0030:  63d3 eb20 0007 0000 0000 0000 0000 0000  c...............
	0x0040:  0000 0000 0000 0000 f81a 2b34 dc3e 0000  ..........+4.>..
	0x0050:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0060:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0070:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0080:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0090:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00a0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00b0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00c0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00d0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00e0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00f0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0100:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0110:  0000 0000 0000 0000 6382 5363 3501 013d  ........c.Sc5..=
	0x0120:  0701 f81a 2b34 dc3e 3902 05dc 3c0f 616e  ....+4.>9...<.an
	0x0130:  6472 6f69 642d 6468 6370 2d31 320c 0750  droid-dhcp-12..P
	0x0140:  6978 656c 2d35 370c 0103 060f 1a1c 333a  ixel-57.......3:
	0x0150:  3b2b 726c ff00 1000 0000 0000 00ee       ;+rl..........
20:29:11.075915 f8:1a:2b:34:dc:3e > 33:33:00:00:00:02, 802.3, length 80: LLC, dsap Unknown (0x0c) Individual, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 80
	0x0000:  0c00 0020 0000 0000 aaaa 0300 0000 86dd  ................
	0x0010:  6000 0000 0010 3aff fe80 0000 0000 0000  `.....:.........
	0x0020:  a32a dda2 85b1 f7a2 ff02 0000 0000 0000  .*..............
	0x0030:  0000 0000 0000 0002 8500 7e7e 0000 0000  ..........~~....
	0x0040:  0101 f81a 2b34 dc3e 0100 0000 0000 0000  ....+4.>........
20:29:14.277184 f8:1a:2b:34:dc:3e > ff:ff:ff:ff:ff:ff, 802.3, length 350: LLC, dsap Unknown (0x0c) Group, ssap Null (0x00) Command, ctrl 0x2000: Information, send seq 0, rcv seq 16, Flags [Command], length 350
	0x0000:  0d00 0020 0000 0000 aaaa 0300 0000 0800  ................
	0x0010:  4510 0146 0000 4000 4011 3998 0000 0000  E..F..@.@.9.....
	0x0020:  ffff ffff 0044 0043 0132 3ccd 0101 0600  .....D.C.2<.....
	0x0030:  63d3 eb20 000e 0000 0000 0000 0000 0000  c...............
	0x0040:  0000 0000 0000 0000 f81a 2b34 dc3e 0000  ..........+4.>..
	0x0050:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0060:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0070:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0080:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0090:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00a0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00b0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00c0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00d0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00e0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x00f0:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0100:  0000 0000 0000 0000 0000 0000 0000 0000  ................
	0x0110:  0000 0000 0000 0000 6382 5363 3501 013d  ........c.Sc5..=
	0x0120:  0701 f81a 2b34 dc3e 3902 05dc 3c0f 616e  ....+4.>9...<.an
	0x0130:  6472 6f69 642d 6468 6370 2d31 320c 0750  droid-dhcp-12..P
	0x0140:  6978 656c 2d35 370c 0103 060f 1a1c 333a  ixel-57.......3:
	0x0150:  3b2b 726c ff00 a0e0 4494 d89f c6cd       ;+rl....D.....

14 packets captured
15 packets received by filter
0 packets dropped by kernel

ifstatus lan
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 73529,
	"l3_device": "br-lan",
	"proto": "static",
	"device": "br-lan",
	"updated": [
		"addresses"
	],
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		{
			"address": "192.168.1.1",
			"mask": 24
		}
	],
	"ipv6-address": [
		
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		{
			"address": "2a09:5e40:1300:b20::",
			"mask": 60,
			"preferred": 2148,
			"valid": 2148,
			"local-address": {
				
			}
		},
		{
			"address": "fdd0:d32e:626::",
			"mask": 60,
			"local-address": {
				
			}
		}
	],
	"route": [
		
	],
	"dns-server": [
		
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		
	}
}
ifstatus wan6
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 73471,
	"l3_device": "wan",
	"proto": "dhcpv6",
	"device": "wan",
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2a09:5e40:2:1::2:5614",
			"mask": 128,
			"preferred": 2200,
			"valid": 2200
		}
	],
	"ipv6-prefix": [
		{
			"address": "2a09:5e40:1300:b20::",
			"mask": 60,
			"preferred": 2200,
			"valid": 2200,
			"class": "wan6",
			"assigned": {
				"lan": {
					"address": "2a09:5e40:1300:b20::",
					"mask": 60
				}
			}
		}
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::428f:9dff:fe7d:c368",
			"metric": 512,
			"valid": 1601,
			"source": "2a09:5e40:1300:b20::/60"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::428f:9dff:fe7d:c368",
			"metric": 512,
			"valid": 1601,
			"source": "2a09:5e40:2:1::2:5614/128"
		}
	],
	"dns-server": [
		"2606:4700:4700::1111",
		"2606:4700:4700::1001"
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		"passthru": "001700202606470047000000000000000000111126064700470000000000000000001001"
	}
}

You run tcpdump with wrong arguments -xvn instead of -evn and you've run twice ifstatus lan

I ran with -evn .. just copy and pasted the command from your post.
Updated ifstatus lan6

That looks more like -xevn with the HEX and ASCII. And there isn't anything useful there anyway. Did you try connect the phone while tcpdump was running?

Anyway, regarding IPv6, you get the prefix but you have configured not to use it:

1 Like

Tried turning it on .. no change. Guess I'll revert to 19.07 .... maybe try pfSense in the long run, using my Linksys as a plain AP :smiley:

Thx for trying to help.

UPDATE : Back on 19.07 ... Android phone connects instantly and with zero issues.

2 Likes

I can confirm this issue is still present on
Powered by LuCI openwrt-22.03 branch (git-22.204.42822-9a18337) / OpenWrt 22.03.0-rc6 r19590-042d558536

The issues started when I moved from 19.something to something newer.

Is there anything I can do to help out the devs getting this sorted?

1 Like

i can confirm this

i went from OpenWrt 22.03.0 r19685-512e76967f to OpenWrt 21.02.1 r16325-88151b8303 and android devices can connect

1 Like