Android IP configuration issue

Hello there,

today I received my Bosch Smart Home Controller. As I had different Interfaces and subnets for different devices, I needed to make sure my Smartphone and the Controller will be within the same interface and firewall zone to communication together.

I created a new interface on my Netgear R6220 Router:

config interface 'SmartHome'
        option proto 'static'
        option device 'lan4'
        option ipaddr '192.168.6.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option type 'bridge'

I want to link LAN4 and one of my wifi called "L_T2":

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option key 'xxx'
        option ieee80211w '2'
        option ssid 'L_T2'
        option network 'SmartHome'
        option encryption 'sae-mixed'

I also have setup firewall:

config zone
        option name 'SmartHome'
        option output 'ACCEPT'
        option input 'DROP'
        option forward 'ACCEPT'
        list network 'SmartHome'

config forwarding
        option src 'SmartHome'
        option dest 'wan'

config rule
        option name 'AllowDNS-SmartHome'
        option src 'SmartHome'
        option dest_port '53'
        option target 'ACCEPT'

config rule
        option name 'AllowDHCP-SmartHome'
        option src 'SmartHome'
        option dest_port '67-68'
        option target 'ACCEPT'

DHCP:

config dhcp 'SmartHome'
        option interface 'SmartHome'
        option start '100'
        option limit '150'
        option leasetime '12h'

The SmartHome Controller is able to get IP address and also pulled latest update.
When I try to connect my Android device with the wifi L_T2, i get an message "saved, IP configuration issue". It was working some minutes before with a different interface and zone, but no different settings. I am confused. Can anyone point me in the right direction?

Thanks and Cheers,
Lasko

There has to be a bridge to have wifi and Ethernet in the same network. See br-lan for an example-- make a br-smarthome the same way.

1 Like

Thanks @mk24. I knew I missed something. After configuration of the bridge and restart of the router, smartphone was able to get IP-adress. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.