Android 8.1 screen off a little bit time can't access the internet

Issue:
When my android 8.1 phone screen off a bit time and reuse it. It will be can't access the internet.(and can't access the openwrt admin web). If I dc the wifi and reconect it, it will be fine(100% fine), or wait a a little bit(maybe 5min) it will be fine(maybe not).
At the android phone have issue same time, my latop can normaly use the same wifi.
My phone at other wifi did't show this issue.
At both wifi 2.4G and 5G wifi have same problem on openwrt.
I try to turn my 2.4G WIFI to 20hz, not wrok.
I try to make it satic dhcp about my phone, not wrok.
On my ONT, my phone work correctly, on my 4 yeah old router under my ONT, my phone work correctly.

Envir:
Router modle: JCG Q20
OpenWrt Verson: 21.02.0-rc3
Android Verson: 8.1
WIFI: 2.4g & 5g have same problem
Only install adblock on openwrt(if u did't count the ohter language and luci theme)
At the openwrt roter I have a Optical Network Terminals(ONT) for connect the internet and have
wifi function.
My ISP: DIdn't provide IPV6 PD( It mean I only can use ipv6 on my ONT, can't use it on my other router)

Config:

network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd47:80eb:fdf4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option reqaddress 'try'
	option peerdns '0'
	list dns '2001:4860:4860::8844'
	list dns '2001:4860:4860::8888'
wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option cell_density '0'
	option channel '13'
	option htmode 'HT40'
	option country 'AU'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key 'luckgold'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option htmode 'VHT80'
	option cell_density '0'
	option channel 'auto'
	option country 'CN'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'luckgold'
	option ssid 'OpenWrt_5G'
dhcp
config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option confdir '/tmp/dnsmasq.d'
	option authoritative '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
firewall
config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	option masq '1'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

At the end:
Did't any other i need to post?
Before I created this topic I have been see a lot of page talk like my situation issue and try a lot of
solution, but it didn't work, so I think I need a help, plz some kindness gentleman and lady waste
your little time to help me, plz.
I'm so sorry about my awful english, if have anything i didn't say clear or have some unfriendly, this
not my real attention. Plz don't mind it and ask me anything if it make you confuse.
Thanks for read this topic, have a good day.

I have the same issue. After my Android 11 sleeps, it will have an issue when I wake up the device. If I am 10 meters or more from the AP, there is trouble getting a strong WiFi signal. Sometimes I have to turn off/on the Android WiFi to recover quickly. If I wait it will take about 5 minutes to reestablish a reliably connection. If I am 5 meters or less I do not experience the issue as frequently. The log is full of these messages:

Mon Jul 19 01:29:31 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED xx:xx:xx:xx:xx:xx
Mon Jul 19 01:29:31 2021 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: disassociated due to inactivity
Mon Jul 19 01:29:32 2021 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Mon Jul 19 01:29:32 2021 kern.debug kernel: [51526.365531] ieee80211 phy0: staid 2 deleted
Mon Jul 19 01:29:33 2021 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 2)
Mon Jul 19 01:29:33 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED xx:xx:xx:xx:xx:xx
Mon Jul 19 01:29:33 2021 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Mon Jul 19 01:29:33 2021 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED xx:xx:xx:xx:xx:xx
Mon Jul 19 01:29:34 2021 daemon.info dnsmasq-dhcp[3399]: DHCPREQUEST(br-lan) 192.168.1.132 xx:xx:xx:xx:xx:xx
Mon Jul 19 01:29:34 2021 daemon.info dnsmasq-dhcp[3399]: DHCPACK(br-lan) 192.168.1.132 xx:xx:xx:xx:xx:xx S10e
Mon Jul 19 01:29:34 2021 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated

same of me, bro. I have the same issue about the WIFI signal, actually It even can't trumped my ONT(10$ for brand new), And my log just like you.
But close range didnt fix my situation, because my router in the close range(less 5m, If you count it on straightly.)

Try to disable the option "Disassociate On Low Acknowledgement" . If that doesn't work try to also enable the option "Disable Inactivity Polling" .

OK, Bro. thanks for your help. I will do it and if it work or not I will feedback it.
Have a nice day!

Hello bro, I have follow your instruction, but it didn't work. the issue still came out.

PS: Maybe you will be interesting when the issue came out look like I can download but can't upload. I will say that because this issue came out at the same time I can get the message on the whatsapp but can't reply or see picture.(see whole picture) @MarioK239

Thanks for your help again.

I still have the same issue as well. I found a link in another forum that says they have work-around: https://forum.turris.cz/t/solution-found-for-wifi-clients-disconnects/6065

config wifi-iface
   ...
   option wpa_group_rekey '86400'
   ...

About to try it myself. The value above is 24 hours.

OpenWRT config resource is here:

This setting didn't fix my issue.

Thanks for let me konw. Very sad about this issue

The following option has giving me some relief:

option max_inactivity '43200'

thanks for let me konw.
It fix your issue? now I testing it.
Update: Look like it don't fix my issue. Still have the problem.@ByteEnable

It fixed mine.

I retest It twice, not work for me. But thanks for you help.

Can you share your log?