Amazon FireTV Stick >AP-STA-POSSIBLE-PSK-MISMATCH @ Xiaomi Redmi Router AC2100

Hi,

I cant connect my new FireTV Stick to my new Xiaomi Redmi Router AC2100 witch runs OpenWRT 21.02.0-rc4.

The funny thing is, when I move the stick near my other WiFi AP with a D-link DAP-2695-A2 which also runs OpenWRT 21.02.0-rc4 it works.

On my Redmi Router I get the message:
Sat Sep 4 18:43:13 2021 daemon.notice hostapd: wlan5g: AP-STA-POSSIBLE-PSK-MISMATCH 80:6d:71:a2:XX:XX

Also on the FireTV I get the message for authentication problem. I have the password transferred with WPS-Key function.

My WiFi setup for wlan2g and wlan5g interfaces are the same...

config wifi-iface 'wlan2g'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SSID'
        option key 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        option wpa_group_rekey '300'
        option wps_pushbutton '1'
        option ifname 'wlan2g'
        option encryption 'sae-mixed'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option nasid '64644AXXXXXX'
        option mobility_domain '4c8a'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option r1_key_holder '64644AXXXXXX'
        list r0kh '64:64:4A:XX:XX:XX,64644AXXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '64:64:4A:XX:XX:XX,64644AXXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh 'A4:2B:B0:XX:XX:XX,A42BB0XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh 'A4:2B:B0:XX:XX:XX,A42BB0XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '14:CC:20:XX:XX:XX,14CC20XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '14:CC:20:XX:XX:XX,14CC20XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '64:64:4A:XX:XX:XX,64:64:4A:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '64:64:4A:XX:XX:XX,64:64:4A:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh 'A4:2B:B0:XX:XX:XX,A4:2B:B0:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh 'A4:2B:B0:XX:XX:XX,A4:2B:B0:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '14:CC:20:XX:XX:XX,14:CC:20:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '14:CC:20:XX:XX:XX,14:CC:20:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'

config wifi-iface 'wlan5g'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'SSID'
        option key 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        option wpa_group_rekey '300'
        option ifname 'wlan5g'
        option encryption 'sae-mixed'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211r '1'
        option nasid '64644AXXXXXX'
        option mobility_domain '4c8a'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option r1_key_holder '64644AXXXXXX'
        list r0kh '64:64:4A:XX:XX:XX,64644AXXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '64:64:4A:XX:XX:XX,64644AXXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh 'A4:2B:B0:XX:XX:XX,A42BB0XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh 'A4:2B:B0:XX:XX:XX,A42BB0XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '14:CC:20:XX:XX:XX,14CC20XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r0kh '14:CC:20:XX:XX:XX,14CC20XXXXXX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '64:64:4A:XX:XX:XX,64:64:4A:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '64:64:4A:XX:XX:XX,64:64:4A:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh 'A4:2B:B0:XX:XX:XX,A4:2B:B0:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh 'A4:2B:B0:XX:XX:XX,A4:2B:B0:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '14:CC:20:XX:XX:XX,14:CC:20:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
        list r1kh '14:CC:20:XX:XX:XX,14:CC:20:XX:XX:XX,XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'

This is the first client who has problems to connect....my D-Link AP has also the same wireless config. Any idea how to fix this?

I've had this problem with Raspberry Pi 4 before. This problem is discussed in this thread.

You can see if it's similar by setting WPA2 and disabling 802.11w. If that works, it sounds similar.

I was thinking, maybe when I push the key with WPS it get bond to the BSSID - and I pushed the key with 2g interface.

But for a test I activated wps also on the 5g interface, deleted the wifi on the firetv stick and pushed it again with the 5g interface with the same problem

at least I got it running:
not funny - but I entered my 63 char long WPA key and this was working.

What ever is different when I enter it manually.... :woozy_face

When I did the first setup of the stick I was close to the D-Link AP and also used the WPS feature.

Just wanted to report back - this problem was coming back on a lot of other devices.

  1. on two Huawai Mate 10 pro devices from my sons running Android 10
  2. my Lenovo T430 running Windows 10

The funny thing is, it was not related to my Redmi AC2100 - I got the problem also on my TP-Link Archer C2600 on 21.02.1 - which I replaced the AC2100 with, because the Redmi is not compatible with 19.07

It seams a problem in 21.02 - I wonder if I am the only one. I twitched now back to 19.07 on my Archer C2600 with the same wifi settings, I was running 21.02. The only thing I am missing is dawn....

Oh and I really tested with simple wifi config like:

        option encryption 'psk2+ccmp'
        option wpa_disable_eapol_key_retries '0'
        option wpa_group_rekey '300'
        option wps_pushbutton '1'
        option tdls_prohibit '0'
        option ieee80211w '0'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

I did also a test where I switched ieee80211r to 0

Maybe it is also related to dawn.... but I am happy now to have a running setup.