Alter vlan switch to allow management on lan subnet instead of vlan subnet

id like to have the following

lan 192.168.40.1
vlan10 192.168.10.1
vlan100 192.168.100.1
vlan101 192.168.101.1
vlan102 192.168.102.1
(this is all configured in the router)

id like the switch to let me access the webui at 192.168.40.2 instead of on vlan10

here is my network config file

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth2'
        list ports 'eth3'
        list ports 'eth4'

config interface 'vlan10'
        option device 'br-lan.10'
        option proto 'static'
        option ipaddr '192.168.10.2'
        option netmask '255.255.255.0'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'eth0:t'
        list ports 'eth1:u*'

config interface 'vlan100'
        option device 'br-lan.100'
        option proto 'none'

config bridge-vlan
        option device 'br-lan'
        option vlan '100'
        list ports 'eth0:t'
        list ports 'eth2:u*'

config interface 'vlan101'
        option device 'br-lan.101'
        option proto 'none'

config bridge-vlan
        option device 'br-lan'
        option vlan '101'
        list ports 'eth0:t'
        list ports 'eth3:u*'

config interface 'vlan102'
        option device 'br-lan.102'
        option proto 'none'

config bridge-vlan
        option device 'br-lan'
        option vlan '102'
        list ports 'eth0:t'
        list ports 'eth4:u*'

If you want to do this, usually that means putting that address in the switch itself and making sure you've got the correct VLAN selected for the management VLAN.

What address does the switch hold currently?

The network file above is my Edgerouter x acting as a switch. Currently I manage on vlan10, is it possible to manage on the lan instead?

LAN ip 192.168.40.1
Vlan10 ip 192.168.10.1

Thanks for the clarification.

Can you post your main router's network config -- we need to make sure we're sending the lan over the trunk.