All network connectivity lost after update

Hi All,

I installed openWRT on my ZyXEL XGS1250-12 switch and now I can only interact with the switch using Serial connection. Any device I connect to the switch using an Ethernet cable can't connect to the switch, and the switch's Ethernet ports don't have link lights anymore.

I got myself here by doing the following:

  • I followed the OEM easy installation instructions and then rebooted.
  • After the reboot, I logged into the web interface, and saw that the following message displayed at the top of the page: " System running in recovery (initramfs) mode. No changes to settings will be stored and are lost after rebooting. This mode should only be used to install a firmware upgrade". I took that to mean I needed to install the "Factory sysupgrade image", which I downloaded from the switch's hardware page and installed using the web interface.

This time when I rebooted the switch, it did not re-connect to my network. I can't connect to the switch through the web interface, ssh, and as far as I can tell, the switch is incapable of networking. I can still interact with the switch using a Serial connection.

This is what the switch's /etc/config/network looks like:

interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd34:5f81:7939::/48'

config device 'switch'
        option name 'switch'
        option type 'bridge'
        option macaddr 'f4:4d:5c:9b:6e:28'

config bridge-vlan 'lan_vlan'
        option device 'switch'
        option vlan '1'
        option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 lan12'

config device
        option name 'switch.1'
        option macaddr 'f4:4d:5c:9b:6e:28'

config interface 'lan'
        option device 'switch.1'
        option proto 'static'
        option ipaddr '192.168.1.5'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

Restoring that file to the way it was when openWRT was first installed did not help. The original /etc/config/network file is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd34:5f81:7939::/48'

config device 'switch'
        option name 'switch'
        option type 'bridge'
        option macaddr 'f4:4d:5c:9b:6e:28'

config bridge-vlan 'lan_vlan'
        option device 'switch'
        option vlan '1'
        option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 lan12'

config device
        option name 'switch.1'
        option macaddr 'f4:4d:5c:9b:6e:28'

config interface 'lan'
        option device 'switch.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Power cycling the switch, and the commands service network restart/service network reload don't help. Link lights don't appear on the ethernet ports, but when I disconnect and reconnect an ethernet cable, I get this in the Serial console:

[74226.978804] rtl83xx-switch switch@1b000000 lan1: Link is Down
[74226.985338] switch: port 1(lan1) entered disabled state
[74234.259112] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[74234.268723] switch: port 1(lan1) entered blocking state
[74234.274559] switch: port 1(lan1) entered forwarding state

I don't know what else to do to troubleshoot. Any suggestions would be welcome. Thanks for reading!

First, I think that you shoud have uploaded the sysupgrade image, not the factory one.

Can you show the dmesg log?

So after the initial openWRT installation, I should have used the "Factory snapshot image" instead of "Factory sysupgrade image"?

Yeah, from dmesg:

[    0.000000] Linux version 6.6.74 (builder@buildhost) (mips-openwrt-linux-musl-gcc (OpenWrt GCC 13.3.0 r28724-807074309d) 13.3.0, GNU ld (GNU Binutils) 2.42) #0 Tue Jan 28 19:59:04 2025
[    0.000000] RTL838X model is 0
[    0.000000] RTL839X model is 0
[    0.000000] RTL93XX model is 93021001
[    0.000000] SoC Type: RTL9302B
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019555 (MIPS 34Kc)
[    0.000000] MIPS: machine is Zyxel XGS1250-12 Switch
[    0.000000] earlycon: ns16550a0 at MMIO 0x18002000 (options '115200n8')
[    0.000000] printk: bootconsole [ns16550a0] enabled
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Using appended Device Tree.
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Kernel command line: earlycon
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00031940
[    0.000000] Readback ErrCtl register=00031940
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 119032K/131072K available (6969K kernel code, 628K rwdata, 1608K rodata, 1220K init, 256K bss, 12040K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] Failed to get CPU clock: -2
[    0.000000] CPU frequency from device tree: 800MHz
[    0.000000] clocksource: realtek_otto_timer: mask: 0xfffffff max_cycles: 0xfffffff, max_idle_ns: 38225208801 ns
[    0.000001] sched_clock: 28 bits at 3125kHz, resolution 320ns, wraps every 42949672800ns
[    0.009036] Calibrating delay loop... 531.66 BogoMIPS (lpj=2658304)
[    0.065702] pid_max: default: 32768 minimum: 301
[    0.080781] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.088774] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.106818] RCU Tasks Trace: Setting shift to 0 and lim to 1 rcu_task_cb_adjust=1 rcu_task_cpu_ids=1.
[    0.123174] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.133974] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.144057] pinctrl core: initialized pinctrl subsystem
[    0.152404] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.159686] thermal_sys: Registered thermal governor 'step_wise'
[    0.174719] clocksource: Switched to clocksource realtek_otto_timer
[    0.199285] NET: Registered PF_INET protocol family
[    0.204957] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.214423] tcp_listen_portaddr_hash hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.223735] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.232229] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.240628] TCP bind hash table entries: 1024 (order: 1, 8192 bytes, linear)
[    0.248368] TCP: Hash tables configured (established 1024 bind 1024)
[    0.256105] MPTCP token hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.264278] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.271507] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.280109] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.292563] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.301432] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.307882] jffs2: version 2.2 (NAND) (SUMMARY) (ZLIB) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.327075] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.336864] pinctrl-single 1b00c600.pinmux: 32 pins, size 4
[    0.343376] pinctrl-single 1b00cc00.pinmux: 32 pins, size 4
[    0.351529] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.365287] printk: console [ttyS0] disabled
[    0.370595] 18002000.uart: ttyS0 at MMIO 0x18002000 (irq = 30, base_baud = 10937500) is a 16550A
[    0.380303] printk: console [ttyS0] enabled
[    0.389652] printk: bootconsole [early0] disabled
[    0.436453] printk: bootconsole [ns16550a0] disabled
[    0.486275] brd: module loaded
[    0.495042] spi-nor spi0.0: mx25l12805d (16384 Kbytes)
[    0.500942] 7 fixed-partitions partitions found on MTD device spi0.0
[    0.508174] OF: Bad cell count for /soc/spi@1200/flash@0/partitions
[    0.515231] OF: Bad cell count for /soc/spi@1200/flash@0/partitions
[    0.522513] Creating 7 MTD partitions on "spi0.0":
[    0.527922] 0x000000000000-0x0000000e0000 : "u-boot"
[    0.536755] 0x0000000e0000-0x0000000f0000 : "u-boot-env"
[    0.545087] 0x0000000f0000-0x000000100000 : "u-boot-env2"
[    0.553547] 0x000000100000-0x000000200000 : "jffs"
[    0.561331] 0x000000200000-0x000000300000 : "jffs2"
[    0.569179] 0x000000300000-0x000000fe0000 : "firmware"
[    0.577684] 2 uimage-fw partitions found on MTD device firmware
[    0.584299] Creating 2 MTD partitions on "firmware":
[    0.589884] 0x000000000000-0x0000003c0000 : "kernel"
[    0.597852] 0x0000003c0000-0x000000ce0000 : "rootfs"
[    0.605883] mtd: setting mtd7 (rootfs) as root device
[    0.611583] 1 squashfs-split partitions found on MTD device rootfs
[    0.618533] 0x0000005d0000-0x000000ce0000 : "rootfs_data"
[    0.626999] 0x000000fe0000-0x000001000000 : "log"
[    0.646798] Probing RTL838X eth device pdev: 818b2000, dev: 818b2010
[    0.673086] Found SoC ID: 9302: RTL9302B, family 9300
[    0.678886] Using MAC 000000e04c000000
[    0.683105] set sds port 0 to 2
[    0.686698] set sds port 24 to 6
[    0.690300] set sds port 25 to 7
[    0.693889] set sds port 26 to 8
[    0.697516] set sds port 27 to 9
[    0.701930] c45_mask: 000e0000
[    0.770864] mdio_bus mdio-bus: MDIO device at address 24 is missing.
[    0.784377] mdio_bus mdio-bus: MDIO device at address 25 is missing.
[    0.797895] mdio_bus mdio-bus: MDIO device at address 26 is missing.
[    0.808642] REALTEK RTL9300 SERDES mdio-bus:1b: Detected internal RTL9300 Serdes
[    0.826265] i2c_dev: i2c /dev entries driver
[    0.831198] rtl9300_i2c_probe probing I2C adapter
[    0.836541] i2c-rtl9300 1b00036c.i2c-rtl9300: SCL speed 100000, mode is 0
[    0.844097] rtl9300_i2c_probe scl_num 0
[    0.848390] rtl9300_i2c_probe sda_num 1
[    0.856658] NET: Registered PF_INET6 protocol family
[    0.876399] Segment Routing with IPv6
[    0.880632] In-situ OAM (IOAM) with IPv6
[    0.885266] NET: Registered PF_PACKET protocol family
[    0.890947] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.906058] 8021q: 802.1Q VLAN Support v1.8
[    0.933947] sfp sfp-p12: Host maximum power 1.0W
[    1.004976] REALTEK RTL9300 SERDES rtl838x slave mii-0:1b: Detected internal RTL9300 Serdes
[    1.026432] REALTEK RTL9300 SERDES rtl838x slave mii-0:3f: Detected internal RTL9300 Serdes
[    1.046067] rtl93xx_setup called
[    1.049724] In rtl83xx_vlan_setup
[    1.053405] In rtl930x_vlan_profile_setup
[    1.057916] In rtl930x_vlan_profile_setup
[    1.062380] UNKNOWN_MC_PMASK: 000000001fffffff
[    1.067346] VLAN 0: L2 learn: 0; Unknown MC PMasks: L2 1fffffff, IPv4 1fffffff, IPv6: 1fffffff
[    1.067365]   Routing enabled: IPv4 UC y, IPv6 UC y, IPv4 MC y, IPv6 MC y
[    1.084511]   Bridge enabled: IPv4 MC n, IPv6 MC n,
[    1.089972] VLAN profile 0: raw 00033000 00000000 1fffffff 1fffffff 1fffffff
[    1.284089] sfp sfp-p12: module Arista Networks  QT-SFP-10G-T     rev 0002 sn QT202003111012   dc 221014
[    1.353051] hwmon hwmon0: temp1_input not attached to any thermal zone
[    2.174768] rtl83xx_enable_phy_polling:          f0000ff
[    2.180712] rtl930x_pie_init
[    2.184128] rtl930x_led_init called
[    2.188153] rtl930x_led_init led_set configuration invalid skipping over this set
[    2.196542] rtl930x_led_init bb00cc00: 01052659
[    2.201587] rtl930x_led_init bb00cc04: aaaa5555
[    2.206653] rtl930x_led_init bb00cc08: 007faaaa
[    2.211698] rtl930x_led_init bb00cc0c: 00000000
[    2.216754] rtl930x_led_init bb00cc10: 00000000
[    2.221792] rtl930x_led_init bb00cc14: 00000000
[    2.226847] rtl930x_led_init bb00cc18: 0a200a01
[    2.231886] rtl930x_led_init bb00cc1c: 0a0b0a28
[    2.236950] rtl930x_led_init bb00cc20: 0a820a0b
[    2.241988] rtl930x_led_init bb00cc24: 00000000
[    2.247044] rtl930x_led_init bb00cc28: 0a200b80
[    2.252081] rtl930x_led_init bb00cc2c: 00000000
[    2.257137] rtl930x_led_init bb00cc30: 00950000
[    2.262176] rtl930x_led_init bb00cc34: 00000000
[    2.267240] rtl930x_led_init bb00cc38: 00950000
[    2.272278] rtl930x_led_init bb00cc3c: 0f0000ff
[    2.277342] rtl930x_led_init bb00cc40: 0f0000ff
[    2.282381] rtl930x_led_init bb00cc44: 0f0000ff
[    2.287444] rtl930x_led_init bb00cc48: 00000000
[    2.292483] rtl930x_led_init bb00cc4c: 00000000
[    2.297555] rtl930x_led_init bb00cc50: 00000000
[    2.302593] rtl930x_led_init bb00cc54: 00000000
[    2.307652] rtl930x_led_init bb00cc58: 00000000
[    2.312696] rtl930x_led_init bb00cc5c: 00000000
[    2.317932] rtl83xx-switch switch@1b000000: configuring for fixed/internal link mode
[    2.326624] rtl93xx_phylink_mac_config port 28, mode 1, phy-mode: internal, speed -1, link 0
[    2.337631] rtl83xx-switch switch@1b000000 lan1 (uninitialized): PHY [mdio-bus:00] driver [Generic PHY] (irq=POLL)
[    2.351995] rtl83xx-switch switch@1b000000 lan2 (uninitialized): PHY [mdio-bus:01] driver [Generic PHY] (irq=POLL)
[    2.366518] rtl83xx-switch switch@1b000000 lan3 (uninitialized): PHY [mdio-bus:02] driver [Generic PHY] (irq=POLL)
[    2.381045] rtl83xx-switch switch@1b000000 lan4 (uninitialized): PHY [mdio-bus:03] driver [Generic PHY] (irq=POLL)
[    2.395468] rtl83xx-switch switch@1b000000 lan5 (uninitialized): PHY [mdio-bus:04] driver [Generic PHY] (irq=POLL)
[    2.409906] rtl83xx-switch switch@1b000000 lan6 (uninitialized): PHY [mdio-bus:05] driver [Generic PHY] (irq=POLL)
[    2.424381] rtl83xx-switch switch@1b000000 lan7 (uninitialized): PHY [mdio-bus:06] driver [Generic PHY] (irq=POLL)
[    2.438853] rtl83xx-switch switch@1b000000 lan8 (uninitialized): PHY [mdio-bus:07] driver [Generic PHY] (irq=POLL)
[    2.452036] rtl83xx-switch switch@1b000000 lan9 (uninitialized): no phy at 24
[    2.460066] rtl83xx-switch switch@1b000000 lan9 (uninitialized): failed to connect to PHY: -ENODEV
[    2.470076] rtl83xx-switch switch@1b000000 lan9 (uninitialized): error -19 setting up PHY for tree 0, switch 0, port 24
[    2.482323] rtl83xx-switch switch@1b000000 lan10 (uninitialized): no phy at 25
[    2.490443] rtl83xx-switch switch@1b000000 lan10 (uninitialized): failed to connect to PHY: -ENODEV
[    2.500551] rtl83xx-switch switch@1b000000 lan10 (uninitialized): error -19 setting up PHY for tree 0, switch 0, port 25
[    2.512895] rtl83xx-switch switch@1b000000 lan11 (uninitialized): no phy at 26
[    2.521024] rtl83xx-switch switch@1b000000 lan11 (uninitialized): failed to connect to PHY: -ENODEV
[    2.531134] rtl83xx-switch switch@1b000000 lan11 (uninitialized): error -19 setting up PHY for tree 0, switch 0, port 26
[    2.543526] rtl83xx-switch switch@1b000000 lan12 (uninitialized): switched to inband/10gbase-r link mode
[    2.555764] rtl838x-eth 1b00a300.ethernet eth0: entered promiscuous mode
[    2.563335] DSA: tree 0 setup
[    2.566782] LINK state irq: 23
[    2.570226] In rtl83xx_setup_qos
[    2.573874] L3_IPUC_ROUTE_CTRL 00002000, IPMC_ROUTE 0000077e, IP6UC_ROUTE 00014400, IP6MC_ROUTE 0001db7e
[    2.584468] L3_IPUC_ROUTE_CTRL 00002001, IPMC_ROUTE 00000501, IP6UC_ROUTE 00014581, IP6MC_ROUTE 00012881
[    2.595043] L3_IP_ROUTE_CTRL 0000013f
[    2.599249] rtl930x_dbgfs_init called
[    2.608274] rtl83xx-switch switch@1b000000: Link is Up - 10Gbps/Full - flow control off
[    2.617436] rtl83xx_fib_event_work_do: FIB4 default rule failed
[    2.624045] rtl83xx_fib_event_work_do: FIB4 default rule failed
[    2.643064] clk: Disabling unused clocks
[    2.653925] VFS: Mounted root (squashfs filesystem) readonly on device 31:7.
[    2.667066] Freeing unused kernel image (initmem) memory: 1220K
[    2.673677] This architecture does not have kernel memory protection.
[    2.680897] Run /sbin/init as init process
[    2.685482]   with arguments:
[    2.688780]     /sbin/init
[    2.691781]   with environment:
[    2.695293]     HOME=/
[    2.697917]     TERM=linux
[    3.175659] init: Console is alive
[    3.179875] init: - watchdog -
[    3.488112] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.533781] gpio_button_hotplug: loading out-of-tree module taints kernel.
[    3.546223] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.565063] init: - preinit -
[    6.884778] random: crng init done
[    8.316753] RESETTING 9300, CPU_PORT 28
[    8.521400] rtl838x-eth 1b00a300.ethernet eth0: configuring for fixed/internal link mode
[    8.530403] In rtl838x_mac_config, mode 1
[    8.535670] rtl83xx-switch switch@1b000000 lan1: configuring for phy/xgmii link mode
[    8.544319] rtl93xx_phylink_mac_config port 0, mode 0, phy-mode: xgmii, speed -1, link 0
[    8.553377] rtl93xx_phylink_mac_config SDS is 2
[    8.558637] 8021q: adding VLAN 0 to HW filter on device lan1
[    8.565245] rtl838x-eth 1b00a300.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[    8.576103] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[    8.583467] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[    8.597930] rtl83xx_fib_event_work_do: FIB4 failed
[    8.603294] rtl83xx_fib_event_work_do: FIB4 failed
[    8.608742] rtl83xx_fib_event_work_do: FIB4 failed
[   10.414782] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   11.695505] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[   12.875850] jffs2: notice: (729) jffs2_build_xattr_subsystem: complete building xattr subsystem, 12 of xdatum (0 unchecked, 3 orphan) and 15 of xref (3 dead, 0 orphan) found.
[   12.895211] mount_root: switching to jffs2 overlay
[   12.902985] overlayfs: upper fs does not support tmpfile.
[   12.917304] urandom-seed: Seeding with /etc/urandom.seed
[   13.003050] rtl83xx_fib4_del: no such gateway: 0.0.0.0
[   13.013994] rtl83xx-switch switch@1b000000 lan1: Link is Down
[   13.033296] procd: - early -
[   13.037586] rtl83xx_fib4_del: no such gateway: 0.0.0.0
[   13.043788] procd: - watchdog -
[   13.094817] rtl83xx_fib4_del: no such gateway: 0.0.0.0
[   13.757983] procd: - watchdog -
[   13.762600] procd: - ubus -
[   13.871083] procd: - init -
[   14.920900] kmodloader: loading kernel modules from /etc/modules.d/*
[   15.009228] gpio-fan gpio-fan: GPIO fan initialized
[   15.185419] kmodloader: done loading kernel modules from /etc/modules.d/*
[   16.628985] urngd: v1.0.2 started.
[   18.215769] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   24.289671] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   24.348254] in rtl838x_eth_stop
[   24.351875] rtl838x-eth 1b00a300.ethernet eth0: Link is Down
[   24.894065] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   24.901454] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   24.908817] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   24.916173] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   25.109795] Using MAC 0000f44d5c9b6e28
[   25.114214] RESETTING 9300, CPU_PORT 28
[   25.318849] rtl838x-eth 1b00a300.ethernet eth0: configuring for fixed/internal link mode
[   25.327853] In rtl838x_mac_config, mode 1
[   25.335337] rtl838x-eth 1b00a300.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   25.344696] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   25.352151] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   25.484480] rtl83xx-switch switch@1b000000 lan1: configuring for phy/xgmii link mode
[   25.493204] rtl93xx_phylink_mac_config port 0, mode 0, phy-mode: xgmii, speed -1, link 0
[   25.502266] rtl93xx_phylink_mac_config SDS is 2
[   25.507656] 8021q: adding VLAN 0 to HW filter on device lan1
[   25.562611] switch: port 1(lan1) entered blocking state
[   25.568515] switch: port 1(lan1) entered disabled state
[   25.574374] rtl83xx-switch switch@1b000000 lan1: entered allmulticast mode
[   25.582108] rtl838x-eth 1b00a300.ethernet eth0: entered allmulticast mode
[   25.590560] rtl83xx-switch switch@1b000000 lan1: entered promiscuous mode
[   25.646711] rtl930x_set_l3_egress_intf writing to index 0: 00000201 10101492
[   25.661263] Not offloading default route for now
[   25.720699] rtl83xx-switch switch@1b000000 lan2: configuring for phy/xgmii link mode
[   25.729424] rtl93xx_phylink_mac_config port 1, mode 0, phy-mode: xgmii, speed -1, link 0
[   25.738486] rtl93xx_phylink_mac_config SDS is -1
[   25.743866] 8021q: adding VLAN 0 to HW filter on device lan2
[   25.832165] switch: port 2(lan2) entered blocking state
[   25.838070] switch: port 2(lan2) entered disabled state
[   25.843930] rtl83xx-switch switch@1b000000 lan2: entered allmulticast mode
[   25.915376] rtl83xx-switch switch@1b000000 lan2: entered promiscuous mode
[   25.967355] rtl83xx-switch switch@1b000000 lan3: configuring for phy/xgmii link mode
[   25.976066] rtl93xx_phylink_mac_config port 2, mode 0, phy-mode: xgmii, speed -1, link 0
[   25.985133] rtl93xx_phylink_mac_config SDS is -1
[   25.990523] 8021q: adding VLAN 0 to HW filter on device lan3
[   26.024767] switch: port 3(lan3) entered blocking state
[   26.030623] switch: port 3(lan3) entered disabled state
[   26.036535] rtl83xx-switch switch@1b000000 lan3: entered allmulticast mode

output from dmseg part 2:

[   26.075490] rtl83xx-switch switch@1b000000 lan3: entered promiscuous mode
[   26.123891] rtl83xx-switch switch@1b000000 lan4: configuring for phy/xgmii link mode
[   26.132598] rtl93xx_phylink_mac_config port 3, mode 0, phy-mode: xgmii, speed -1, link 0
[   26.141655] rtl93xx_phylink_mac_config SDS is -1
[   26.147061] 8021q: adding VLAN 0 to HW filter on device lan4
[   26.183846] switch: port 4(lan4) entered blocking state
[   26.189755] switch: port 4(lan4) entered disabled state
[   26.195669] rtl83xx-switch switch@1b000000 lan4: entered allmulticast mode
[   26.255398] rtl83xx-switch switch@1b000000 lan4: entered promiscuous mode
[   26.328649] rtl83xx-switch switch@1b000000 lan5: configuring for phy/xgmii link mode
[   26.337373] rtl93xx_phylink_mac_config port 4, mode 0, phy-mode: xgmii, speed -1, link 0
[   26.346425] rtl93xx_phylink_mac_config SDS is -1
[   26.351818] 8021q: adding VLAN 0 to HW filter on device lan5
[   26.400741] switch: port 5(lan5) entered blocking state
[   26.406645] switch: port 5(lan5) entered disabled state
[   26.412504] rtl83xx-switch switch@1b000000 lan5: entered allmulticast mode
[   26.465415] rtl83xx-switch switch@1b000000 lan5: entered promiscuous mode
[   26.502243] rtl83xx-switch switch@1b000000 lan6: configuring for phy/xgmii link mode
[   26.510946] rtl93xx_phylink_mac_config port 5, mode 0, phy-mode: xgmii, speed -1, link 0
[   26.520004] rtl93xx_phylink_mac_config SDS is -1
[   26.525411] 8021q: adding VLAN 0 to HW filter on device lan6
[   26.575364] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   26.582713] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[   26.615699] switch: port 6(lan6) entered blocking state
[   26.621546] switch: port 6(lan6) entered disabled state
[   26.627485] rtl83xx-switch switch@1b000000 lan6: entered allmulticast mode
[   26.636087] rtl83xx-switch switch@1b000000 lan6: entered promiscuous mode
[   26.742106] rtl83xx-switch switch@1b000000 lan7: configuring for phy/xgmii link mode
[   26.750817] rtl93xx_phylink_mac_config port 6, mode 0, phy-mode: xgmii, speed -1, link 0
[   26.759883] rtl93xx_phylink_mac_config SDS is -1
[   26.765274] 8021q: adding VLAN 0 to HW filter on device lan7
[   26.855390] switch: port 7(lan7) entered blocking state
[   26.861232] switch: port 7(lan7) entered disabled state
[   26.867178] rtl83xx-switch switch@1b000000 lan7: entered allmulticast mode
[   26.875791] rtl83xx-switch switch@1b000000 lan7: entered promiscuous mode
[   26.997808] rtl83xx-switch switch@1b000000 lan8: configuring for phy/xgmii link mode
[   27.006513] rtl93xx_phylink_mac_config port 7, mode 0, phy-mode: xgmii, speed -1, link 0
[   27.015570] rtl93xx_phylink_mac_config SDS is -1
[   27.020973] 8021q: adding VLAN 0 to HW filter on device lan8
[   27.112449] switch: port 8(lan8) entered blocking state
[   27.118360] switch: port 8(lan8) entered disabled state
[   27.124225] rtl83xx-switch switch@1b000000 lan8: entered allmulticast mode
[   27.132853] rtl83xx-switch switch@1b000000 lan8: entered promiscuous mode
[   27.228428] rtl83xx-switch switch@1b000000 lan12: configuring for inband/10gbase-r link mode
[   27.237904] rtl93xx_phylink_mac_config port 27, mode 2, phy-mode: 10gbase-r, speed -1, link 0
[   27.247444] rtl93xx_phylink_mac_config SDS is 9
[   27.252483] rtl9300_sds_rst 31
[   27.382753] rtl9300_phy_enable_10g_1g 1gbit phy: 00001140
[   27.389797] rtl9300_phy_enable_10g_1g 1gbit phy enabled: 00001140
[   27.397607] rtl9300_phy_enable_10g_1g 10gbit phy: 00002040
[   27.404740] rtl9300_phy_enable_10g_1g 10gbit phy after: 00002040
[   27.412427] rtl9300_phy_enable_10g_1g set medium: 00000002
[   27.419558] rtl9300_phy_enable_10g_1g set medium after: 00000002
[   27.446243] rtl9300_serdes_setup: Configuring RTL9300 SERDES 9
[   27.454757] rtl9300_serdes_mac_link_config: registers before 00000000 00001403
[   27.466813] rtl9300_serdes_mac_link_config: registers after 00000000 00001403
[   27.474784] rtl9300_force_sds_mode: SDS: 9, mode 28
[   27.480216] rtl9300_force_sds_mode --------------------- serdes 9 forcing to 1a ...
[   27.800264] rtl9300_force_sds_mode --------------------- serdes 9 forced to 1a DONE
[   28.110479] rtl9300_sds_10g_idle WARNING: Waiting for RX idle timed out, SDS 9
[   28.118554] start_1.1.1 initial value for sds 9
[   28.180539] end_1.1.1 --
[   28.183361] start_1.1.2 Load DFE init. value
[   28.190135] end_1.1.2
[   28.192664] start_1.1.3 disable LEQ training,enable DFE clock
[   28.211068] end_1.1.3 --
[   28.213888] start_1.1.4 offset cali setting
[   28.220557] end_1.1.4
[   28.223086] start_1.1.5 LEQ and DFE setting
[   28.241744] end_1.1.5
[   28.253279] start_1.2.1 ForegroundOffsetCal_Manual
[   28.262633] end_1.2.1
[   28.273638] start_1.2.3 Foreground Calibration
[   28.292129] rtl9300_do_rx_calibration_2_3: fgcal_gray: 21, fgcal_binary 31
[   28.300815] rtl9300_do_rx_calibration_2_3: end_1.2.3
[   28.306371] start_1.4.1
[   28.529954] end_1.4.1
[   28.532683] start_1.4.2
[   28.545225] vth_set_bin = 7
[   28.547945] vth_set_bin = 7
[   28.552041] Vth Maunal = 0
[   28.670960] Tap0 Sign : +
[   28.673977] tap0_coef_bin = 31
[   28.677910] tap0 manual = 0
[   28.687319] end_1.4.2
[   28.690426] start_1.5.2
[   28.770827] end_1.5.2
[   28.794529] rtl9300_do_rx_calibration: SDS enabled
[   28.874454] 8021q: adding VLAN 0 to HW filter on device lan12
[   28.895844] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[   28.915966] switch: port 1(lan1) entered blocking state
[   28.921811] switch: port 1(lan1) entered forwarding state
[   29.261073] sfp sfp-p12: module Arista Networks  QT-SFP-10G-T     rev 0002 sn QT202003111012   dc 221014
[   29.274277] switch: port 9(lan12) entered blocking state
[   29.280315] switch: port 9(lan12) entered disabled state
[   29.286341] rtl83xx-switch switch@1b000000 lan12: entered allmulticast mode
[   29.295028] rtl83xx-switch switch@1b000000 lan12: entered promiscuous mode
[   29.342353] hwmon hwmon2: temp1_input not attached to any thermal zone
[  763.138782] rtl83xx-switch switch@1b000000 lan1: Link is Down
[  763.145310] switch: port 1(lan1) entered disabled state
[  796.419093] rtl83xx-switch switch@1b000000 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
[  796.428715] switch: port 2(lan2) entered blocking state
[  796.434552] switch: port 2(lan2) entered forwarding state
[  995.531448] rtl83xx-switch switch@1b000000: unknown nexthop, id 0
[  995.538389] rtl83xx-switch switch@1b000000: unknown nexthop, id 0
[  995.545249] rtl930x_route_lookup_hw: searching for 192.168.1.0
[  995.551746] rtl930x_route_lookup_hw: found: 0, index: 0
[  995.557600] rtl83xx_route_rm: Got id for prefix route: -1
[  995.563664] rtl83xx_fib4_del: no such gateway: 0.0.0.0
[  995.620674] rtl83xx_fib4_del: no such gateway: 192.168.1.1
[  995.635290] switch: port 2(lan2) entered disabled state
[  995.642088] rtl83xx-switch switch@1b000000 lan1: left allmulticast mode
[  995.649566] rtl83xx-switch switch@1b000000 lan1: left promiscuous mode
[  995.657021] switch: port 1(lan1) entered disabled state
[  995.672304] rtl83xx-switch switch@1b000000 lan12: left allmulticast mode
[  995.679854] rtl83xx-switch switch@1b000000 lan12: left promiscuous mode
[  995.687430] switch: port 9(lan12) entered disabled state
[  995.698784] rtl83xx-switch switch@1b000000 lan2: left allmulticast mode
[  995.706239] rtl83xx-switch switch@1b000000 lan2: left promiscuous mode
[  995.713715] switch: port 2(lan2) entered disabled state
[  995.721391] rtl83xx-switch switch@1b000000 lan2: Link is Down
[  995.732854] rtl83xx-switch switch@1b000000 lan3: left allmulticast mode
[  995.740328] rtl83xx-switch switch@1b000000 lan3: left promiscuous mode
[  995.747811] switch: port 3(lan3) entered disabled state
[  995.759995] rtl83xx-switch switch@1b000000 lan4: left allmulticast mode
[  995.767450] rtl83xx-switch switch@1b000000 lan4: left promiscuous mode
[  995.774928] switch: port 4(lan4) entered disabled state
[  995.786814] rtl83xx-switch switch@1b000000 lan5: left allmulticast mode
[  995.794209] rtl83xx-switch switch@1b000000 lan5: left promiscuous mode
[  995.801708] switch: port 5(lan5) entered disabled state
[  995.813851] rtl83xx-switch switch@1b000000 lan6: left allmulticast mode
[  995.821334] rtl83xx-switch switch@1b000000 lan6: left promiscuous mode
[  995.828797] switch: port 6(lan6) entered disabled state
[  995.840619] rtl83xx-switch switch@1b000000 lan7: left allmulticast mode
[  995.848077] rtl83xx-switch switch@1b000000 lan7: left promiscuous mode
[  995.855588] switch: port 7(lan7) entered disabled state
[  995.867751] rtl83xx-switch switch@1b000000 lan8: left allmulticast mode
[  995.875201] rtl838x-eth 1b00a300.ethernet eth0: left allmulticast mode
[  995.882476] rtl83xx-switch switch@1b000000 lan8: left promiscuous mode
[  995.889955] switch: port 8(lan8) entered disabled state
[  995.898792] in rtl838x_eth_stop
[  995.902821] rtl838x-eth 1b00a300.ethernet eth0: Link is Down
[  996.408894] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  996.416283] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  996.423577] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  996.430925] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  998.948102] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  998.988432] RESETTING 9300, CPU_PORT 28
[  999.193072] rtl838x-eth 1b00a300.ethernet eth0: configuring for fixed/internal link mode
[  999.202076] In rtl838x_mac_config, mode 1
[  999.221158] rtl838x-eth 1b00a300.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[  999.231656] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  999.239118] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[  999.302149] rtl83xx-switch switch@1b000000 lan1: configuring for phy/xgmii link mode
[  999.310855] rtl93xx_phylink_mac_config port 0, mode 0, phy-mode: xgmii, speed -1, link 0
[  999.319922] rtl93xx_phylink_mac_config SDS is 2
[  999.325321] 8021q: adding VLAN 0 to HW filter on device lan1
[  999.338534] switch: port 1(lan1) entered blocking state
[  999.344374] switch: port 1(lan1) entered disabled state
[  999.350310] rtl83xx-switch switch@1b000000 lan1: entered allmulticast mode
[  999.358028] rtl838x-eth 1b00a300.ethernet eth0: entered allmulticast mode
[  999.366452] rtl83xx-switch switch@1b000000 lan1: entered promiscuous mode
[  999.396956] Not offloading default route for now
[  999.447701] rtl83xx-switch switch@1b000000 lan2: configuring for phy/xgmii link mode
[  999.456407] rtl93xx_phylink_mac_config port 1, mode 0, phy-mode: xgmii, speed -1, link 0
[  999.465471] rtl93xx_phylink_mac_config SDS is -1
[  999.470915] 8021q: adding VLAN 0 to HW filter on device lan2
[  999.525774] switch: port 2(lan2) entered blocking state
[  999.531617] switch: port 2(lan2) entered disabled state
[  999.537565] rtl83xx-switch switch@1b000000 lan2: entered allmulticast mode
[  999.586140] rtl83xx-switch switch@1b000000 lan2: entered promiscuous mode
[  999.648777] rtl83xx-switch switch@1b000000 lan3: configuring for phy/xgmii link mode
[  999.657481] rtl93xx_phylink_mac_config port 2, mode 0, phy-mode: xgmii, speed -1, link 0
[  999.666553] rtl93xx_phylink_mac_config SDS is -1
[  999.671990] 8021q: adding VLAN 0 to HW filter on device lan3
[  999.693802] switch: port 3(lan3) entered blocking state
[  999.699710] switch: port 3(lan3) entered disabled state
[  999.705630] rtl83xx-switch switch@1b000000 lan3: entered allmulticast mode
[  999.719492] rtl83xx-switch switch@1b000000 lan3: entered promiscuous mode
[  999.751231] rtl83xx-switch switch@1b000000 lan4: configuring for phy/xgmii link mode
[  999.759946] rtl93xx_phylink_mac_config port 3, mode 0, phy-mode: xgmii, speed -1, link 0
[  999.769005] rtl93xx_phylink_mac_config SDS is -1
[  999.774500] 8021q: adding VLAN 0 to HW filter on device lan4
[  999.805524] switch: port 4(lan4) entered blocking state
[  999.811370] switch: port 4(lan4) entered disabled state
[  999.817300] rtl83xx-switch switch@1b000000 lan4: entered allmulticast mode
[  999.837778] rtl83xx-switch switch@1b000000 lan4: entered promiscuous mode
[  999.879714] rtl83xx-switch switch@1b000000 lan5: configuring for phy/xgmii link mode
[  999.888429] rtl93xx_phylink_mac_config port 4, mode 0, phy-mode: xgmii, speed -1, link 0
[  999.897520] rtl93xx_phylink_mac_config SDS is -1
[  999.902981] 8021q: adding VLAN 0 to HW filter on device lan5
[  999.925520] switch: port 5(lan5) entered blocking state
[  999.931362] switch: port 5(lan5) entered disabled state
[  999.937293] rtl83xx-switch switch@1b000000 lan5: entered allmulticast mode
[  999.955507] rtl83xx-switch switch@1b000000 lan5: entered promiscuous mode
[  999.990152] rtl83xx-switch switch@1b000000 lan6: configuring for phy/xgmii link mode
[  999.998860] rtl93xx_phylink_mac_config port 5, mode 0, phy-mode: xgmii, speed -1, link 0
[ 1000.007928] rtl93xx_phylink_mac_config SDS is -1
[ 1000.013416] 8021q: adding VLAN 0 to HW filter on device lan6
[ 1000.065384] switch: port 6(lan6) entered blocking state
[ 1000.071227] switch: port 6(lan6) entered disabled state
[ 1000.077164] rtl83xx-switch switch@1b000000 lan6: entered allmulticast mode
[ 1000.085767] rtl83xx-switch switch@1b000000 lan6: entered promiscuous mode
[ 1000.144893] rtl83xx-switch switch@1b000000 lan7: configuring for phy/xgmii link mode
[ 1000.153540] rtl93xx_phylink_mac_config port 6, mode 0, phy-mode: xgmii, speed -1, link 0
[ 1000.162607] rtl93xx_phylink_mac_config SDS is -1
[ 1000.168091] 8021q: adding VLAN 0 to HW filter on device lan7
[ 1000.205524] switch: port 7(lan7) entered blocking state
[ 1000.211371] switch: port 7(lan7) entered disabled state
[ 1000.217302] rtl83xx-switch switch@1b000000 lan7: entered allmulticast mode
[ 1000.225904] rtl83xx-switch switch@1b000000 lan7: entered promiscuous mode
[ 1000.284888] rtl83xx-switch switch@1b000000 lan8: configuring for phy/xgmii link mode
[ 1000.293535] rtl93xx_phylink_mac_config port 7, mode 0, phy-mode: xgmii, speed -1, link 0
[ 1000.302601] rtl93xx_phylink_mac_config SDS is -1
[ 1000.308085] 8021q: adding VLAN 0 to HW filter on device lan8
[ 1000.345513] switch: port 8(lan8) entered blocking state
[ 1000.351359] switch: port 8(lan8) entered disabled state
[ 1000.357297] rtl83xx-switch switch@1b000000 lan8: entered allmulticast mode
[ 1000.365910] rtl83xx-switch switch@1b000000 lan8: entered promiscuous mode
[ 1000.428090] rtl83xx-switch switch@1b000000 lan12: configuring for inband/10gbase-r link mode
[ 1000.437570] rtl93xx_phylink_mac_config port 27, mode 2, phy-mode: 10gbase-r, speed -1, link 0
[ 1000.447109] rtl93xx_phylink_mac_config SDS is 9
[ 1000.452157] rtl9300_sds_rst 31
[ 1000.582451] rtl9300_phy_enable_10g_1g 1gbit phy: 00001140
[ 1000.589496] rtl9300_phy_enable_10g_1g 1gbit phy enabled: 00001140
[ 1000.597305] rtl9300_phy_enable_10g_1g 10gbit phy: 00002040
[ 1000.604411] rtl9300_phy_enable_10g_1g 10gbit phy after: 00002040
[ 1000.612113] rtl9300_phy_enable_10g_1g set medium: 00000002
[ 1000.619248] rtl9300_phy_enable_10g_1g set medium after: 00000002
[ 1000.645944] rtl9300_serdes_setup: Configuring RTL9300 SERDES 9
[ 1000.654439] rtl9300_serdes_mac_link_config: registers before 00000000 00001403
[ 1000.666499] rtl9300_serdes_mac_link_config: registers after 00000000 00001403
[ 1000.674439] rtl9300_force_sds_mode: SDS: 9, mode 28
[ 1000.679892] rtl9300_force_sds_mode --------------------- serdes 9 forcing to 1a ...
[ 1000.999939] rtl9300_force_sds_mode --------------------- serdes 9 forced to 1a DONE
[ 1001.310126] rtl9300_sds_10g_idle WARNING: Waiting for RX idle timed out, SDS 9
[ 1001.318200] start_1.1.1 initial value for sds 9
[ 1001.380188] end_1.1.1 --
[ 1001.383008] start_1.1.2 Load DFE init. value
[ 1001.389776] end_1.1.2
[ 1001.392303] start_1.1.3 disable LEQ training,enable DFE clock
[ 1001.410710] end_1.1.3 --
[ 1001.413536] start_1.1.4 offset cali setting
[ 1001.420207] end_1.1.4
[ 1001.422732] start_1.1.5 LEQ and DFE setting
[ 1001.441392] end_1.1.5
[ 1001.452926] start_1.2.1 ForegroundOffsetCal_Manual
[ 1001.462272] end_1.2.1
[ 1001.473272] start_1.2.3 Foreground Calibration
[ 1001.491759] rtl9300_do_rx_calibration_2_3: fgcal_gray: 63, fgcal_binary 32
[ 1001.500436] rtl9300_do_rx_calibration_2_3: end_1.2.3
[ 1001.505988] start_1.4.1
[ 1001.729569] end_1.4.1
[ 1001.732295] start_1.4.2
[ 1001.744848] vth_set_bin = 7
[ 1001.747575] vth_set_bin = 7
[ 1001.751669] Vth Maunal = 0
[ 1001.870589] Tap0 Sign : +
[ 1001.873607] tap0_coef_bin = 31
[ 1001.877540] tap0 manual = 0
[ 1001.886949] end_1.4.2
[ 1001.890054] start_1.5.2
[ 1001.970467] end_1.5.2
[ 1001.994168] rtl9300_do_rx_calibration: SDS enabled
[ 1002.054985] start_1.4.1
[ 1002.278598] end_1.4.1
[ 1002.281323] start_1.4.2
[ 1002.293850] vth_set_bin = 7
[ 1002.296606] vth_set_bin = 7
[ 1002.300707] Vth Maunal = 0
[ 1002.419614] Tap0 Sign : +
[ 1002.422627] tap0_coef_bin = 31
[ 1002.426558] tap0 manual = 0
[ 1002.435968] end_1.4.2
[ 1002.439073] start_1.5.2
[ 1002.519474] end_1.5.2
[ 1002.591248] 8021q: adding VLAN 0 to HW filter on device lan12
[ 1002.617214] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[ 1002.624565] rtl83xx_fib_event: FIB_RULE ADD/DEL for IPv6 not supported
[ 1002.667028] rtl83xx-switch switch@1b000000 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
[ 1002.677417] switch: port 2(lan2) entered blocking state
[ 1002.683266] switch: port 2(lan2) entered forwarding state
[ 1002.825536] switch: port 9(lan12) entered blocking state
[ 1002.831480] switch: port 9(lan12) entered disabled state
[ 1002.837517] rtl83xx-switch switch@1b000000 lan12: entered allmulticast mode
[ 1002.846232] rtl83xx-switch switch@1b000000 lan12: entered promiscuous mode
[ 1002.934258] sfp sfp-p12: module Arista Networks  QT-SFP-10G-T     rev 0002 sn QT202003111012   dc 221014
[ 1003.063081] hwmon hwmon3: temp1_input not attached to any thermal zone
[ 1015.138757] rtl83xx-switch switch@1b000000 lan2: Link is Down
[ 1015.145287] switch: port 2(lan2) entered disabled state
[ 1017.219084] rtl83xx-switch switch@1b000000 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
[ 1017.228700] switch: port 2(lan2) entered blocking state
[ 1017.234535] switch: port 2(lan2) entered forwarding state
[ 1018.258780] rtl83xx-switch switch@1b000000 lan2: Link is Down
[ 1018.265308] switch: port 2(lan2) entered disabled state
[ 1021.379110] rtl83xx-switch switch@1b000000 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
[ 1021.388720] switch: port 2(lan2) entered blocking state
[ 1021.394558] switch: port 2(lan2) entered forwarding state
[ 1050.498791] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[ 1050.508403] switch: port 1(lan1) entered blocking state
[ 1050.514241] switch: port 1(lan1) entered forwarding state
[ 1724.418448] rtl83xx-switch switch@1b000000 lan2: Link is Down
[ 1724.425233] switch: port 2(lan2) entered disabled state
[35251.938791] rtl83xx-switch switch@1b000000 lan1: Link is Down
[35251.945318] switch: port 1(lan1) entered disabled state
[35262.339113] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[35262.348968] switch: port 1(lan1) entered blocking state
[35262.354884] switch: port 1(lan1) entered forwarding state
[74226.978804] rtl83xx-switch switch@1b000000 lan1: Link is Down
[74226.985338] switch: port 1(lan1) entered disabled state
[74234.259112] rtl83xx-switch switch@1b000000 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[74234.268723] switch: port 1(lan1) entered blocking state
[74234.274559] switch: port 1(lan1) entered forwarding state

I misread the "factory sysupgrade image", OpenWrt has two or three images for most targets:

  • factory image - not available for your device - this image is mostly used to flash openwrt from device's vendor firmware directly (when there are no multiple steps required to install openwrt)
  • initramfs image - available for your device and used as the first step, keeps all data in RAM, doesn't write to flash anything
  • sysupgrade image - available for your device and used as the second step - this image loads data from the flash and stores the data in a flash-friendly overlay filesystem.

So you did the correct steps.

Can you call fw_printenv bootcmd and see what the output is - does it contain rtk network on; boota?

Also, just to confirm, if you set an IP address on your pc to 192.168.1.2/24 and ping 192.168.1.1 you don't get a response from the switch?

Okay, thanks for the context, I did not know what the different OpenWrt images are for.

Yes, when I run when I run fw_printenv bootcmd I get bootcmd=rtk network on; boota

Also, just to confirm, if you set an IP address on your pc to 192.168.1.2/24 and ping 192.168.1.1 you don't get a response from the switch?

Almost. When I attach a device to the switch with an Ethernet cable and ping 192.168.1.1 I get no response. I've tried 2 laptops, and neither is able to "see" that it is attacked to the switch. However, I have not tried to assign either laptop an IP of 192.168.1.2 before connecting to the switch.

Which OpenWrt version did you install? Snapshot?
Yesterday, there was a similar post with a GS1900-24E where the user did not have network access after installing snapshot:

1 Like

It does seem like that person is encountering a similar problem.

Yeah, I first tried installing OpenWrt with the version 23.05.5 snapshot for my switch. The file is called openwrt-23.05.5-realtek-rtl930x-zyxel_xgs1250-12-initramfs-kernel.bin

Can you then install the older version? I don't know what the easiest way to copy over serial would be.

I will try downgrading, I see there alot of older versions to choose from. Any suggestions as to which to try? My guess is to start with 22.03.7.

I can't figure out how to send files through the serial command. I'm going to post a new topic asking for help with sending files though the serial command.

Have you tried running the initramfs from the the dev snapshot by tftp-ram-booting it?

https://downloads.openwrt.org/snapshots/targets/realtek/rtl930x/

and then maybe (If network works) follow up with installing the sysupgrade from

https://downloads.openwrt.org/releases/24.10.0-rc7/targets/realtek/rtl930x/

I have not, and it had not occurred to me. I had noticed something about a server at 192.168.1.111 in the fw_printenv command, but I didn't think to look into. I'm having trouble with the serial console file transfer angle, so I'll start looking into setting up a TFTP server.

Thank you for the suggestion!

Update on tftp-ram-booting:
I changed the boot command to something that would not work ('rtk network on; bootb`), but found that even in network boot mode, none of the Ethernet ports work.

Downgrading OpenWrt to 22.03.7 does not seem to resolve the issue, I transferred the older firmware file (openwrt-22.03.7-realtek-rtl930x-zyxel_xgs1250-12-initramfs-kernel.bin) via the Serial connection and then installed older firmware using sysupgrade -v /tmp/openwrt-22.03.7-realtek-rtl930x-zyxel_xgs1250-12-initramfs-kernel.bin per the instructions for upgrading OpenWrt from the CLI.

When I rebooted, I found that none of the Ethernet ports work.

If tftpboot doesn't work that would indicate that there is no network in uboot - which means you have issues even before the openwrt kernel is involved.

Check the uboot help command for commands that initialise the network. No point proceeding to boot openwrt if there's no networking intialised by uboot.

Can you tell me where to find "uboot help command". From fw_printenv I see that bootcmd=rtk network on; boota, which is what the switch's hardware page says it should be.

Interrupt the boot process in the bootloader and at the uboot command prompt type help and post the list of available commands.
Prior to starting openwrt

Can you tell what I need to do to interrupt the boot process?
I imagine there is a key combination I should hit after using reboot but before the main OpenWrt console comes back up, but I did not find instructions for interrupting the boot process on the boot process or bootloader pages.

Do you have a serial connection? The bootloader will usually show what command combo is needed to interrupt the booting.

If you log the boot process you can review the uboot stage for any messages.
Or just spam the enter key as the switch starts.