Alix 2D13 with Draytek Vigor 130 Modem and 1und1 ADSL2+ - suffering from not being able to config OpenWrt properly

Hello and welcome to the 1.000.000 thread of a noob asking for help!

As stated in the topic above, I'm suffering from not being able to set up my Alix 2D13 with openWrt properly. Until now, I'm using a Fritzbox 7320 which should be replaced by the openWrt router. Since 1&1 is charging customers a fee for multiple connections, the Fritzbox had to be replaced with an Draytek Vigor 130 in Modem "only" setup, which has been well described by iDomix youtube channel. I did all necessary changes that arise from his VDSL setup in comparison to my ADSL2+ connection.

The setup of the of the Draytek looks the following:

For the openWrt setup, I'm confused which settings I have to adopt. The majority of the threads here and elsewhere do not cover ADSL2+ setups, since VDSL/VDSL2 connections are more popular nowadays. Sadly, I'm not able to get any faster connection in my house. Those ADSL descriptions I found on the internet are often dating back 10 years or more. I'm asking myself if the development of openWrt cover up some of the setup work. Additionally, some connection types have undergone technical changes and may not be applied in openWrt like 10 years ago.

My question: Can anyone who has a similar connection with 1&1 in Germany or a similar setup with an ADSL2+ connection provide a helping hand to me? I'm updating this thread with my current openWrt and more pics of my Vigor 130 settings shortly.

Kind regards and a nice weekend to everyone here

Dennis

I have a ADSL line, Vigor 130 + OpenWrt and recently had to force VLAN 7 in the Vigor modem configuration.

No other changes were required to make it work.

Note: unless there is a need, I much prefer changing this parameter in the modem rather than in openwrt.

VLAN tagging may, or may not be required, depending on your region (old BRAS based infrastructure doesn't need VLAN tagging, if you've been moved over to the newer BNG platform already, you do need it for both ADSL and VDSL; no the ISP usually won't tell you). If you do need VLAN tagging, you can either let the modem do it for you (transparently) or do the tagging on the router (the later is usually to be preferred).

1 Like

@mbo2o:

I followed those instructions previously. My openWrt config looks the following

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda2:c314:ecde::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.2'

config dsl 'dsl'
        option tone 'bv'
        option annex 'b'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth1'
        option ipv6 'auto'
        option mtu '1476'
        option username 'H*******@online.de'
        option password '****'
#       option ifname 'dsl0.7'

#config device 'wan_dev'
#       option macaddr ''
#       option name 'dsl0'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config atm-bridge
        option atmdev '0'
        option payload 'bridged'
        option vci '32'
        option vpi '1'
        option encaps 'llc'

There are a couple of things I do not know how to deal with:

config interface 'wan'
#       option ifname 'dsl0.7'
  1. Changing the ifname from eth1 to dsl0.7 is causing an error. Is it a neccessity to rename it in this way?
#config device 'wan_dev'
#       option macaddr ''
#       option name 'dsl0'
  1. I don't know what macaddr I have to specify here? Do I have to put in the macaddr of the modem or the one of the eth port of the router?

@deuteragenie:

I made a phone call to draytek, since 1&1 doesn't provide a "Schnittstellenbeschreibung"/connection details to customers. I was told that it is not necessary to have one establishing a connection. Only exception BNG what slh said. Could you be so kind to provide me with some more information about your Vigor/openWrt setup?

Thanks to all of you

My OpenWrt setup has nothing specific wrt WAN connectivity.
It just uses the default PPPoE settings with the relevant the uid/pwd.
My Vigor is in passthrough mode (obviously), and specifies VLAN 7.

Simple. Works.

Your DSL modem uses the same IPv4 subnet as the OpenWrt router's LAN. I recommend to change one of them to a different subnet, for example 192.168.2.0/24.

To keep the DSL modem's management interface accessible, add a new section like this:

config interface 'wanmodem'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

and also add this wanmodem interface to your OpenWrt firewall's wan zone.

Remove the gateway.

These sections are only useful on an OpenWrt router with a built-in DSL modem.
Since you are using a separate DSL modem, you can remove them.

No, don't use any interface name based on dsl0. Again, this is intended for a built-in DSL modem and will not work with your router.

I am not aware that 1&1 would lock you to a single MAC address. It should work without the wan_dev device section.

Thank you @mpa

My /etc/config/network now reads the following:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda2:c314:ecde::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth1'
        option ipv6 'auto'
        option mtu '1476'
        option username 'H1und1/****@online.de'
        option password '****'

config device 'wanmodem'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

Sadly the openWrt router is not establishing a connection. May this happen because the modem is not handing over the connection via pppoe on the wan port? The section in my Vigor looks like this:

Do I have to switch pppoe mode for something else?

Your OpenWrt configuration now looks to be correct, you may only have to experiment with eth1 (connected to a classic BRAS infrastructure) XOR eth1.7 (switched to modern BNG infrastructure) for wan.

I'm not quite that sure about the configuration for your vigor 130 though.

  • Internet Access --> General Setup
    • DSL Mode ADSL (Auto should work though)
    • VLAN Tag insertion
      • ADSL: Disable
      • ADSL: Disable
    • PPPoE / PPPoA
      • PPPoE/PPPoA Client: Disable
    • MPoA / Static or dynamic IP
      • MPoA (RFC1483/2684): Enable
      • Multi-PVC channel: Channel 2
      • Encapsulation: 1483 Bridged IP LLC
      • VPI: 1
      • VCI: 32
      • Modulation: Multimode
      • Bridge Mode: Enable Bridge Mode
    • IPv6
      • Connection Type: Offline

I'm guessing a bit about the ADSL specific settings, as I've only used this device for VDSL so far. Check VPI/ VCI with the documentation for your ISP.

Do I understand it correctly that Deutsche Telekom uses VLAN 7 for internet + phone traffic and VLAN 8 for IPTV (ie Entertain) ?

Could anyone post a working configuration, including IPTV using igmpprox, for DTAG ?

I have the same settings and it works.

I used to have VLAN tagging in the vigor modem (VLAN 7), and have now moved the VLAN tagging to openwrt with success (with Luci: go to "switch", replace the port status "2" with "7" and tag "cpu0" and "wan" - leave the rest of the line "off".

How to add VLAN 8 for IPTV ?

  • Just create another Interface and use '8.'
  • Then again, go to Switch and add VLAN 8

Does this board have a switch chip at all?
Without a switch, you would replace eth1 with eth1.7 in order to use VLAN 7 tags on WAN.

1 Like

Well... actually it appears that Deutsche Telekom has changed its approach and is now pushing IPTV traffic through VLAN 7. So no need to add VLAN 8 in Switch.

Now begins the fight to make igmpproxy work to get the IPTV streams on the Vigor 130 Modem + OpenWRT Router using VLAN 7 configuration.

Vlan8 for IPTV is being actively phased out, it is quite likely that on your link all packets use vlan7.
I would also try to get a capture from the modem's DSL port to confirm that the VLAN tag from the lab port really is passed into the dsl-link....

Thanks!

I assume that the VLAN tag is correctly passed by the modem, because if I remove the VLAN tagging from the router I loose connectivity. If the modem would remove the VLAN tag, I would expect the same problems, which I don't have. I also assume this is valid in both directions.

Note: capturing the DSL traffic from the modem may not be trivial, as it uses a non-standard connector.

1 Like

Thanks for the many advices here. Sadly, I've not been able to establish a connection so far..

Changing the WAN port eth1 with the option ifname 'eth1.7' did not work. Since the Alix2d13 board has three physical eth ports and no VLAN switch the switch config does not apply.

@deuteragenie: I was not supplied with a "Schnittstellenbeschreibung" by 1&1. The told me to use their start-key and the fritzbox. Do you have any further information to share on this ISP and/or a documentation? DNS server IP, name settings, ie. ... Looking at the OpenWrt config, I'm pretty sure my problem arises from my Vigor not being setup properly.

Ah, another connector is not going to be enough if you want to capture from the DSL-output port; I was thinking about performing the capture from the modem :wink:

Maybe take it step by step?

Why not resetting your Vigor Modem to factory default, and simply set it up to acquire an IP address ? Maybe ensure that you have the last firmware installed for that modem.

It was explained how to setup VLAN to 7 above in the modem, and how the ADSL parameters should look like.

  1. Ensure that ADSL sync, and that you can ping from the modem.
  2. When everything works in the modem, enable PPPoE passthrough and return to your OpenWrt setup.
  3. When this works, remove VLAN tagging from the modem and set it up in OpenWrt.

On another note: as expected, I am fighting with the igmpproxy setup on PPPoE / VLAN 7. I'll open a separate issue on the forum with my findings (or lack thereof...).

@deuteragenie:

Your right, I take it step by step then. I just restored the Vigor back to factory default settings. Before initially setting up the modem two weeks ago, I fleshed v130_384_modem_7.all firmware on it. It was recommended by the Draytek support hotline. Which one are you using?

I entered the ISP account details so the ADSL syncs. The "VLAN Tag insertion" (ADSL) is set to:

Value: 7 / Priority: 0

I receive an IP from my ISP: