Alias interface doesn't come up when primary doesn't get DHCP lease

config interface 'stuff'
option device 'eth0.3'
option proto 'dhcp'

config interface 'stuff2'
option device '@stuff'
option proto 'static'
option ipaddr '10.32.0.44'
option netmask '255.255.255.0'

As long as stuff does not get a dhcp answer, stuff2 will not come up.

Interestingly, if I swap the config, so the main is static and the fallback is dhcp, the fallback works.

Why does the order matter here?
Is there an option to make it not matter that the primary isn't up?

(
On reading other threads in here:
Please don't dump on me for wanting to do this. If you really don't want me to do this please give an actual explanation why.
My usecase is that when the DHCP is temporarily not available because the switch uplink is down, that I can still reach the devices from a laptop at the switch. Why not wait for the uplink to come up again? Easy. Because the dhcp client in OpenWRT seems to give up after a while. When the uplink comes up afterwards they don't try to get an ip anymore.
In this case not the direct uplink to the AP is down but the uplink of the upstream switch.
When such a thing happens, I have unreachable APs that I have to actually go to another building for to reboot them.
)

I don't know why this happens, but can you provide a bit more context here... what is the device doing? Is this a dumb AP or similar? Is the 10.32.0.44 address on the same subnet as the DHCP server's leases?

Layer2 AP, same subnet as DHCP.
AP that switches for multiple VLANs but shouldn't route.
Sometimes wacky things might make the APs unreachable.
Sometimes that might coincide with their reboot or dhcp lease expiry.
As the DHCP clients seem to give up after a while, I end up with hosts without address.
This leads to:

  • Me having to pull APs out of wall compartments to reboot them if I want access.
  • Roaming messages over the wire not arriving. I could FT over Air but the other problem persists.

Why not static and no DHCP?
Another admin insists to have everything in DHCP.