AIoT AC2350 Xiaomi Bricked

Good afternoon
Can someone help me with my Xiaomi AIoT AC2350, which after this procedure had no wireless signal and access to the interface was prevented... It only has a blue LED on...
It resets, restarts but only turns on a blue LED, I can access the interface (, but when I try to advance in the configuration, it doesn't work.

There's no "advance" in the configuration, in openwrt, which firmware did you install?

Did you try the TFTP recovery?

1 Like

hello frolic
I didn't get to install Openwrt, I tried several times but without success!

Yes I already did this recovery method, but it does not solve the problem.
From what I read the bootloader is fine but the interface does not advance to the router configuration, even with the network cable connected to the PC.


I'm sorry but I don't think the problem you're having right now is related to the OpenWrt for developers sub-forum. It would be better to ask such questions for troubleshooting under Installing and Using OpenWrt sub-forum.
However, you can try the debricking guide linked here. If this method doesn't work for you, then you may need to reprogram the flash chip on the device with a full dump/backup.

And yes, if you want to flash OpenWrt on your router, please follow the instructions in the link mentioned above.

Good luck,

1 Like

I apologize for the sub-forum where I initially put the problem, already moved to the suggested sub-forum.

Do you really think it's necessary reprogram the flash chip on the device with a full dump/backup?
I have a complete dump/backup of my router...

That's okay no problem.

If you can not debrick it with standard recovery methods you may have to get your hands dirty... Luckily you have a backup! Relatively easy to work with. So I say yes.


1 Like

You mean the CH341a programmer?

programador CH341

Yes, you can use it to reprogram the flash chip.


1 Like

Okay, I'll try to get a visible picture of the flash chip so I don't do anything wrong, again. :face_with_hand_over_mouth:

Problem solved without flash chip...

As per the image, I managed to login with wifi name: user_root, and password:user_root.
This way I was able to access the router interface and then ssh access by the known method.
From there it was just installing OpenWrt.
Thank you all for your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.