AGPF - Wrong Version of Bad Installation?

I'm try to upgrade my openwrt installed over my Pirelli AGPF and i have download (as I always have) the "smp" version from here:

I have installed it by:

It took a lot time and my router didn't seem to restart after waiting even 20 minutes.

When it's finally reboot i have reopened the router panel and wtf... it's not be upgraded ?
I can again read the version installed:
OpenWrt 21.02.0 r16279-5cc0535800 / LuCI openwrt-21.02 branch git-21.231.26241-422c175

How it's append ? There's a wrong number reported or it's obtain a BAD Installation and my router made a restore of previous 21.02.0 version ??
How i can check if the installation has been completed or whatever happened?
Thanks in advance....

According to the Table of Hardware, the AGPF is not supported in version 21.02

OH.... and because download it's available on link i reported ????

It's your link report wrong information ?

At this point how 21.02.0 i have installed and stay to use ? A fake version ?
I have a lot of confusion over my head.........
Problably i'm stay to usage a virtual 21.02.0 like it's an older version?

Lol..truly.. i don't really understand what 21.02.0 i am using to today :slight_smile:

Reading also here:

Apparently there's a 432 device and 21.02.0 it's supported.

It's 21.02.1 it's not compatible ? If yes because it's avaiable for download ?

I see 19.07.8 in two places...the ToH and here...

Both links could be outdated, but since 21.02 is not upgrading...despite what the firmware says it's targeted questionable.

I have totally no idea.... but you can trust me i'm stay using at today the 21.02.0 on my AGPF.
It's connected to my FTTC router by ethernet cable and on it i can use my devices whit the LAN speed at 100MB/s obviously and it's works. Also the wifi it's support only the 2.4Ghz and it's have a good coverage and also at today has surprising stability.

Simply here.... from the main page i see it's avaiable the 21.02.1 version.... as i always do in the pass have i tried to update and this time it's fail or somethings similar.

I thought it was a good place to ask for information..... also because objectively it is not that the router returns an error on the screen during the flashing procedure.
It's take about 30 minutes.... at reboot it's remain to 21.02.0 insted to updated to 21.02.1... strange :slight_smile:

About some minutes ago i have tryed to flash this version by SSH session after i have read this:

I have copyed the firmware in /tmp/ and by SSH do this:

root@OpenWrt:~# sysupgrade -v /tmp/openwrt-21.02.1-bcm63xx-smp-pirelli_agpf-s0-s
Mon Dec 13 12:38:38 UTC 2021 upgrade: Image metadata not present
Mon Dec 13 12:38:46 UTC 2021 upgrade: Saving config files...
Mon Dec 13 12:38:54 UTC 2021 upgrade: Commencing upgrade. Closing all shell sess                                    ions.
Command failed: Request timed out

After this i'm goin in front of my router and this is made a self reboot....... there's no updated and it's remain at "OpenWrt 21.02.0 r16279-5cc0535800".
I have also reopen a SSH session and on /tmp/ the file .bin of firmware it's not more present. It's the /tmp/ path it's been be deleted after a reboot of router ?

Anyway the 21.02.1 it's also downloadable from here:

I have also compared the sha256 to check the integrety of my files downloaded on my pc..... apparently it's ok.
Apparently it's simply fail to install.... i don't have absolutely knowledge to try to understand because there's happens...

I could be wrong about this, but the fact that the filename has "cfe" in it suggests that it may be formatted for installation directly via the CFE web or tftp method. It may not work properly with the standard OpenWrt sysupgrade process.

Yeah..... it could be in fact I had taken a cue from other users because I saw that many use sysupgrade to do the same update from the version 21.02.0 -> 21.02.1.

Anyway in the past I have in fact always trivially updated through its GUI/Luci and it's ever works.

I have also read about this 21.02.1 some other people have success made this upgrade only if reset the configuration:
I thinks i can also try this solution but before that i need to made some modification on my home network:
I need to change the ip of my FTTC Router to to another ip because after the reset/upgraded the agpf I find myself both routers with the same ip address on the same network.

But I have a question.... is there anyone who keeps this specific model up to date?
or all available versions are automatically compiled by a script or somethings similar ?

There are two ways to handle this...

  1. change your FTTC router to another address, as you have mentioned.
  2. Peform the AGPF upgrade and initial configuration offline... i.e. nothing connected to the router except for a single computer that is managing the upgrade process. That computer should, likewise, not be connected to anything else (wired or wifi) so that the only network device is the router you are targeting.
1 Like

OMG.... it's worked!!

My AGPF as been updated to 21.02.1. I have need to reset the configuration.............

Now need to reset all previous configuration.........