After upgraded to 18.06.4 I have to add firewall.user for using PPtP VPN

I use 18.06.2 before and PPtP VPN works fine. After upgraded to 18.06.4 I have to add custom iptables rule in firewall.user for using PPtP VPN, which is described on document:

The iptables rule is

iptables -t raw -A OUTPUT -p tcp -m tcp --dport 1723 -j CT --helper pptp

I haved added these packages


I have tested if I removed the rule, PPtP VPN will be failed and the error message is "negotation error"

My device is Linksys WRT1900ACv2

I had been using firewall.user rules for a pptp connection for 17.01 and maybe even chaos calmer, and I think it was part of the pptp tutorial I found when I started using OpenWrt. I can’t explain why you didn’t have to use those rules in the past.

That said, pptp is not a good vpn choice if you can avoid it. The encryption is weak and can be broken really easily. It is well documented as a now unsafe vpn technology. And, beyond that, support for the protocol has been deprecated in many modern os versions, including the past two versions of iOS and Mac OS. So if you have the option, consider other vpn options like OpenVPN or WireGuard.

Yes, PPtP is not a good VPN solution, but I have to use it.

I'm not sure why I could use it before I upgrade, maybe I forget I setup a custom iptables rule, I just flash the sysupgrade image and keep config, if I setup before, it could be work as before, I find there is no custom iptables rule when I add it.