After setted up relayd, whole network's freezing

so i am using TL-WR842ND and i just managed to get relayd wifi extender working or at least i thought so, when both routers are turned on the wifi, or lan internet doesnt work, nothing is loading its timing out, but i can ping stuff after some long delay, i am not sure how to post more logs or configuration from my router, but i think i didi it corectly, they are both connected via cable i have vdsl router->switch->openwrt router connected like this i put openwert on and my main is on and every step i did correctly but ass i said it hangs, and when i try to turn off my main wifi, to try out if the openwrt one works, it seems like both dissapear, maybe i misunderstood how this should work ?

i managed to get my setting archive and some screenshot about my setup

here is link to archive

In that case you should set up as a dumb AP not relayd extender. relayd is only for a wifi connection to the other router which is the source of Internet, when an Ethernet cable connection is not possible.

Connecting by cable and wifi at the same time creates a network loop, which will jam the whole network with traffic and make it stop working. Connect only with one method not both, and using Ethernet cable is the best method.

When you have an AP and a STA set up on the same radio (the WR842 only has one radio), if the STA cannot connect to its AP (the main router), the AP will also go off the air.

1 Like

oh maybe i misunderstoop what relayd was supposed to do? thanks ill try dumb AP and ye that makes sense that it was in a loop thanks for help !

well after days of trying to setup Dumb AP the uhh the configuration wikipage is really not that sightfull, i get lost like i am not sure if before or after process should i rename Openwrt's wifi to the same as my main router, and same password etc. so they act as one wifi, and everytime i am doing the configuration someway half the process i cannot connect to my router, like the ip i set it to is inacesable so i have to restart my router to factory to get into it again, idk why is it happening, i thought it would only happend when i disable openwrt's DHCP server but i wait for that step to be the last but still something it removing the access to my router, is it changing default gateaway? or disabling IPV6? many things are not clear for me

so after some tried i managed to do it, i realised the forbiden acces to my router wasnt causing any setting i didt but changing toom any settings at once, i managed to get it working by saving and applying every change, and then it worked,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.