After installing 17.01.4 on my wndr3700 I get ip address of 64.121.xxx.x


#8

Routers have at least two networks. This is the case in default OpenWRT:

  • WAN, faces your Internet Service Provider
  • LAN, faces YOU

You can only access the web GUI from LAN, this address is http://192.168.1.1 by default. You can only access this service from the LAN.


#9

That address is reported as the lan default gateway


#10

LANs do not have default gateways.


#11

OK when I normally type ipconfig from the command prompt it reports as 192.168.1.1. Until I tried to install lede 17.01.4 Now it reports blank for default gateway and 169.254.214.76 as the ip address

Ethernet adaptor local area connection


#12

When you type ifconfig you should see multiple interfaces. Paste the full result of your ifconfig command.


#13

WHAT!?!?

We are talking about your ROUTER, not your Windows computer, correct???


#14

OK maybe people in there 60s shouldn't try to learn openwrt. I cleared my browser cache and files and now I can get to web UI. Sorry.
Check that. I only got to the web ui until I plugged in my wan, can get on the internet not web ui unless I use static gateway 192.168.1.1 and then no internet.


#15

OK...

Neither your computer nor router should have user-provided settings for their interfaces, they should all be default:

  • On Windows, DHCP Local Area Connection
  • On the router, DEAFULAT CONFIGS, FROM A FRESH RESET OR FLASH

You should be able to get Internet on the WAN port and the web GUI on 192.168.1.1 from LAN. Your device should have Internet at the same time. You do not need to configure your computer's Ethernet nor router for a standard, Ethernet-based ISP (like a cable modem, ONT, or devices set to bridge mode).

Out-the-box OpenWRT, that simple.


#16

I don't know what to say. I went into the UI and had to connect the lan and wan. Its been "waiting for changes to be applied for about 10 mins.


#17

What are you talking about???

  • PC: clear settings from Ethernet card and plug into LAN port
  • Router: reset and plug WAN into ISP

Everything should work. Don't apply any settings.

We'll start here.


#18

Do not connect your modem yet. Connect only the PC to the router. You should be able to log in at 192.168.1.1. Observe the WAN IPv4 on the LEDE main status page. It should be 'not connected'. Now connect the modem to the WAN port. It should change to a public IP.


#19

Won't work. Maybe I got a bad router, when netgear firmware was on it was incredibly slow.

OK let me do a 30-30-30 and try again.


#20

reset router, computer win 7, can't see the web ui, This site can't be reached, took too long to respond.


#21

Let's debug this issue.

  1. Turn off your router
  2. Unplug WAN & LAN
  3. Power it up & Reset settings to defaults
  4. Only connect your PC, which is set to automatically get IP, gateway & DNS settings (DHCP)
  5. Post the output of the ipconfig command here.

Most importantly, do not connect your modem just yet. Only use the router for now to see if you properly get an IP and if you can reach the web interface. Don't change any settings after resetting, keep them on default.


#22

There is no 30-30-30 please see these docs to factory reset.

https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#factory_reset


#23

Only way I could connect was serial putty. here is some of the data:

type or past0x40
/bin/ash: page: not found
root@LEDE:/# size = 128MB
/bin/ash: size: not found
root@LEDE:/# Setting 0xb8116290 to 0x50a02d0f
/bin/ash: Setting: not found
root@LEDE:/# Using default environment
/bin/ash: Using: not found
root@LEDE:/#
root@LEDE:/# In:    serial
/bin/ash: In:: not found
root@LEDE:/# Out:   serial
/bin/ash: Out:: not found
root@LEDE:/# Err:   serial
/bin/ash: Err:: not found
root@LEDE:/# Net:   ag934x_enet_initialize...
/bin/ash: Net:: not found
root@LEDE:/#  4096 bytes read: OK
/bin/ash: 4096: not found
root@LEDE:/# Fetching MAC Address from 0x87fe7928
/bin/ash: Fetching: not found
root@LEDE:/#  wasp  reset mask:c02300
/bin/ash: wasp: not found
root@LEDE:/# WASP  ----> S17 PHY *
/bin/ash: WASP: not found
root@LEDE:/# : cfg1 0x80000000 cfg2 0x7114
root@LEDE:/# eth0: 08:bd:43:ab:22:6e
/bin/ash: eth0:: not found
root@LEDE:/# athrs17_reg_init: complete
/bin/ash: athrs17_reg_init:: not found
root@LEDE:/# eth0 up
/bin/ash: eth0: not found
root@LEDE:/# eth0
/bin/ash: eth0: not found
root@LEDE:/# Hit any key to stop autoboot:  0
/bin/ash: Hit: not found
root@LEDE:/# dup 1 speed 1000
/bin/ash: dup: not found
root@LEDE:/#
root@LEDE:/#  Client starts...[Listening] for ADVERTISE...checksum bad
/bin/ash: Client: not found
root@LEDE:/# checksum bad
/bin/ash: checksum: not found
root@LEDE:/# checksum bad
/bin/ash: checksum: not found
root@LEDE:/# Tchecksum bad
/bin/ash: Tchecksum: not found
root@LEDE:/# Tchecksum bad
/bin/ash: Tchecksum: not found
root@LEDE:/# checksum bad
/bin/ash: checksum: not found
root@LEDE:/# T
/bin/ash: T: not found
root@LEDE:/# Retry count exceeded; boot the image as usual
/bin/ash: Retry: not found
/bin/ash: boot: not found
root@LEDE:/#
root@LEDE:/#  nmrp server is stopped or failed !
/bin/ash: nmrp: not found
root@LEDE:/#
root@LEDE:/# Loading from device 0: ath-nand (offset 0x6c0000)
/bin/ash: syntax error: unexpected "("
root@LEDE:/#
root@LEDE:/# ** check kernel image **
/bin/ash: S17: not found
root@LEDE:/#    Verifying Checksum ... OK
/bin/ash: Verifying: not found
root@LEDE:/#
root@LEDE:/# ** check rootfs image **
/bin/ash: S17: not found
root@LEDE:/#    Verifying Checksum ... OK
/bin/ash: Verifying: not found
root@LEDE:/# ## Booting image at 81000000 ...
root@LEDE:/#    Image Name:   MIPS OpenWrt Linux-4.4.92
/bin/ash: Image: not found
root@LEDE:/#    Created:      2017-10-17  17:46:20 UTC
/bin/ash: Created:: not found
root@LEDE:/#    Image Type:   MIPS Linux Kernel Image (lzma compressed)
/bin/ash: syntax error: unexpected "("
root@LEDE:/#    Data Size:    1965951 Bytes =  1.9 MB
/bin/ash: Data: not found
root@LEDE:/#    Load Address: 80060000
/bin/ash: Load: not found
root@LEDE:/#    Entry Point:  80060000
/bin/ash: Entry: not found
root@LEDE:/#    Verifying Checksum ... OK
/bin/ash: Verifying: not found
root@LEDE:/#    Uncompressing Kernel Image ... OKe code here

#24

As you can see, you are pasting data to the serial terminal. Your putty screen should look like this:

root@LEDE:/#

The other lines appear to be things you are pasting that are producing command not found errors...please be advised that the right mouse click performs the PASTE function in Putty. Now, the following commands will get your device back to default configs:

firstboot
reboot


#25

Hi Jef. It looks like you accidentally pasted your dmesg into your root terminal, which isn't great.

I'd suggest that you load this build, personally - it's bulletproof:

Also, it sounds like you're attaching your computer and your router to your internet through the LAN. You need to plug your modem into the WAN port, and your local computers on the LAN port (if not wireless).

Since you get a public IP from RCN, your computers' MAC address is probably registered. You'll need to look that up with "ipconfig /all | more" on your Windows machine, and set that as your MAC address on the router- or call RCN and have them change it to whatever your WAN port MAC address is.


#26

Don't go there right away though, first just do

firstboot
reboot

and then

  1. Turn off the modem, and the router.
  2. Plug the modem into the router's WAN connection using an ethernet cord.
  3. Plug your computer into the router LAN
  4. Turn on the modem, wait for blinking lights to stabilize,
  5. Then turn on the router.

At this point it's very likely that your router gets a public IP address on the WAN side, and provides a 192.168.1.0/24 subnet on the LAN side, and if you restart your computer's networking (or your whole computer, whatever) you'll be all set to go.


#27

Thank you all for your help. I'm back to the beginning but now I think I know what not to do. I did the same thing to a wndr3800 see if I can do the same with that. thanks again!