After factory reset, ssh with root still requires password?

Hi all,

I inherited a TP-LINK router from a friend which supposedly already has openwrt installed on it, including a nice piece of tape on the router with openwrt written in sharpie.

OpenWrt appears in the list of possible networks to connect to,
and I can successfully connect,

but when I visit in the browser it says "unable to connect"

In terminal, when I try ssh root@
it asks for a password,
I've tried entering 'root', 'admin' and just leaving it empty, all are denied.

I was hoping that a factory reset would bring the router all the way back to factory state, where root has no password.

I did the factory reset by holding down the reset button for 10 seconds, and then releasing it,
the LED blinked and the router restarted.

Interestingly, when I tried sshing again, I received a warning that "REMOTE HOST IDENTIFICATION HAS CHANGED!" which made me think the factory reset did in fact work.

I removed the relevant entry from /Users/maxfowler/.ssh/known_hosts to get rid of the error message,
and then tried ssh-ing again,

but then yet again I was met with the password prompt and did not know the password.

Any ideas? any way to a factory reset that will get rid of whatever password was set for root? or another way to login?

Maybe the image flashed on this device had a preconfigured root password.
Failsafe is the other option to reset the pass.


This doesn't do anything. The proper method for resetting is:

My suggestion is find the latest firmware for your device, download it... do the failsafe mode, log in, and flash the newest version without keeping settings. Then you'll KNOW what you've got.


Depending on which TP-Link unit it is, try reflashing using TFTP.