After disabling guest interface a get many dhcp error messages

After disabling my GUEST interface a get many of these messages:

Sat Feb 8 07:46:16 2020 daemon.err odhcpd[1337]: Failed to add proxy neighbour entry 2003:d2:xxxx:df1:c8b7:ee1d:7c6a:b717 on GUEST

Any help would be nice...

My configuration NETWORK :

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd00::/64'

config interface 'LAN'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ipaddr '192.168.2.1'
	option ifname 'eth1'
	option ip6assign '64'
	option dns '192.168.1.100'

config switch
	option name 'switch0'
	option reset '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6'
	option vid '1'

config interface 'WWAN'
	option proto 'static'
	option ipaddr '192.168.1.4'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.100'

config interface 'Pseudobridge'
	option proto 'relay'
	option ipaddr '192.168.1.4'
	list network 'LAN'
	list network 'WWAN'

config interface 'GUEST'
	option proto 'static'
	option ipaddr '192.168.5.1'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ip6assign '64'
	option force_link '0'
	list dns '192.168.1.100'

config interface 'WWAN6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '60'

WIFI:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option distance '8'
	option log_level '3'
	option legacy_rates '0'
	option noscan '1'
	option txpower '23'
	option country 'US'
	option channel 'auto'
	option htmode 'VHT80'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option noscan '1'
	option htmode 'HT40'
	option log_level '4'
	option country 'US'
	option channel '6'
	option txpower '22'

config wifi-iface 'wifinet0'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option key 'ddddddddddddddddddddddddd'
	option ssid 'Fritz_5Ghz'
	option network 'WWAN WWAN6'

config wifi-iface 'wifinet1'
	option ssid 'im6shop'
	option device 'radio1'
	option key 'dddddddddddddddddddddddddddddd'
	option mode 'ap'
	option network 'LAN'
	option disassoc_low_ack '0'
	option macfilter 'allow'
	option encryption 'psk2+ccmp'
	

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'gast'
	option encryption 'psk2'
	option key 'ccccccccccccccc'
	option isolate '1'
	option network 'GUEST'
	option disabled '1'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option network 'LAN'
	option key 'dddddddddddddddddddd'
	option encryption 'psk2'
	option ssid 'im6shop'
       option disabled '1'

Your configuration looks a bit messed up.

It could help if you explain your whole setup, what's the router model, how is it getting Internet and what other network devices are in your setup.

By the way, to included code in your post, highlight the text that's code, then use the Pre-formatted text tool </>.

2 Likes

Thanks for your answer. I am using Archer C7 V2 (AR71xx 19.07.1) as a repeater (releayd). I connect to my master router via 5 Ghz. My clients connect to the archer via 2,4 ghz. In addition i defined a guest network.
When the guest wlan is disabled i get the error mesages:

daemon.err odhcpd[1337]: Failed to add proxy neighbour entry 2003:d2:xxxx:df1:c8b7:ee1d:7c6a:b717 on GUEST

I have found a workaround:
If i restart the dhcp deamon after i disabled the guest interface, the error message disapear. (/etc/init.d/odhcpd restart)