After changing internal IP, Router unavailable

Because of a change of location, I had to change the internal IP-Address of a Linksys 1200 running Openwrt 19. I did it over the webinterface and confirmed the "change unproofed" button. Now it isn´t reachable, neither by ssh nor by Webinterface. I booted into failsafe and checked the configuration files many times without finding any wrong configuration that could lead to that. Anyone any idea what went wrong?

Not without you posting the conf files.

there is lots of possibilitys
has it still got dhcp server on
is the pc getting an address
is it set to static is your pc even in the same subnet

DHCP Server is off, because that will be done from a server behind the router. PC is configured manually to have ip-address in the same range as the router has now. What config-files do you need?
here is /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1f:a779:fa9f::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1 tun0'
        option ipaddr '192.168.122.254'
        list dns '192.168.122.222'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'Vpn0'
 option ifname 'tun0'
        option proto 'none' 

that configuration worked for some years now, the only change was the lan-ip-address and the nameserver-address. Former ip-address was 192.168.178.1 and nameserver was 192.168.178.219.
When I boot normally, I don´t even get a ping.

Version 19 is old and unsupported. We might not be able to reproduce the issue.
What is the output of ip -4 addr; ip -4 ro list table all; ip -4 ru ?

Be sure to get a new IP on the client:
https://openwrt.org/faq/change_lan_ip

1 Like

only thing that look's odd is the DNS addresss on the LAN
as it get's it form WAN & not sending one out via DHCP ?
but it's an old format now it differs from current ones
but shouldn't stop it talking

maybe conflict with WAN or VPN ranges