The Problem is that when i change my network Device (Default is br-lan) to any other created (new with Vlan connection to openwrt Router works without any Problems) i cannot connect to my Wlan's if i use any kind of Encrpytion. I always get the message Wrong Password. It does not matter if it is on a laptop or on a Cell phone. When i put my network Device back to default i can connect without changing my password. I did some research but did not find someone with the same issue. Does anyone experiance the same issue?
Wifi networks can only join bridge interfaces.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option curmode 'router'
config device
option name 'br-lan'
option type 'bridge'
option igmp_snooping '1'
option multicast_to_unicast '0'
list ports 'lan2'
config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.2'
option gateway '192.168.1.254'
list dns '8.8.8.8'
list dns '1.1.1.1'
option device 'br-lan.1'
config interface 'wan'
option device 'wan'
option reqopts '33 43 249'
option vendorid 'dslforum.org'
option proto 'dhcp'
option disabled '0'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option disabled '0'
config interface 'agent'
option proto 'dhcp'
option device 'br-lan'
option disabled '1'
config interface 'wwan'
option proto 'dhcp'
option disabled '1'
config device
option type 'bridge'
option name 'SwtichOffice'
list ports 'lan3'
list ports 'lan4'
config bridge-vlan
option device 'SwtichOffice'
option vlan '1'
list ports 'lan3'
list ports 'lan4'
config bridge-vlan
option device 'SwtichOffice'
option vlan '100'
list ports 'lan3:t'
list ports 'lan4:t'
config bridge-vlan
option device 'SwtichOffice'
option vlan '200'
list ports 'lan3:t'
list ports 'lan4:t'
config bridge-vlan
option device 'SwtichOffice'
option vlan '300'
list ports 'lan3:t'
list ports 'lan4:t'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'lan2'
config bridge-vlan
option device 'br-lan'
option vlan '100'
list ports 'lan2:t'
config bridge-vlan
option device 'br-lan'
option vlan '200'
list ports 'lan2:t'
config bridge-vlan
option device 'br-lan'
option vlan '300'
list ports 'lan2:t'
config interface 'Office'
option proto 'static'
option device 'br-lan.100'
option ipaddr '192.168.100.2'
option netmask '255.255.255.0'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/wmac.1'
option band '2g'
option htmode 'HE20'
option channel 'auto'
option country 'CH'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Triductor_2GAp'
option ifname 'wlan0-ap'
option encryption 'psk2'
option key '12345678'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/wmac.2'
option band '5g'
option htmode 'HE80'
option channel 'auto'
option disabled '0'
option country 'CN'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid 'Triductor_5GAp'
option ifname 'wlan1-ap'
option wps_pushbutton '0'
config wifi-iface 'wlan0_ap_bh'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key '12345678'
option encryption 'psk2'
option ssid 'Tri_Mesh_BH_'
option multi_ap '1'
option wds '1'
option ifname 'wlan0-ap-bh'
option hidden '1'
option wps_pushbutton '0'
option disabled '0'
config wifi-iface 'wlan0_ap_fh'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key '12345678'
option encryption 'psk2'
option ssid 'Tri_Mesh_FH_'
option multi_ap '2'
option wds '1'
option ifname 'wlan0-ap-fh'
option hidden '0'
option wps_pushbutton '0'
option disabled '0'
config wifi-iface 'wlan1_ap_bh'
option device 'radio1'
option network 'lan'
option mode 'ap'
option key '12345678'
option encryption 'psk2'
option ssid 'Tri_Mesh_BH_'
option multi_ap '1'
option wds '1'
option ifname 'wlan1-ap-bh'
option hidden '1'
option wps_pushbutton '0'
option disabled '0'
config wifi-iface 'wlan1_ap_fh'
option device 'radio1'
option network 'lan'
option mode 'ap'
option key '12345678'
option encryption 'psk2'
option ssid 'Tri_Mesh_FH_'
option multi_ap '2'
option wds '1'
option ifname 'wlan1-ap-fh'
option hidden '0'
option wps_pushbutton '1'
option disabled '0'
config wifi-iface 'wlan0_sta_bh'
option disabled '1'
option device 'radio0'
option mode 'sta'
option wds '1'
option network 'lan'
option multi_ap '1'
option default_disabled '1'
option ifname 'wlan0-sta-bh'
option wps_pushbutton '0'
config wifi-iface 'wlan1_sta_bh'
option disabled '1'
option device 'radio1'
option mode 'sta'
option wds '1'
option network 'lan'
option multi_ap '1'
option default_disabled '1'
option ifname 'wlan1-sta-bh'
option wps_pushbutton '0'
config wifi-iface 'repeater'
option device 'radio0'
option network 'wwan'
option mode 'sta'
option ifname 'wlan0-sta-rp'
option disabled '1'
option wps_pushbutton '0'
config wifi-iface 'wifinet9'
option device 'radio0'
option mode 'ap'
option ssid '0018H2'
option key '12345678'
option network 'lan'
option encryption 'sae-mixed'
option wps_pushbutton '1'
config wifi-iface 'wifinet10'
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt2'
option encryption 'psk2'
option key '12345678'
option network 'lan'
config wifi-iface 'wifinet11'
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt3'
option encryption 'sae-mixed'
option key '12345678'
Hi i did so i disable Dhcp and Firewall in the Startup Menu. Made further test.
Connection does not work if Vlan's are involved on the interface. If i remove vlan's it works.
You need to choose your location between Switzerland and China.
it is plain violation of local rules.
Please add dhcp conf wrt br-lan.1
sorry I tested it without DHCP because i have a firewall which is making dhcp. This works as i told when i remove Encryption i have connection. As soon as i put encryption it is always tell me that the password is wrong. As it is a test environment i forgot to put all on ssid to ch. Made it with the same result. And it only happens if VLan devices are involved....
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
!
{
"kernel": "5.10.138",
"hostname": "OpenWrt",
"system": "ARMv7 Processor rev 1 (v7l)",
"model": "THG6500-TAX2",
"board_name": "THG6500-TAX2",
"rootfs_type": "squashfs",
"release": {
"distribution": "TGP",
"version": "3.1.0",
"revision": "r19685-512e76967f",
"target": "tr6560/generic",
"description": "TGP 3.1.0 "
}
}
It appears you are using firmware that is not from the official OpenWrt project.
When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.
You may find that the best options are:
- Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
- Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
- Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).
If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.