After 22.03 Upgrade Transmission not Working

After upgrade transmission torrent client not working. Reinstalled again according to the openwrt transmission wiki guide but still not working. Also there is a weird situation on screenshot.

Where did I go wrong?

I assume you've enabled it in the config file ?


works for me

 7321 root      2160 SN   {transmission} /sbin/ujail -t 5 -n transmission -S /etc/seccomp/transmission-daemon.json -U transmission -G transmission -l -e CURL_CA_BUNDLE -r /etc/ssl/cer
 7331 transmis  3156 SN   /usr/bin/transmission-daemon -f -g /tmp/transmission

root@OpenWrt:/tmp# ls -l /tmp/transmission/
drwxr-xr-x    2 transmis transmis        40 Sep 12 09:47 blocklists
drwxr-xr-x    2 transmis transmis        40 Sep 12 09:47 done
drwxr-xr-x    2 transmis transmis        40 Sep 12 09:47 incomplete
drwxr-xr-x    2 transmis transmis        40 Sep 12 09:47 resume
-rw-r--r--    1 transmis transmis      1827 Sep 12 09:47 settings.json
-rw-r--r--    1 transmis transmis         0 Sep 12 09:47 stats.json
drwxr-xr-x    2 transmis transmis        40 Sep 12 09:47 torrents

root@OpenWrt:/tmp# service transmission status
root@OpenWrt:/tmp# service
/etc/init.d/transmission           enabled         running
1 Like

I've got fresh install 22.03 and problem solved.

A fresh install of 22.03 did not fix the issue for me. By commenting out the jail_mount lines in the init.d/transmission as discussed in the thread below it is now working but this is not a long term solution.

1 Like

Sadly, commenting jail doesn't work for me. Even that Transmission will run, it crashes when trying to download anything.

Same problem started to happen to me.

I need to correct myself. Commenting from the init file working. It didn't work initially but I forget to comment seccomp as well. Refer to below:

Hello partners! Excuse my bad English, I updated to the same version of openwrt that they mention and the download program does not work. I get the following result

403: Forbidden
Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

I upgraded 22.03.3. Transmission not working again. Same problem at first message but this time I couldn't find a solution.