AFP Netatalk share permission issue

Hi, i am desperately trying to find a solution for my permission problem with netatalk and latest snapshot release of OpenWrt for my Archer C7 V4 EU model. I have followed this guide (and previous this one as well) trying to make Time Machine backups available for my mac but with no luck. I can see the disk in Time Machine settings, but when i select the disk and enter the password i always get the same error:

10

and this is the line from the afpd log:

Apr 07 18:34:54.748971 cnid_metad[1880] {cnid_metad.c:509} (note:AFPDaemon): CNID Server listening on localhost:4700
Apr 07 18:34:54.771559 afpd[1879] {afp_config.c:198} (note:AFPDaemon): Netatalk AFP/TCP listening on 10.0.10.2:548
Apr 07 18:35:45.393788 afpd[1889] {auth.c:235} (note:AFPDaemon): Login by jurijs (AFP3.4)
Apr 07 18:35:45.401714 afpd[1889] {netatalk_conf.c:1502} (error:AFPDaemon): load_volumes: getpwuid_r: Permission denied
Apr 07 18:35:45.405536 afpd[1889] {netatalk_conf.c:1502} (error:AFPDaemon): load_volumes: getpwuid_r: Permission denied
Apr 07 18:35:45.408407 afpd[1889] {auth.c:804} (note:AFPDaemon): AFP logout by jurijs
Apr 07 18:35:45.413359 afpd[1889] {dsi_stream.c:504} (error:DSI): dsi_stream_read: len:0, unexpected EOF
Apr 07 18:35:45.413706 afpd[1889] {afp_dsi.c:517} (note:AFPDaemon): afp_over_dsi: client logged out, terminating DSI s           $
Apr 07 18:35:45.414223 afpd[1889] {afp_dsi.c:108} (note:AFPDaemon): AFP statistics: 0.60 KB read, 0.44 KB written

All my settings and permissions are exactly the same as in the guide above, all the packages are installed as there as well but it still doesn't work. Does anyone has any idea on how to get this working? Thanks in advance.

I think the issue is caused by file permission

chmod 775 /path/to/volume

and restart afpd

service afpd restart

if the problem continues, check the path in your /etc/afp.conf, or check your mount config.