Afoundry EW1200

Hi all. EW1200 user here.

I'm reading a lot about how to change firmware, because I need to restart several times per day my router. I'm getting really mad with this.

So I have a couple of questions.

With 5.4 firmware, I can telnet the router, but no user/password is valid here. I tried factory defaults even. But seems this doesn't work. Server are waiting for my username and password, but everything is 'Login Incorrect'.

I tried to download settings from router. It's a bin file. No idea how to open it so I tried with my code editor.
There is text inside, but nothing similar to telnet.cfg... So, not sure if i'm doing this well.

Is there a 'secret' key for telnet? Need I to change config file? adding a line if it's not present? I really like to try @Blotto's way, instead of open my router...

Router logs says:
Oct 27 11:32:39 Router auth.warn login[2193]: invalid password for 'admin' on 'pts/0'"

Any help is welcome! Thank you!!

Hi guys.
I finally managed to make it work.
The reason why I wasn't getting access to 192.168.1.1 was that I forgot to change back the /etc/config/network parameters to 'Static' // 192.168.1.1 as I had changed them to "DHCP" in order to receive internet from my ISP router.
After changing that and started the web interface:
/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

I've been using it for 2 days and I have similar disassociation issues like k1ll3ry0.
Will probably try to get a refund.

What would be your best advice / choice on a similar powerful router nowadays?

I'm looking at Asus RT-AC88U or it's DSL modem counterpart DSL-AC88U.

Take a look at Ubiquiti. For the cost, you simply cannot beat the performance. I'm not sure if you have a separate server or router but I would greatly recommend the Ubiquiti AP AC PRO. Link: https://www.ubnt.com/unifi/unifi-ap-ac-pro/ You can either run it as an independent access point and configure it through your PC using the Ubiquiti Controller or you could get a USG which would act as the Controller for the AP. USG link here: https://www.ubnt.com/unifi-routing/usg/

I have a separate server running as a full network VPN tunnel. Every packet goes through the tunnel which is nice because it only utilizes a single client on my VPN network. The OPNsense server also handles DHCP and all other routing/firewall needs so I only needed a "Dumb AP" to distribute to my wireless devices. I HIGHLY RECOMMEND UBIQUITI. It's as set and forget as you can get...Never any network issues in the 2 months I have had it.

what about the UAP‑AC‑HD with 802.11ac Wave 2 4x4 MU-MIMO?

For standard home applications, the PRO will more than suffice as it's rated for roughly 200 users. You're looking at a massive increase in price range for something that you probably will not need. Roughly $130 vs $300 if priced through amazon. The range is fantastic, speeds are wonderful and the way they manage 2.4Ghz and 5Ghz ranges, single SSID and it differentiates between what it thinks you need in terms of speed. Pretty neat stuff. Stay away from anything less than the PRO though they are meant to be used in a mesh throughout the household where a PRO handles the entire 1st and 2nd floor of my house from edge to edge and some ways down the driveway. I have mine mounted to the ceiling with lines running through the attic and the downward pointing of the AP covers the entire living space. However, it will only perform as well as the service you provide for it. I have Gbit internet and I can sustain 400Mbps on the first floor to my Nexus 6P and Macbook Pro.

1 Like

I’ve been using it for a few days and I have similar disassociation issues like k1ll3ry0 and At0mx.

But I found out the following:
The transmission power is completely sufficient, but once I had an interruption in the upper floor of my apartment, a renewed authentication fails.
Only when I go back near my router, the connection is immediately restored and I can move away from him again.
It's as if the settings like distance, RTS threshold and fragmentation threshold have no effect. Compared to the original firmware, the effective distance to the router has been reduced from about 500m to 30m, but the field strength is consistently great. I tried it with 10mW up to 100mW, but it had no effect on the effective distance to the router.
Is there another, better driver for the wifi module or the WPA / WPA2 negotiation? Or is it possible to extend the runtime limit with other unknown parameters?
If not, someone has the original firmware from the router?

Same issue here.

I have the stock firmware (1.7.2) but how can I install it?
Download: https://www.dropbox.com/s/rpxoeufj6ufw5lh/mt7621_ew1200en_1.7.2.tar.gz?dl=0

From the factory web GUI: System-->Management-->Backup Button
This will export a file called farm_config.tar
Save this to your hard drive and untar it. It will barf out a collection of all
of your config files. cd to /config/tui/ and you'll see telnet.cfg
Edit telnet.cfg with a text editor (change "disable" to "enabled"), save,
create a new tarball and restore from the same web admin page you downloaded from,
reboot, and you should be good to go. Nmap before & after to see if telnet is open after
reboot. Those are the steps that worked for me.

Sorry, I think my question was not clear.
The question is: how can I revert to the stock firmware? LEDE is currently installed. See https://forum.openwrt.org/t/afoundry-ew1200-revert-to-stock-firmware/11063 for more information.

Hi Fiber Monkey,
thank you for your stock firmware, but unfortunately, I could not use your file.
But I found another file "EW1200_Afoundry_EN.upgrade" (just do not know where it was).
I simply flashed this file via the LUCI web page of the LEDE OpenWRT interface. I gave the router a few minutes (> 5min) to flash and after a restart I could not access the router anymore.
Then I pressed the reset button for about> 5 seconds and after another restart it was found under its default IP: 192.168.2.1 with the default user: admin and Password: 88888888
Now I am satisfied with this router again.
sorry for my bad english
See: EW1200_Afoundry

If you extract the archive, you will find file ‘mt7621_s1200en_1.7.2.upgrade’ :-).

OK, but is this newer than mine?
and is this compatible?
grafik

That's a good question. I think you hardware model is newer than mine.

Hi, mine is bricked too.I've followed your steps but the terminal keeps blank, also after entering the credentials...

Do you have other suggestions?

Thanks you in advance.

  • FIberMonkey

Hi, really sorry to zombie this post, i hope this doesn't bother anyone. Is there anyone here still having the original 5.4 firmare that could upload somewhere to help me? Tried to find it everywhere (i found an old version on a french forum, if someone is interested), but to no avail.
Thank you guys

1 Like

Hello, have you found the firmware?
I'm loosing any hope....

Hi, i actually found one, but unfortunately it doesn't seem to be the 5.4 fw version. It reports the version 0.1.8. Still it works, maybe you can find it useful, so i uploaded on a free hosting service. Here it is:

Still looking for the latest 5.4, so if anyone having it is reading this post, it would be sooooo nice to have it uploaded anywhere...

1 Like

Thank you! Better than nothing. Still searching for a most recent version, but it's hard.Thanks again.

Hi, could you confirm that for you is the 0.1.8 version? After install, for me is the 0.1.4.
Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.