Afoundry AF-EW1200 - Flash nightmare any help


I wonder if anyone can help I have an Afoundry AF-EW1200, I flashed the openwrt-18.06.1-ramips-mt7621-ew1200-initramfs-kernel.bin and I have now is for a few brief few seconds top left of browser is LuCI - Lua Configuration Interface then disappears to blank browser tried a few different browsers and no joy going by the LED’s it looks like it's booting up and windows 7 to any LAN port shows the new IP address the original default of the router was

I’ve tried resetting the router and deleted the cache no joy I am quite new to this so don’t get too technical, the one good thing is I have a second router same model working on the original firmware, simple is there an easy way to copy the working routers configuration files over to the faulty one.

I was told plug the USB on the router to windows and FTP the files over but windows does not show anything connected all that happens is the USB light comes on the router.

Many thanks

Looks to me like a problem with the web interface.
First verify the device is functional
From windows start a CMD and type there
If you get a few replies, go ahead and login to the device by telnet. On the same CMD type
That should log you into the router and you'll be able to troubleshoot better.
For example I'd check if web server is up ps w | grep http and if not I'd restart it with
/etc/init.d/uhttpd restart
Paste here any errors or mistakes you might come across.

The initramfs-kernel should not be installed in flash, it is for development use to run from RAM. You should have flashed the sysupgrade.bin. (Models that don't have a factory.bin should take the sysupgrade format from the factory firmware.)

Try ssh to but likely you are only interacting with the bootloader.

Tread carefully!! I found the below in the git commit notes :

Firmware update page on the stock web interface can not accept sysupgrade images, it bricks the device.
At this point, the only working solution I found was to connect to the serial console port (available on J4 header) and to use opkg to install
Then scp the sysupgrade file in the device's /tmp and run sysupgrade from console without preserving configuration files.

It looks like support for that device has only been added very recently, and may still have a few bugs .. (or there may even exist more that one hardware version of the device too)


I was told plug the USB on the router to windows and FTP the files over

Who told you to do that? What other info did they provide for installing openwrt??

You're definitely going to need serial console now. Recovery should be straightforward if the bootloader lets you TFTP files into the router. Then you can either boot the initrd OpenWrt in RAM and run sysupgrade on it, or write the sysupgrade OpenWrt directly to flash.

Thanks to everyone I will have to take it one by one



Pinging with 32 bytes of data:

Reply from bytes=32 time<1ms TTL=64

Reply from bytes=32 time<1ms TTL=64

Reply from bytes=32 time<1ms TTL=64

Reply from bytes=32 time<1ms TTL=64

Ping statistics for

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms



'telnet' is not recognized as an internal or external command,

operable program or batch file.

OK the above will have to be translated into English, I have taken on board that I flashed the wrong one to start I should of used (openwrt-18.06.1-ramips-mt7621-ew1200-squashfs-sysupgrade.bin).

Please tell me more I like this router don’t want to give up just yet, I do appreciate all you're help.

Neither Telnet or SSH come with Windows. You can use several third-party programs. Popular free programs include Putty and Tera Term.

OpenWrt no longer includes Telnet access, though your bootloader may have it (That would be model-specific, and I have no experience with that model). Also try Telnet on port 9000.

OK let me look and down load this first, thanks

I just loaded putty:

login as: root

BusyBox v1.30.0 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r8978-eb1887b
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
root@OpenWrt:~# login as: root

You're lucky to have a working router. Check the other steps I mentioned earlier whether the web server is running.

Is this correct i done:

root@OpenWrt:~# ps w | grep http
 1542 root      1200 S    grep http
root@OpenWrt:~# /etc/init.d/uhttpd restart
-ash: /etc/init.d/uhttpd: not found

Sorry this is all new to me and to say I’m lost would be an understatement, i appreciate you're patience

If you can SSH to router, then I'd recommend to do the sysupgrade from there. Most of the problems will go away after a proper image upgrade. Use WinSCP to transfer files to router /tmp and do sysupgrade from there.
Also you're using Snapshot builds, AFAIK there's no built-in LuCI in there. You need to separately download it after flashing.

1 Like

I have FTP Voyager I take it that will do, but it don’t login, not sure what you mean by /tmp I’m sorry but I may need a step by step I 2 3.

I'm going up the wooden hill now, I will be back tomorrow thank you all again.

Yes it is correct and it looks like there is no web server running on your router.
Since the device is operational, you may connect to the router and upload the correct image.
Download it on your desktop first. Also download the WinSCP client. It is free and has option for scp to login and transfer files to your router.
Fire up WinSCP and connect to, protocol SCP, user root and whatever password you have assigned. On the right pane double click the .. to go up one directory and enter tmp. Then send the sysupgrade image from your desktop.
After it is uploaded, run the command sysupgrade -v /tmp/filename-of-downloaded-sysupgrade.bin to start the upgrade procedure.

Sorry this is all new to me and to say I’m lost would be an understatement, i appreciate you're patience

Don't worry, we've all been there in our first steps :blush:

1 Like

Is there a release build for that model?

You need WinSCP because you will need to login through SCP protocol from there. As you have no password right now, you'll only need username which is root.
Login to WinSCP and switch the directory to /tmp on the router from within WinSCP. Then drag n drop the firmware file to that directory and after that login to putty such as you did before and run command sysupgrade /tmp/upgrade-file.bin and it should upgrade your router.
Note: upgrade-file.bin will be the actual name of tbe file whatever you name it but keep it short.

Yes openwrt-18.06.1-ramips-mt7621-ew1200-squashfs-sysupgrade.bin the one i should of used in the first place

Well I followed ahmar16 instruction to the letter and it was done within 8 minutes absolutely fantastic, I don’t know how to thank you all I really appreciate all you're help and patience, it's nice to find a friendly forum some can be what I call a closed community a bit like when a cowboy walks into a saloon and it all goes quite.:grinning:!

So I don’t mess up again if I ever needed to go back to stock firmware (unlikely) just do a normal upgrade or is that a no.