Aerohive ap121 cannot get networked

This is a new install on a aerohive ap121. I flashed the device correctly and it's up and running but i can't hit the default ip address, 192.168.1.1/24.

With DEBUG enabled i get the following error when the interface comes up. I really hope this error is related to the problem and someone can help me figure this out. I ran out of things to test.

[   49.224806] NET: Registered protocol family 24
[   49.342848] ieee80211 phy0: Atheros AR9340 Rev:2 mem=0xb8100000, irq=47
[   49.422198] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   49.510882] ieee80211 phy1: Atheros AR9300 Rev:3 mem=0xb0000000, irq=40
[   49.879068] kmodloader: done loading kernel modules from /etc/modules.d/*
[   61.149787] eth0: link up (1000Mbps/Full duplex)
[   61.206615] br-lan: port 1(eth0) entered blocking state
[   61.269137] br-lan: port 1(eth0) entered disabled state
[   61.332040] device eth0 entered promiscuous mode
cat: can't open '/sys/devices/virtual/ieee80211/phy*/name': No such file or directory
sh: add: unknown operand
sh: add: unknown operand
[   61.769606] br-lan: port 1(eth0) entered blocking state
[   61.832115] br-lan: port 1(eth0) entered forwarding state
[   61.896863] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   62.209078] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
udhcpc: started, v1.28.3
udhcpc: sending discover
udhcpc: no lease, failing
 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd11:d21a:4483::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

From localhost I can ping the loopback and itself on 192.168.1.1.

The laptop is at 192.168.1.33/24 and both device are connected to an unmanaged switch.

Aerohive can't ping the laptop either.

If i reseat the cable the link down and up is detected just fine.

I tried
Setting static address
Adding a wan interface virtual interface
Removing the bridge interface and making it a plain ethernet interface
Downgrading firmware to 18.06.0

Version flashed to device
openwrt-18.06.1-ar71xx-nand-hiveap-121-squashfs-factory.bin

Device model
HiveAP 121

interfaces with a clean install

root@OpenWrt:/# ifconfig 
br-lan    Link encap:Ethernet  HWaddr 40:18:B1:6D:BB:C0  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::4218:b1ff:fe6d:bbc0/64 Scope:Link
          inet6 addr: fd11:d21a:4483::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:154 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:17149 (16.7 KiB)  TX bytes:2004 (1.9 KiB)

eth0      Link encap:Ethernet  HWaddr 40:18:B1:6D:BB:C0  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:163 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20405 (19.9 KiB)  TX bytes:2262 (2.2 KiB)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:1564 (1.5 KiB)  TX bytes:1564 (1.5 KiB)
root@OpenWrt:/# ifdown lan
[  611.873540] br-lan: port 1(eth0) entered disabled state
[  612.070338] device eth0 left promiscuous mode
[  612.122511] br-lan: port 1(eth0) entered disabled state
[  612.259606] eth0: link down
[  612.317395] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
root@OpenWrt:/# cat: can't open '/sys/devices/virtual/ieee80211/phy*/name': No such file or directory
sh: remove: unknown operand
sh: remove: unknown operand

root@OpenWrt:/# ifup lan
[  620.022862] br-lan: port 1(eth0) entered blocking state
[  620.085396] br-lan: port 1(eth0) entered disabled state
[  620.148272] device eth0 entered promiscuous mode
cat: can't open [  620.308723] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
'/sys/devices/virtual/ieee80211/phy*/name': No such file or directory
sh: add: unknown operand
sh: add: unknown operand
'radio0' is disabled
'radio0' is disabled
'radio1' is disabled
'radio1' is disabled
root@OpenWrt:/# 
root@OpenWrt:/# [  623.128096] eth0: link up (1000Mbps/Full duplex)
[  623.183508] br-lan: port 1(eth0) entered blocking state
[  623.246037] br-lan: port 1(eth0) entered forwarding state
[  623.312359] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

The br-lan interface looks is sending and receiving packets.
Maybe the laptop has firewall blocking the pings from the Openwrt?
Can you see something in arp ?
Does the laptop acquire IP and other settings from Openwrt via DHCP?
Keep in mind that when you upgrade-downgrade from Openwrt, you must use the sysupgrade version of the image, not the factory, which is used to change from the factory firmware to Openwrt.

Yes your are correct the br-lan interface is receiving and sending traffic. Also arp is showing the laptops mac address. So it appears that thing are connected but not completely/correctly configured.

I solved the issue by enabling the radio0 interface in /etc/config/wireless by changing option disabled '1'
to option disabled '0' and running "ifup lan"

This enabled the wifi radio. At this point the SSID became available, so i connected to it got an ip and was able to hit the we page.

Thank for your help trendy..

1 Like

Now that i can access the Web UI over the wifi network, "LAN", I assumed things were all fixed up, but unfortunately the original problem remains, I cannot get eth0, "WAN", networked.

Traffic is flowing through the interface, as trendy pointed out before, but the interface isn't hitting , even with the firewall disabled.
I tried setting static address and DHCP on the interface. DHCP worked fine in UBOOT.

Is there something i'm missing in the setup process?

udhcpc: started, v1.28.3
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: no lease, failing

From my understanding this device has only one ethernet port, eth0 which is bridged with the wifi under the br-lan interface.
The WAN interface you mentioned is bound on what physical interface? There is no reference in the configs you posted earlier.

Since bringing up the UI i've changed the network config. This is the new config. I've bound the only physical interface, eth0, to the wan interface as eth0 and the lan bridge interface is bound to virtual interface eth0.1


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd76:0670:a687::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ipv6 '1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option ipv6 '1'

I was able to get wan interface working, however very unstable. pings are failing very frequently. This is most like the source issue that led me to believe the interface config is not working.

1377 packets transmitted, 90 received, +153 errors, 93% packet loss, time 1409020ms

I don't see any errors on the interface

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:957582 errors:0 dropped:4131 overruns:0 frame:0
          TX packets:28230 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:132121088 (126.0 MiB)  TX bytes:8984382 (8.5 MiB)
          Interrupt:4 

Have you connected the Ethernet port to some vlan-aware switch? I don't think the wan provider will appreciate you sending him vlan tagged frames.

Hi guys, in the new version of OpenWRT, only dhcpv6 is installed by default, you need to install the standard dhcpd or select this package when building the firmware from source codes and restart dnsmasq.

helped me /etc/init.d/dnsmasq restart

den4ik, yes this was an initial problem that we resolved like you said, by starting dnsmasq.

trendy, I've removed the vlan on the lan interface, as you are correct, this is not required.

I realized something that may help in troubleshooting.. If i disable the wan interface on my laptop, i can ping consistently to the wan interface on the AP, this of course is going through the wireless bridge on the AP.

Not sure how helpful this is because i still don't have internet on the wan interface. Maybe it proves that the wan interface is working as expected and this is more of a routing issue.

Am i off base here and just don't understand how an AP works? I thought the WAN interface, eth0, should be able to get an IP, via dhcp, and nat this out to wifi0 and wifi1.

What is your intended use? It sounds like you have an Ethernet network with a path to the Internet, and you want this device to serve wifi users by either bridging or routing them into the Ethernet network. Those are called a dumb AP and a routed AP respectively.

The dumb AP is as you might expect, the simplest to set up. It does not do any NAT or DHCP assignments. When a wifi user connects, his DHCP request is passed out the Ethernet cable and handled by the main router on the network. There is only one network in a dumb AP, the default LAN network.

The LAN interface needs to have an IP address to log in to the router, but only for administration. The LAN IP is not involved in communication between the wireless users and the main network. This IP needs to be in the main network, but not conflicting with anything else. It can be configured statically or as a DHCP client.


The routed AP has two networks lan and wan. This is the same as the default configuration of a typical desktop router except that due to the limited hardware, there are no Ethernet ports on the LAN. All access to the LAN either by users or for administration must be via wifi. The single Ethernet port which is the wan network is connected to the "backhaul" network to provide Internet access. It is usually a DHCP client but can also be statically configured. It is essential that the WAN IP not be in the same range as the LAN IP.

The default /etc/config/firewall even on a single Ethernet port device contains standard rules to forward and NAT between two networks named lan and wan. The forwarding is one way, from lan to wan. Incoming connections on the WAN are blocked by default. If you want to log into the routed AP from the wan (Ethernet) side, you need to open ports in the firewall.

1 Like

As @mk24 suggested, there are a couple of ways to operate this device of yours. Let us know which scenario are you using and we'll see what needs to be fixed.

Makes perfect sense why things are not working, thanks.

i just want to get things working in a Dumb AP config, with no vlans. AP gets it's own IP from DHCP and has no DHCP server, my router will give out client addresses.

After I get to this point I tackle the below...

This is for a home network with iot stuff, so I want trusted and untrusted networks. I have a firewall, juniper srx with Poe ports, that I want to handle DHCP for separate vlans. The fw port the AP is connected to will serve dhpc for both vlans so hopefully the tagged traffic will get it's correct address and will pass through the correct fw chain.

all of this is not my forte and have a good jist of what I think I need to do and figuring it out as I go along.

Reset to a stock configuration.
Connect router to your PC only and log in.
Configure and enable a wifi AP on the LAN network
Edit the LAN network interface--

  • Change protocol to DHCP (client). Set a hostname.
  • Disable DHCP server (both v4 and v6)

Apply these changes then plug it into your firewall network. The firewall DHCP server should have granted an IP. Wifi clients should be able to connect. You now have a single network dumb AP.

To add another network, make a new network bridge interface with proto None. Make a new wifi AP and attach it to that interface. Edit the physical settings of both the lan and the new network to connect each one to one VLAN on the Ethernet cable (eth0.1 and eth0.2 for example). Configure the firewall with matching VLANs.

1 Like

That worked all to easily. That's for helping me with understanding how I'm supposed to connect everything. When I have my final config ill post it here for others.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.