Ads blocking without Adguard Home?

Hi openwrtians! Newbie for this router platform...sorry.

Successfully flashed, installed and working now. Due to low storage (10MB), I could only install adblock (with luci-app-adblock) and simple adblock. But it seems not working well, I guess the SmartDNS using 8.8.8.8 and 1.1.1.1 is one of the reason. But either running it or not, the adblock still not working as what the 3rd party should be.
Any help? Thanks in advance.

Product: Lenovo Newifi Y1 (CPU:MediaTek MT7620A)
Storage: 10MB (50MB tempfs)
Openwrt: https://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-lenovo_newifi-y1-squashfs-sysupgrade.bin

If I have to use Putty or Winscp, could you help to listout the code? Thanks! XD

In what way?
Where does smartdns come into the picture?

How would that be ?

There are several packages that can do adblocking. Adguard is one of the most popular.

Anyway, If you want ads blocking without installing a particular package due low free flash space, you can download one of the known ad sites list (like 300KB or so), and declare it as an additional host file for your DNS service.

Thanks! I gotta compiled list from opendns, but how to do with it? :smiley:

I don't know....I thought blocking ads relying on the "blocker's dns server"? But I used a SmartDNS (for testing use), I scared it will be crashed...

Sorry ye, not sure is the logic correct..? :flushed:

It does.

If you mean the commercial service, it's not very likely.

Both adblock or simple adblock should do what you want, but you also have to make sure your clients actually use your dns.

I also use adblock with warp+ no issue, working well

Make sure blocked domain show number, if 0 press reload

This is the nslookup result

I guess the client side did connect to the correct dns, cuz using openwrt.lan...?
did I misinterpret what it means?

Yup. It show blocked domains, around 11k. But the advertisement from adclick.g.doubleclick.net not working. I tested yahoo.com using ignotico mode. Still showing up the ads from google...sigh....

then you've only done half the job.

Thanks for the reply, not really understand. The part of undone is?

checked the link provided ?

After I disabled the SmartDNS, I think the AdBlock works, I add some additional list for it.
image

And it somehow works.

BTW what link provided? The list link?

shouldn't use * in a hosts file, but perhaps Linux doesn't care ...

the one I posted 1h ago ?

you can still use SmartDNS, but need to keep the routers' DNS in between the service and the clients.

Done amendment.

Yup.

I changed it to another way, 1st router (using DNS forward), 2nd router (This one, with openwrt, using adblock), and to client. Still working.
My SmartDNS using these servers:


Once I enabled, the Adblock not working good. I have to disabled it. :sob:

This has nothing to do with your upstream DNSes.

Define "not working good", I'm tired of guessing.

After tested, the Adblock only work without enabling the SmartDNS. And it worked what I expected.

Some of the ads are blocked, but Google ads still working.

In case you don't want to install any package, you can grab a list of ad domains to block (for instance this one), open it and check it points all those domains to the IP address 0.0.0.0, like
imagen

Copy that file to your router's flash (with WinSCP if you're doing this from your PC/laptop) or RAM (i.e. /tmp if you're doing this with an script), and add it as an additional hosts file for your DNS service:

Save and apply. Test it trying to ping one of the blocked domains. Done.

1 Like

Thanks mate!!!

After you choose and figure out one of the several options we have proposed, you can tag the related post as "Solution", for quick reference to future readers.