Adguard Home static, dynamic ip

I didnt assigne a static ip for Adguatd Home.
Novh I cant reach it over the web interface.
A static ip wasn assigned but the Port was Changed, I know the Port but the ip isnt reachable.

Cane anybody help me out what I can do?

Thanks in advance

AGH doesn't need an IP by itself, it'd be the device it's running on, that would need it ?
Did you check the DHCP ?

But AGH asks for the port a the star and shows you on what ips with port ist running. I neeed to get in the adguard interface angain, to adjust thing. Its running on my openwrt Router.

I dont know what do you mean wirh DHCP. Can you explain?

I just testet if it blocking ads and it isnt. Enable in luci startup AGH and tried again. Still the ads are not blocked. Can it be that it isnt even running?

A port for what?

Then check the settings, or do a netstat via ssh, see what port its listening to.

How could we know, we know zero about your setup ...

A Prot for web interface and DNS.
I know the Port it listens because I set it.
I did netstat and cant see anywhere AGH.

What do you need for infos to help me?

Yes the error is in front of the pc, I am new to this.

Services via ssh delivers AGH disabled, stopped.

I assume you mean PORT, not PROT(ocol) ?

if it's disabled, you need to enable it 1st, then start it.

Yes i meant port. I enabled it and now a services it enabled but stopped. Why, what do I need to chang so it starts at reboot?

If you enable a service it means it starts automatically on boot.
If the service is stopped, you need to start it.

I tried, rebooted and it is still on stoppe.
Wrote service adguardhome start and it is still stopped.

What can I do?

fix the reason to why it refuses to start ...

1 Like

It would be a good idea to look at the logs for hints why it is not starting.

1 Like

I tried to install Adguard, but then addresses such as local domains to the router and etc. stopped working. Is there a way to solve this?

Can you telle me where I can finde them and can i show you, so you can help me out?

Don't replace dnsmasq with AGH, use it as an upstream DNS resolver to dnsmasq.


they're usually located in /tmp

both the opkg and manual installs are discussed on this thread. It also links to the wiki for other discussions.

Currently openwrt's opkg version has a flaw and will not install in jailed chroots. Thus you should use the manual /opt version till openwrt fixes the opkg version.

Thanks fixed it

same problem, same fix

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.